disable package that can't build on atheros target (no pci/usb)
authorNicolas Thill <nico@openwrt.org>
Mon, 17 Sep 2007 02:04:38 +0000 (02:04 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 17 Sep 2007 02:04:38 +0000 (02:04 +0000)
SVN-Revision: 8823

package/kernel/modules/other.mk
package/rt2x00/Makefile

index 8644d89ce28fbcbf1fba49d7948ba6317209b1c6..9b5bc6d46799be82e28c359146c5f9cc97998e57 100644 (file)
@@ -92,9 +92,11 @@ endef
 $(eval $(call KernelPackage,lp))
 
 
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
 define KernelPackage/soundcore
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Sound support
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT @!TARGET_atheros
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -238,10 +240,11 @@ endef
 $(eval $(call KernelPackage,pcmcia-serial))
 
 
+# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT
+  DEPENDS:=@USB_SUPPORT @!TARGET_atheros
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \
index a6c7e5c86b41b2462a72970ac799e2b874932371..71cd418be8f5a1c0a0e3d93ed98823e83e1ed4d8 100644 (file)
@@ -25,10 +25,11 @@ ifeq ($(DUMP),)
   include $(LINUX_DIR)/.config
 endif
 
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
 define KernelPackage/rt2x00/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Ralink Drivers for RT2x00 cards
-  DEPENDS:=@LINUX_2_6
+  DEPENDS:=@LINUX_2_6 @!TARGET_atheros
   KCONFIG:=CONFIG_MAC80211
 endef