kernel: fix dwc3 symbols
authorJohn Crispin <john@openwrt.org>
Sat, 4 Apr 2015 05:20:34 +0000 (05:20 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 4 Apr 2015 05:20:34 +0000 (05:20 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45268

package/kernel/linux/modules/usb.mk

index 46cd382aeda3b396364b53e2bc738ce55be22b85..95ccb8422b7491bbbe4183a1dcf4965e1176bb51 100644 (file)
@@ -497,6 +497,9 @@ define KernelPackage/usb-dwc3
   TITLE:=DWC3 USB controller driver
   KCONFIG:= \
        CONFIG_USB_DWC3 \
+       CONFIG_USB_DWC3_HOST=y \
+       CONFIG_USB_DWC3_GADGET=n \
+       CONFIG_USB_DWC3_DUAL_ROLE=n \
        CONFIG_USB_DWC3_DEBUG=n \
        CONFIG_USB_DWC3_VERBOSE=n
   FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3.ko