uboot-envtools: disable AES support, reduces code size
authorFelix Fietkau <nbd@openwrt.org>
Wed, 6 May 2015 00:59:28 +0000 (00:59 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 6 May 2015 00:59:28 +0000 (00:59 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45615

package/boot/uboot-envtools/patches/200-fw_env_no_aes.patch [new file with mode: 0644]
package/boot/uboot-envtools/patches/300-support-env-in-ubivol-chardev.patch

diff --git a/package/boot/uboot-envtools/patches/200-fw_env_no_aes.patch b/package/boot/uboot-envtools/patches/200-fw_env_no_aes.patch
new file mode 100644 (file)
index 0000000..05fd3c7
--- /dev/null
@@ -0,0 +1,38 @@
+--- a/tools/env/fw_env.c
++++ b/tools/env/fw_env.c
+@@ -245,7 +245,7 @@ int fw_printenv (int argc, char *argv[])
+       int i, n_flag;
+       int rc = 0;
+-      if (argc >= 2 && strcmp(argv[1], "-a") == 0) {
++      if (0 && argc >= 2 && strcmp(argv[1], "-a") == 0) {
+               if (argc < 3) {
+                       fprintf(stderr,
+                               "## Error: '-a' option requires AES key\n");
+@@ -324,7 +324,7 @@ int fw_printenv (int argc, char *argv[])
+ int fw_env_close(void)
+ {
+       int ret;
+-      if (aes_flag) {
++      if (0 && aes_flag) {
+               ret = env_aes_cbc_crypt(environment.data, 1);
+               if (ret) {
+                       fprintf(stderr,
+@@ -1222,7 +1222,7 @@ int fw_env_open(void)
+       crc0 = crc32 (0, (uint8_t *) environment.data, ENV_SIZE);
+-      if (aes_flag) {
++      if (0 && aes_flag) {
+               ret = env_aes_cbc_crypt(environment.data, 0);
+               if (ret)
+                       return ret;
+@@ -1279,7 +1279,7 @@ int fw_env_open(void)
+               crc1 = crc32 (0, (uint8_t *) redundant->data, ENV_SIZE);
+-              if (aes_flag) {
++              if (0 && aes_flag) {
+                       ret = env_aes_cbc_crypt(redundant->data, 0);
+                       if (ret)
+                               return ret;
index 05ec74ae68f081ecae9c9377dd82e5b8fdcb48b3..b778e8a1bac29b4ecdfb2a91a99358200729f557 100644 (file)
@@ -11,13 +11,15 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/tools/env/Makefile
 +++ b/tools/env/Makefile
-@@ -24,6 +24,11 @@ ifeq ($(MTD_VERSION),old)
+@@ -24,6 +24,13 @@ ifeq ($(MTD_VERSION),old)
  HOST_EXTRACFLAGS += -DMTD_OLD
  endif
  
 +ifeq ($(UBI),y)
 +HOST_EXTRACFLAGS += -DUBI
 +HOST_LOADLIBES = "-Wl,--gc-sections,-lubi-utils"
++else
++HOST_LOADLIBES = "-Wl,--gc-sections"
 +endif
 +
  always := fw_printenv