ramips: mt7621: Add new device AsiaRF AP7621-NV1
authorDaniel Danzberger <daniel@dd-wrt.com>
Mon, 22 Jul 2019 10:54:06 +0000 (12:54 +0200)
committerPetr Štetiar <ynezz@true.cz>
Fri, 20 Sep 2019 09:36:27 +0000 (11:36 +0200)
SoC:    Mediatek MT7621A
CPU:    4x 880Mhz
Cache:  32 KB I-Cache and 32 KB D-Cach
        256 KB L2 Cache (shared by Dual-Core)
RAM:    DDR3 512MB 16bits BUS
FLASH:  16MB
Switch: Mediatek Gigabit Switch (2 x LAN, 1 x WAN)
POE:    (1x PD, 2x PSE)
USB:    1x 3.0
PCI:    3x Mini PCIe (3 USB2.0 + 2 x UIM interface)
GPS:    Quectel L70B
SIM:    2 Slots
BTN:    Reset
LED:    - Power
        - Ethernet
        - Wifi
        - USB
UART:  UART is present as Pads with throughholes on the PCB.
       They are located on left side.
       3.3V - RX - GND - TX / 57600-8N1
       3.3V is the square pad

Installation
------------
The stock image is a modified openwrt and can be overflashed via sysupgrade -F

Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
[merge conflict in mt7621.mk]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/mt7621_asiarf_ap7621-001.dts
target/linux/ramips/dts/mt7621_asiarf_ap7621-nv1.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_asiarf_ap7621.dtsi [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index 7fc7717ba4af731fd04aaaf050a6876836176b85..7ab5653d09ecd2ef7c1019cd304b868ce041f706 100755 (executable)
@@ -226,6 +226,9 @@ ramips_setup_interfaces()
        asiarf,ap7621-001)
                ucidef_add_switch "switch0" "0:lan" "4:wan" "6@eth0"
                ;;
+       asiarf,ap7621-nv1)
+               ucidef_add_switch "switch0" "0:wan" "2:lan" "3:lan" "6@eth0"
+               ;;
        asiarf,awapn2403)
                ucidef_add_switch "switch0" \
                        "0:lan" "1:wan" "6@eth0"
index 2e1479d0c69a381c6675fc34e787aef22dbb3d15..9926a9bd5a132cd9819fdf98edc9476062e1f371 100644 (file)
@@ -1,123 +1,9 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
 /dts-v1/;
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7621_asiarf_ap7621.dtsi"
 
 / {
        compatible = "asiarf,ap7621-001", "mediatek,mt7621-soc";
        model = "AsiaRF AP7621-001";
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               wlan1 {
-                       label = "ap7621-001:orange:wlan1";
-                       gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
-               };
-
-               wlan0 {
-                       label = "ap7621-001:orange:wlan0";
-                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&sdhci {
-       status = "okay";
-};
-
-&spi0 {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <40000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x2000>;
-                       };
-
-                       partition@32000 {
-                               label = "2860";
-                               reg = <0x32000 0x4000>;
-                       };
-
-                       partition@36000 {
-                               label = "rtdev";
-                               reg = <0x36000 0x2000>;
-                       };
-
-                       partition@38000 {
-                               label = "Reserve";
-                               reg = <0x38000 0x8000>;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               label = "firmware";
-                               reg = <0x50000 0xfa0000>;
-                               compatible = "denx,uimage";
-                       };
-
-                       partition@ff0000 {
-                               label = "nvram";
-                               reg = <0xff0000 0x10000>;
-                               read-only;
-                       };
-               };
-       };
 };
-
-&pcie {
-       status = "okay";
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0xe000>;
-       mediatek,portmap = "llllw";
-};
-
-&pinctrl {
-       state_default: pinctrl0 {
-               gpio {
-                       ralink,group = "wdt", "jtag";
-                       ralink,function = "gpio";
-               };
-       };
-};
-
diff --git a/target/linux/ramips/dts/mt7621_asiarf_ap7621-nv1.dts b/target/linux/ramips/dts/mt7621_asiarf_ap7621-nv1.dts
new file mode 100644 (file)
index 0000000..ec322d0
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+#include "mt7621_asiarf_ap7621.dtsi"
+
+/ {
+       compatible = "asiarf,ap7621-nv1", "mediatek,mt7621-soc";
+       model = "AsiaRF AP7621-NV1";
+};
diff --git a/target/linux/ramips/dts/mt7621_asiarf_ap7621.dtsi b/target/linux/ramips/dts/mt7621_asiarf_ap7621.dtsi
new file mode 100644 (file)
index 0000000..044b06b
--- /dev/null
@@ -0,0 +1,120 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+/dts-v1/;
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wlan1 {
+                       label = "ap7621-001:orange:wlan1";
+                       gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan0 {
+                       label = "ap7621-001:orange:wlan0";
+                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x2000>;
+                       };
+
+                       partition@32000 {
+                               label = "2860";
+                               reg = <0x32000 0x4000>;
+                       };
+
+                       partition@36000 {
+                               label = "rtdev";
+                               reg = <0x36000 0x2000>;
+                       };
+
+                       partition@38000 {
+                               label = "Reserve";
+                               reg = <0x38000 0x8000>;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               reg = <0x50000 0xfa0000>;
+                               compatible = "denx,uimage";
+                       };
+
+                       partition@ff0000 {
+                               label = "nvram";
+                               reg = <0xff0000 0x10000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+       mediatek,portmap = "llllw";
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "wdt", "jtag";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
index 1727f998c89ae308a5910a09dfa8a3dd99ef1373..f098976dfce9aac05820d92395334ebe68d5e7a9 100644 (file)
@@ -125,6 +125,16 @@ define Device/asiarf_ap7621-001
 endef
 TARGET_DEVICES += asiarf_ap7621-001
 
+define Device/asiarf_ap7621-nv1
+  MTK_SOC := mt7621
+  IMAGE_SIZE := 16000k
+  DEVICE_VENDOR := AsiaRF
+  DEVICE_MODEL := AP7621-NV1
+  DEVICE_PACKAGES := \
+       kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3
+endef
+TARGET_DEVICES += asiarf_ap7621-nv1
+
 define Device/asus_rt-ac57u
   MTK_SOC := mt7621
   DEVICE_VENDOR := ASUS