ar71xx: package the AR934x NAND driver module
authorGabor Juhos <juhosg@openwrt.org>
Thu, 13 Sep 2012 07:26:23 +0000 (07:26 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 13 Sep 2012 07:26:23 +0000 (07:26 +0000)
SVN-Revision: 33386

target/linux/ar71xx/modules.mk

index 165b3fca7fa2025b9dc0549fead89c8dafb10203..5607d188c28b86e221a38d8345da5bdc509d42bd 100644 (file)
@@ -37,6 +37,22 @@ endef
 $(eval $(call KernelPackage,leds-wndr3700-usb))
 
 
+define KernelPackage/nand-ar934x
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Atheros AR934x NAND flash controller driver
+  KCONFIG:=CONFIG_MTD_NAND_AR934X
+  DEPENDS:=@TARGET_ar71xx +kmod-nand
+  FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
+  AUTOLOAD:=$(call AutoLoad,30,ar934x_nfc)
+endef
+
+define KernelPackage/nand-ar934x/description
+  Atheros AR934x NAND flash controller driver.
+endef
+
+$(eval $(call KernelPackage,nand-ar934x))
+
+
 define KernelPackage/spi-vsc7385
   SUBMENU:=$(SPI_MENU)
   TITLE:=Vitesse VSC7385 ethernet switch driver
@@ -67,3 +83,4 @@ define KernelPackage/wdt-ath79/description
 endef
 
 $(eval $(call KernelPackage,wdt-ath79))
+