mpc85xx: fix build with kernel 5.4
authorDavid Bauer <mail@david-bauer.net>
Mon, 24 Feb 2020 21:49:45 +0000 (22:49 +0100)
committerDavid Bauer <mail@david-bauer.net>
Fri, 28 Feb 2020 22:32:37 +0000 (23:32 +0100)
This fixes some outstanding issues with the Kernel 5.4 build:

 * Adds missing support patch for the Enterasys WS-AP3710i
 * Fixes incorrect NAND symbols
 * Adds patch for broken image wrapping

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mpc85xx/generic/config-default
target/linux/mpc85xx/p1020/config-default
target/linux/mpc85xx/p2020/config-default
target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch [new file with mode: 0644]
target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch [new file with mode: 0644]

index c38ffce92fd4569886a0057413bae0588c574c52..93ed5c5e55499c72b888e10ac6e8bd75d4946aab 100644 (file)
@@ -1,6 +1,5 @@
 # CONFIG_FSL_CORENET_CF is not set
-CONFIG_MTD_NAND=y
-CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_NAND_FSL_IFC=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
 CONFIG_MTD_SPLIT_TPLINK_FW=y
index 2ad3f75beea88bbfd4738bf520727cb3478226b8..00a02a8dc10dbbb61d76eef1c978030afc749c81 100644 (file)
@@ -19,8 +19,7 @@ CONFIG_LOCK_SPIN_ON_OWNER=y
 CONFIG_MFD_CORE=y
 CONFIG_MFD_MAX77620=y
 CONFIG_MTD_CFI=y
-CONFIG_MTD_NAND=y
-CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_NAND_FSL_ELBC=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
index e6526446b43704503a05419cf6b19768c72e58a3..2369bbc7a63dc8a4dd5ae69bce11f00d9eb5ff21 100644 (file)
@@ -7,9 +7,8 @@ CONFIG_HAVE_RCU_TABLE_FREE=y
 CONFIG_LOCK_SPIN_ON_OWNER=y
 CONFIG_MPC85xx_RDB=y
 CONFIG_MTD_CFI=y
-CONFIG_MTD_NAND=y
+CONFIG_MTD_RAW_NAND=y
 CONFIG_MTD_NAND_BCH=y
-CONFIG_MTD_NAND_ECC=y
 CONFIG_MTD_NAND_ECC_BCH=y
 CONFIG_MTD_NAND_FSL_ELBC=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
diff --git a/target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch b/target/linux/mpc85xx/patches-5.4/106-powerpc-85xx-ws-ap3710i-support.patch
new file mode 100644 (file)
index 0000000..4bacedb
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
+@@ -71,6 +71,17 @@ config PANDA
+         This board is a Concurrent Dual-Band wireless access point with a
+         Freescale P1020 SoC.
++config WS_AP3710I
++      bool "Enterasys WS-AP3710i"
++      select DEFAULT_UIMAGE
++      select ARCH_REQUIRE_GPIOLIB
++      select GPIO_MPC8XXX
++      help
++        This option enables support for the Enterasys WS-AP3710i board.
++
++        This board is a Concurrent Dual-Band wireless access point with a
++        Freescale P1020 SoC.
++
+ config MPC8540_ADS
+       bool "Freescale MPC8540 ADS"
+       select DEFAULT_UIMAGE
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
+@@ -24,6 +24,7 @@ obj-$(CONFIG_P1022_RDK)   += p1022_rdk.o
+ obj-$(CONFIG_P1023_RDB)   += p1023_rdb.o
+ obj-$(CONFIG_PANDA)       += panda.o
+ obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
++obj-$(CONFIG_WS_AP3710I)  += ws-ap3710i.o
+ obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
+ obj-$(CONFIG_FB_FSL_DIU)      += t1042rdb_diu.o
+ obj-$(CONFIG_RED_15W_REV1)    += red15w_rev1.o
diff --git a/target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch b/target/linux/mpc85xx/patches-5.4/900-powerpc-bootwrapper-force-gzip-as-mkimage-s-compress.patch
new file mode 100644 (file)
index 0000000..8a1e6ae
--- /dev/null
@@ -0,0 +1,31 @@
+From c9395ad54e2cabb87d408becc37566f3d8248933 Mon Sep 17 00:00:00 2001
+From: Christian Lamparter <chunkeey@gmail.com>
+Date: Sun, 1 Dec 2019 02:08:23 +0100
+Subject: [PATCH] powerpc: bootwrapper: force gzip as mkimage's compression
+ method
+
+Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
+instruct the mkimage to use the xz compression, which isn't
+supported. This patch forces the gzip compression, which is
+supported and doesn't matter because the generated uImage for
+the apm821xx target gets ignored as the OpenWrt toolchain will
+do separate U-Boot kernel images for each device individually.
+
+Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
+[copied to mpc85xx]
+Signed-off-by: David Bauer <mail@david-bauer.net>
+---
+ arch/powerpc/boot/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -254,7 +254,7 @@ compressor-$(CONFIG_KERNEL_LZO) := lzo
+ # args (to if_changed): 1 = (this rule), 2 = platform, 3 = dts 4=dtb 5=initrd
+ quiet_cmd_wrap        = WRAP    $@
+-      cmd_wrap        =$(CONFIG_SHELL) $(wrapper) -Z $(compressor-y) -c -o $@ -p $2 \
++      cmd_wrap        =$(CONFIG_SHELL) $(wrapper) -Z gzip -c -o $@ -p $2 \
+               $(CROSSWRAP) $(if $3, -s $3)$(if $4, -d $4)$(if $5, -i $5) \
+               vmlinux