iproute2: cake: make gso/gro splitting configurable
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sun, 29 Jul 2018 13:56:03 +0000 (14:56 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Thu, 2 Aug 2018 21:00:19 +0000 (22:00 +0100)
This patch makes sch_cake's gso/gro splitting configurable
from userspace.

To disable breaking apart superpackets in sch_cake:

tc qdisc replace dev whatever root cake no-split-gso

to enable:

tc qdisc replace dev whatever root cake split-gso

Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
Signed-off-by: Dave Taht <dave.taht@gmail.com>
[pulled from netdev list - no API/ABI change]
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/190-add-cake-to-tc.patch

index b1e4518b2355a70d2369259a8254cdc893f24249..d91616e456941e85c7f4268cff5d41a3629c7b69 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.17.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
index 76594cca498c4d6bb347bff463a4fab6e787c920..b44efac974ad56d94f450744483c92f358c5b456 100644 (file)
  TCMODULES += e_bpf.o
 --- /dev/null
 +++ b/tc/q_cake.c
-@@ -0,0 +1,790 @@
+@@ -0,0 +1,799 @@
 +// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
 +
 +/*
 +"                  dual-srchost | dual-dsthost | triple-isolate* ]\n"
 +"                [ nat | nonat* ]\n"
 +"                [ wash | nowash* ]\n"
++"                [ split-gso* | no-split-gso ]\n"
 +"                [ ack-filter | ack-filter-aggressive | no-ack-filter* ]\n"
 +"                [ memlimit LIMIT ]\n"
 +"                [ ptm | atm | noatm* ] [ overhead N | conservative | raw* ]\n"
 +      int nat = -1;
 +      int atm = -1;
 +      int mpu = 0;
++      int split_gso = -1;
 +
 +      while (argc > 0) {
 +              if (strcmp(*argv, "bandwidth") == 0) {
 +                      wash = 0;
 +              } else if (strcmp(*argv, "wash") == 0) {
 +                      wash = 1;
++              } else if (strcmp(*argv, "split-gso") == 0) {
++                      split_gso = 1;
++              } else if (strcmp(*argv, "no-split-gso") == 0) {
++                      split_gso = 0;
 +              } else if (strcmp(*argv, "flowblind") == 0) {
 +                      flowmode = CAKE_FLOW_NONE;
 +              } else if (strcmp(*argv, "srchost") == 0) {
 +              addattr_l(n, 1024, TCA_CAKE_NAT, &nat, sizeof(nat));
 +      if (wash != -1)
 +              addattr_l(n, 1024, TCA_CAKE_WASH, &wash, sizeof(wash));
++      if (split_gso != -1)
++              addattr_l(n, 1024, TCA_CAKE_SPLIT_GSO, &split_gso,
++                        sizeof(split_gso));
 +      if (ingress != -1)
 +              addattr_l(n, 1024, TCA_CAKE_INGRESS, &ingress, sizeof(ingress));
 +      if (ack_filter != -1)