kernel: update linux 3.7 to 3.7.8
authorGabor Juhos <juhosg@openwrt.org>
Fri, 15 Feb 2013 07:36:15 +0000 (07:36 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 15 Feb 2013 07:36:15 +0000 (07:36 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35604

19 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.7/630-packet_socket_type.patch
target/linux/generic/patches-3.7/651-wireless_mesh_header.patch
target/linux/generic/patches-3.7/721-phy_packets.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/geos/target.mk

index 58e911ae42dc703aefc83593586adce7f3946088..062bfb495ed1d2b405a5b1ef7e553e18aa3bf1fe 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.7)
-  LINUX_KERNEL_MD5SUM:=bd37c2e05cb82331eb00da81773b2d85
+ifeq ($(LINUX_VERSION),3.7.8)
+  LINUX_KERNEL_MD5SUM:=4bc40d18bf90f25d5463cfb9442876af
 endif
 
 # disable the md5sum check for unknown kernel versions
index 74b90d448a55a7cda277c64715753c046e92bea4..6074aeeb6863a73ddb63f8903d70ce024feb7a5e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 1227df163f44ddeae11e2ed484d0c002c7d2e0e7..aeed946ce9e42e02bd38db80b6ba8772502acf06 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
index e7e1712b7ee2d33b4b81703b5f2b20364293f261..70e03ac9ed09bf204ff1c6449fa3924998ebfb46 100644 (file)
  /*
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3842,13 +3842,14 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3847,13 +3847,14 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index 206763d77247ad4350341369db64524a61cdf066..3a686feaa0f626c3c340aa2c5968be0d2f8f3437 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 96d90f370b89fc4c4258a0018d12d5c898bf7d58..6736364aec6ba2933a54a529ada4d85d18ebae73 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 27a46078e6204dfb9b59cfdefbb0a025a53fe9d0..40200377c9bbb50995faa91ddbf7b6866c0944ed 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2511,6 +2513,7 @@ static int packet_create(struct net *net
+@@ -2513,6 +2515,7 @@ static int packet_create(struct net *net
        spin_lock_init(&po->bind_lock);
        mutex_init(&po->pg_vec_lock);
        po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3111,6 +3114,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3113,6 +3116,16 @@ packet_setsockopt(struct socket *sock, i
  
                return fanout_add(sk, val & 0xffff, val >> 16);
        }
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3165,6 +3178,13 @@ static int packet_getsockopt(struct sock
+@@ -3167,6 +3180,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index ff3f0979f0bf3ad9452e0a10082c52a2eb4de80e..c21b007777bc030045d176133ebaf1d50cf62420 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -134,7 +134,7 @@ static inline bool dev_xmit_complete(int
+@@ -137,7 +137,7 @@ static inline bool dev_xmit_complete(int
   */
  
  #if defined(CONFIG_WLAN) || IS_ENABLED(CONFIG_AX25)
index 8dda0934b53f502053db7875ec522a7c7bbe5fa2..b8c15fcc6c51efd0091d1113aa3926df1ec7dc2e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1074,6 +1074,11 @@ struct net_device {
+@@ -1077,6 +1077,11 @@ struct net_device {
        const struct net_device_ops *netdev_ops;
        const struct ethtool_ops *ethtool_ops;
  
@@ -12,7 +12,7 @@
        /* Hardware header description */
        const struct header_ops *header_ops;
  
-@@ -1130,6 +1135,9 @@ struct net_device {
+@@ -1133,6 +1138,9 @@ struct net_device {
        void                    *ax25_ptr;      /* AX.25 specific data */
        struct wireless_dev     *ieee80211_ptr; /* IEEE 802.11 specific data,
                                                   assign before registering */
index 650b90f70259a55169b022c54502a0bf9489960f..c9bc96769f5aa6056af403d133d129f0431a4c9e 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index efa17d986fb32df50c905ba68a5fd848d7c37f16..21caadce4a31c9ac8509c2e61009bc5ce47a80e7 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 DEVICE_TYPE:=developerboard
 
index d7023cb6fccab000a351670484120fbc255f97da..399b05ea9e2348596665b10b27aadd7bebc888a5 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
index a7d4330c65f3d592bcb32e151104d2d3fc783988..c84c0e291150bd4716b63e6c8b2c9fb8ce69607f 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
index b7dac46a3c0979ec67adc811363517a15f84209b..aa518a91d90d2581b9c0164e86fc30b833192e3d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 3cd2e2ae62646d711e3ea5a47bdbf2de1c4ad87d..4d525e56afb1b5bd69142725f28206f07c00bb6b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 
index 80719258b3ca25bf269937dabb0be5b64433db42..a81610af6712772a352181784ed96a1fcf09ee81 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index c1672c29aacc706aa2c3801dfbc6aee3b5b4f6f4..b6fc34c4116175b8faadf12f3dc5eca5e8966fdf 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 29787294ea00fb46295a17a824ee72e3e8a50b27..901eb92a85dd8782558e8975a5180ddb4bef7be1 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index d1f73070fdfa8915118de6ead644b4055b6ff636..84621feba1d8503c94ebe911fa8d57ea9eae0051 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \