kernel: fix l2tp kernel packages
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Nov 2010 20:51:30 +0000 (20:51 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Nov 2010 20:51:30 +0000 (20:51 +0000)
l2tp-ip and l2tp-eth should depend on l2tp_netlink
fix pppol2tp for kernel >= 2.6.35

SVN-Revision: 23993

package/kernel/modules/netsupport.mk
target/linux/generic/config-2.6.35
target/linux/generic/config-2.6.36
target/linux/generic/config-2.6.37

index 08068d1e6a9c19be33478156e4a27caef3317cc2..1baba4b5b737bcaee79400c1c5df2415558c9a92 100644 (file)
@@ -473,11 +473,12 @@ define KernelPackage/pppol2tp
   DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37:kmod-l2tp
   KCONFIG:=CONFIG_PPPOL2TP
   ifneq ($(CONFIG_LINUX_2_6_35)$(CONFIG_LINUX_2_6_36)$(CONFIG_LINUX_2_6_37),)
-    FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.mod.o
+    FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
+    AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
   else
     FILES:=$(LINUX_DIR)/drivers/net/pppol2tp.ko
+    AUTOLOAD:=$(call AutoLoad,40,pppol2tp)
   endif
-  AUTOLOAD:=$(call AutoLoad,40,pppol2tp)
 endef
 
 define KernelPackage/pppol2tp/description
@@ -630,10 +631,13 @@ $(eval $(call KernelPackage,pktgen))
 define KernelPackage/l2tp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37
-  TITLE:=L2TPv3 Support
-  KCONFIG:=CONFIG_L2TP CONFIG_L2TP_DEBUGFS=n
-  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_core.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,32,l2tp_core)
+  TITLE:=Layer Two Tunneling Protocol (L2TP)
+  KCONFIG:=CONFIG_L2TP \
+       CONFIG_L2TP_V3=y \
+       CONFIG_L2TP_DEBUGFS=n
+  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_core.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/net/l2tp/l2tp_netlink.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_netlink)
 endef
 
 define KernelPackage/l2tp/description
@@ -642,36 +646,33 @@ endef
 
 $(eval $(call KernelPackage,l2tp))
 
+
 define KernelPackage/l2tp-eth
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=L2TP ethernet pseudowire support for L2TPv3
   DEPENDS:=+kmod-l2tp
-  KCONFIG:= CONFIG_L2TP_V3=y \
-  CONFIG_L2TP_ETH
-  FILES:= \
-         $(LINUX_DIR)/net/l2tp/l2tp_netlink.$(LINUX_KMOD_SUFFIX) \
-         $(LINUX_DIR)/net/l2tp/l2tp_eth.$(LINUX_KMOD_SUFFIX) 
-  AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_netlink l2tp_eth)
+  KCONFIG:=CONFIG_L2TP_ETH
+  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_eth.$(LINUX_KMOD_SUFFIX) 
+  AUTOLOAD:=$(call AutoLoad,33,l2tp_eth)
 endef
 
 define KernelPackage/l2tp-eth/description
- Kernel modules for L2TP V3 pseudowire support
+ Kernel modules for L2TP ethernet pseudowire support for L2TPv3
 endef
 
 $(eval $(call KernelPackage,l2tp-eth))
 
 define KernelPackage/l2tp-ip
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=Support for L2TP-over-IP socket family
+  TITLE:=L2TP IP encapsulation for L2TPv3
   DEPENDS:=+kmod-l2tp
-  KCONFIG:= CONFIG_L2TP_V3=y \
-  CONFIG_L2TP_IP
+  KCONFIG:=CONFIG_L2TP_IP
   FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_ip)
+  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip)
 endef
 
 define KernelPackage/l2tp-ip/description
- Kernel modules for L2TP-over-IP socket family
+ Kernel modules for L2TP IP encapsulation for L2TPv3
 endef
 
 $(eval $(call KernelPackage,l2tp-ip))
index 7a2ebeae7fc122c21346c001ebe518567d41adab..f1911ed3dd4d4cfa3427de9553e78524e09bf56f 100644 (file)
@@ -1247,6 +1247,9 @@ CONFIG_KMOD=y
 # CONFIG_KSM is not set
 # CONFIG_KSZ884X_PCI is not set
 # CONFIG_L2TP is not set
+# CONFIG_L2TP_ETH is not set
+# CONFIG_L2TP_IP is not set
+# CONFIG_L2TP_V3 is not set
 # CONFIG_LANMEDIA is not set
 # CONFIG_LAPB is not set
 # CONFIG_LASAT is not set
index 5249a8b9d9ca87624d40b93ba1cc3d3562b3472f..68be8b231402d0c68f95935de836af55014a7a9e 100644 (file)
@@ -1135,6 +1135,9 @@ CONFIG_KERNEL_LZMA=y
 # CONFIG_KSM is not set
 # CONFIG_KSZ884X_PCI is not set
 # CONFIG_L2TP is not set
+# CONFIG_L2TP_ETH is not set
+# CONFIG_L2TP_IP is not set
+# CONFIG_L2TP_V3 is not set
 # CONFIG_LANMEDIA is not set
 # CONFIG_LAPB is not set
 # CONFIG_LASAT is not set
index 9caef5dd40bf2b0562c0ebd64c80ef425e19c80d..5278c2bfe5e1cbaf085d788fa05bcaf52747cbb3 100644 (file)
@@ -1123,6 +1123,9 @@ CONFIG_KERNEL_LZMA=y
 # CONFIG_KSM is not set
 # CONFIG_KSZ884X_PCI is not set
 # CONFIG_L2TP is not set
+# CONFIG_L2TP_ETH is not set
+# CONFIG_L2TP_IP is not set
+# CONFIG_L2TP_V3 is not set
 # CONFIG_LANMEDIA is not set
 # CONFIG_LAPB is not set
 # CONFIG_LASAT is not set