glibc: remove accidentally commited folder
authorJohn Crispin <john@openwrt.org>
Thu, 12 Mar 2015 20:29:50 +0000 (20:29 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 12 Mar 2015 20:29:50 +0000 (20:29 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 44703

toolchain/patches/2.15/001-fix_autoconf_macro.patch [deleted file]
toolchain/patches/2.15/005-versions.patch [deleted file]
toolchain/patches/2.15/050-all_glibc-2.14-leak-revert-crash.patch [deleted file]
toolchain/patches/2.15/100-fix_cross_rpcgen.patch [deleted file]
toolchain/patches/2.15/110-fix_cross_zic.patch [deleted file]
toolchain/patches/2.15/120-use_host_cflags.patch [deleted file]
toolchain/patches/2.15/200-add-dl-search-paths.patch [deleted file]
toolchain/patches/2.19/100-fix_cross_rpcgen.patch [deleted file]
toolchain/patches/2.19/200-add-dl-search-paths.patch [deleted file]
toolchain/patches/2.19/300-require-autoconf-2.69.patch [deleted file]

diff --git a/toolchain/patches/2.15/001-fix_autoconf_macro.patch b/toolchain/patches/2.15/001-fix_autoconf_macro.patch
deleted file mode 100644 (file)
index 55b26c7..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/libc/aclocal.m4
-+++ b/libc/aclocal.m4
-@@ -88,6 +88,12 @@
- fi
- rm -fr contest*])
-+dnl Test a compiler option or options with an empty input file.
-+dnl LIBC_TRY_CC_OPTION([options], [action-if-true], [action-if-false])
-+AC_DEFUN([LIBC_TRY_CC_OPTION],
-+[AS_IF([AC_TRY_COMMAND([${CC-cc} $1 -xc /dev/null -S -o /dev/null])],
-+ [$2], [$3])])
-+
- AC_DEFUN([LIBC_PROG_BINUTILS],
- [# Was a --with-binutils option given?
- if test -n "$path_binutils"; then
---- a/libc/configure
-+++ b/libc/configure
-@@ -7404,7 +7404,14 @@
- else
-   libc_cv_cc_nofma=
- for opt in -ffp-contract=off -mno-fused-madd; do
--  LIBC_TRY_CC_OPTION($opt, libc_cv_cc_nofma=$opt; break)
-+  if { ac_try='${CC-cc} $opt -xc /dev/null -S -o /dev/null'
-+  { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-+  test $ac_status = 0; }; }; then :
-+  libc_cv_cc_nofma=$opt; break
-+fi
- done
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_cc_nofma" >&5
---- a/libc/configure.in
-+++ b/libc/configure.in
-@@ -2238,10 +2238,9 @@
-                libc_cv_cc_submachine, [dnl
-   libc_cv_cc_submachine=no
-   for opt in "-march=$submachine" "-mcpu=$submachine"; do
--    if AC_TRY_COMMAND([${CC-cc} $opt -xc /dev/null -S -o /dev/null]); then
-+    LIBC_TRY_CC_OPTION([$opt], [
-       libc_cv_cc_submachine="$opt"
--      break
--    fi
-+      break], [])
-   done])
-   if test "x$libc_cv_cc_submachine" = xno; then
-     AC_MSG_ERROR([${CC-cc} does not support $submachine])
diff --git a/toolchain/patches/2.15/005-versions.patch b/toolchain/patches/2.15/005-versions.patch
deleted file mode 100644 (file)
index da9d2ba..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/libc/configure.in
-+++ b/libc/configure.in
-@@ -1037,7 +1037,7 @@
-   critic_missing="$critic_missing gcc")
- AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
-   [GNU Make[^0-9]*\([0-9][0-9.]*\)],
--  [3.79* | 3.[89]*], critic_missing="$critic_missing make")
-+  [3.79* | 3.[89]* | 4.* ], critic_missing="$critic_missing make")
- AC_CHECK_PROG_VER(MSGFMT, gnumsgfmt gmsgfmt msgfmt, --version,
-   [GNU gettext.* \([0-9]*\.[0-9.]*\)],
diff --git a/toolchain/patches/2.15/050-all_glibc-2.14-leak-revert-crash.patch b/toolchain/patches/2.15/050-all_glibc-2.14-leak-revert-crash.patch
deleted file mode 100644 (file)
index d1e19aa..0000000
+++ /dev/null
@@ -1,110 +0,0 @@
-partially revert commit 4bff6e0175ed195871f4e01cc4c4c33274b8f6e3 - caused segmentation faults in dlopen
-
-References:
-http://comments.gmane.org/gmane.comp.lib.glibc.user/1227
-http://sourceware.org/ml/libc-alpha/2011-06/msg00006.html
-
-diff --git a/libc/elf/dl-close.c b/libc/elf/dl-close.c
-index 4b17bf8..733cc1b 100644
---- a/libc/elf/dl-close.c
-+++ b/libc/elf/dl-close.c
-@@ -119,17 +119,8 @@ _dl_close_worker (struct link_map *map)
-   if (map->l_direct_opencount > 0 || map->l_type != lt_loaded
-       || dl_close_state != not_pending)
-     {
--      if (map->l_direct_opencount == 0)
--      {
--        if (map->l_type == lt_loaded)
--          dl_close_state = rerun;
--        else if (map->l_type == lt_library)
--          {
--            struct link_map **oldp = map->l_initfini;
--            map->l_initfini = map->l_orig_initfini;
--            _dl_scope_free (oldp);
--          }
--      }
-+      if (map->l_direct_opencount == 0 && map->l_type == lt_loaded)
-+      dl_close_state = rerun;
-       /* There are still references to this object.  Do nothing more.  */
-       if (__builtin_expect (GLRO_dl_debug_mask & DL_DEBUG_FILES, 0))
-diff --git a/libc/elf/dl-deps.c b/libc/elf/dl-deps.c
-index 51cb2fa..eddcbf0 100644
---- a/libc/elf/dl-deps.c
-+++ b/libc/elf/dl-deps.c
-@@ -489,6 +489,7 @@ _dl_map_object_deps (struct link_map *map,
-                 nneeded * sizeof needed[0]);
-         atomic_write_barrier ();
-         l->l_initfini = l_initfini;
-+        l->l_free_initfini = 1;
-       }
-       /* If we have no auxiliary objects just go on to the next map.  */
-@@ -689,6 +690,7 @@ Filters not supported with LD_TRACE_PRELINKING"));
-   l_initfini[nlist] = NULL;
-   atomic_write_barrier ();
-   map->l_initfini = l_initfini;
-+  map->l_free_initfini = 1;
-   if (l_reldeps != NULL)
-     {
-       atomic_write_barrier ();
-@@ -697,7 +699,7 @@ Filters not supported with LD_TRACE_PRELINKING"));
-       _dl_scope_free (old_l_reldeps);
-     }
-   if (old_l_initfini != NULL)
--      map->l_orig_initfini = old_l_initfini;
-+    _dl_scope_free (old_l_initfini);
-   if (errno_reason)
-     _dl_signal_error (errno_reason == -1 ? 0 : errno_reason, objname,
-diff --git a/libc/elf/dl-libc.c b/libc/elf/dl-libc.c
-index f44fa10..7563093 100644
---- a/libc/elf/dl-libc.c
-+++ b/libc/elf/dl-libc.c
-@@ -284,6 +284,10 @@ libc_freeres_fn (free_mem)
-             if (! old->dont_free)
-               free (old);
-           }
-+
-+        /* Free the initfini dependency list.  */
-+        if (l->l_free_initfini)
-+          free (l->l_initfini);
-       }
-       if (__builtin_expect (GL(dl_ns)[ns]._ns_global_scope_alloc, 0) != 0
-diff --git a/libc/elf/rtld.c b/libc/elf/rtld.c
-index b93a01f..2fc83ce 100644
---- a/libc/elf/rtld.c
-+++ b/libc/elf/rtld.c
-@@ -2277,6 +2277,7 @@ ERROR: ld.so: object '%s' cannot be loaded as audit interface: %s; ignored.\n",
-             lnp->dont_free = 1;
-             lnp = lnp->next;
-           }
-+        l->l_free_initfini = 0;
-         if (l != &GL(dl_rtld_map))
-           _dl_relocate_object (l, l->l_scope, GLRO(dl_lazy) ? RTLD_LAZY : 0,
-diff --git a/libc/include/link.h b/libc/include/link.h
-index e877104..b1b4065 100644
---- a/libc/include/link.h
-+++ b/libc/include/link.h
-@@ -192,6 +192,9 @@ struct link_map
-                                                during LD_TRACE_PRELINKING=1
-                                                contains any DT_SYMBOLIC
-                                                libraries.  */
-+    unsigned int l_free_initfini:1; /* Nonzero if l_initfini can be
-+                                     freed, ie. not allocated with
-+                                     the dummy malloc in ld.so.  */
-     /* Collected information about own RPATH directories.  */
-     struct r_search_path_struct l_rpath_dirs;
-@@ -240,9 +243,6 @@ struct link_map
-     /* List of object in order of the init and fini calls.  */
-     struct link_map **l_initfini;
--    /* The init and fini list generated at startup, saved when the
--       object is also loaded dynamically.  */
--    struct link_map **l_orig_initfini;
-     /* List of the dependencies introduced through symbol binding.  */
-     struct link_map_reldeps
diff --git a/toolchain/patches/2.15/100-fix_cross_rpcgen.patch b/toolchain/patches/2.15/100-fix_cross_rpcgen.patch
deleted file mode 100644 (file)
index 8fe5cf3..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
---- a/libc/sunrpc/proto.h
-+++ b/libc/sunrpc/proto.h
-@@ -56,12 +56,14 @@ void add_type(int len, const char *type)
-    $build's C library and $host's GLIBC.  */
- #ifdef _CROSS_RPCGEN_
-+#undef stpcpy
-+
- /* Rather then defining _GNU_SOURCE before including $build's <string.h>
-    we just declare stpcpy here.  */
- extern char *stpcpy (char *, const char *);
--/* Use $build's i18n support as we can't use $host's.  */
--#define _(X) (gettext (X))
-+/* Do not use i18n support  */
-+#define _(X) (X)
- /* rpcgen sources check for __GNU_LIBRARY__ to tweak for GLIBC code
-    that rpcgen generates.  The proper fix would be to rename all those checks
---- a/libc/sunrpc/rpc/types.h
-+++ b/libc/sunrpc/rpc/types.h
-@@ -70,18 +70,23 @@ typedef unsigned long rpcport_t;
- #endif
- #ifndef __u_char_defined
--typedef __u_char u_char;
--typedef __u_short u_short;
--typedef __u_int u_int;
--typedef __u_long u_long;
--typedef __quad_t quad_t;
--typedef __u_quad_t u_quad_t;
--typedef __fsid_t fsid_t;
-+typedef unsigned char u_char;
-+typedef unsigned short u_short;
-+typedef unsigned int u_int;
-+typedef unsigned long u_long;
-+#if __WORDSIZE == 64
-+typedef long int quad_t;
-+typedef unsigned long int u_quad_t;
-+#elif defined __GLIBC_HAVE_LONG_LONG
-+typedef long long int quad_t;
-+typedef unsigned long long int u_quad_t;
-+#endif
-+typedef u_quad_t fsid_t;
- # define __u_char_defined
- #endif
--#ifndef __daddr_t_defined
--typedef __daddr_t daddr_t;
--typedef __caddr_t caddr_t;
-+#if !defined(__daddr_t_defined) && defined(linux)
-+typedef long int daddr_t;
-+typedef char *caddr_t;
- # define __daddr_t_defined
- #endif
---- a/libc/sunrpc/rpc_main.c
-+++ b/libc/sunrpc/rpc_main.c
-@@ -997,9 +997,10 @@ mkfile_output (struct commandline *cmd)
-       abort ();
-       temp = rindex (cmd->infile, '.');
-       cp = stpcpy (mkfilename, "Makefile.");
--      if (temp != NULL)
--      *((char *) stpncpy (cp, cmd->infile, temp - cmd->infile)) = '\0';
--      else
-+      if (temp != NULL) {
-+        strncpy(cp, cmd->infile, temp - cmd->infile);
-+        cp[temp - cmd->infile - 1] = 0;
-+      } else
-       stpcpy (cp, cmd->infile);
-     }
diff --git a/toolchain/patches/2.15/110-fix_cross_zic.patch b/toolchain/patches/2.15/110-fix_cross_zic.patch
deleted file mode 100644 (file)
index 221eb28..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/libc/timezone/zic.c
-+++ b/libc/timezone/zic.c
-@@ -8,6 +8,8 @@ static char    elsieid[] = "@(#)zic.c  8.19"
- #ifdef CROSS_ZIC
- #define REPORT_BUGS_TO ""
- #define PKGVERSION ""
-+#undef _
-+#define _(X) (X)
- #else
- #include "config.h"
- #endif
-@@ -490,6 +492,7 @@ char *     argv[];
- #ifdef unix
-       (void) umask(umask(S_IWGRP | S_IWOTH) | (S_IWGRP | S_IWOTH));
- #endif /* defined unix */
-+#ifndef CROSS_ZIC
- #if HAVE_GETTEXT
-       (void) setlocale(LC_ALL, "");
- #ifdef TZ_DOMAINDIR
-@@ -497,6 +500,7 @@ char *     argv[];
- #endif /* defined TEXTDOMAINDIR */
-       (void) textdomain(TZ_DOMAIN);
- #endif /* HAVE_GETTEXT */
-+#endif
-       progname = argv[0];
-       if (TYPE_BIT(zic_t) < 64) {
-               (void) fprintf(stderr, "%s: %s\n", progname,
diff --git a/toolchain/patches/2.15/120-use_host_cflags.patch b/toolchain/patches/2.15/120-use_host_cflags.patch
deleted file mode 100644 (file)
index 4c58fb4..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/libc/sunrpc/Makefile
-+++ b/libc/sunrpc/Makefile
-@@ -175,7 +175,7 @@ $(objpfx)rpcgen: $(addprefix $(objpfx),$
-       $(+link)
- $(addprefix $(objpfx)cross-,$(rpcgen-objs)): $(objpfx)cross-%.o: %.c
--      gcc $< -c -D_RPC_THREAD_SAFE_ -D_CROSS_RPCGEN_ \
-+      gcc $< -c -D_RPC_THREAD_SAFE_ -D_CROSS_RPCGEN_ $(HOST_CFLAGS) \
-               $(OUTPUT_OPTION) $(compile-mkdep-flags)
- $(objpfx)cross-rpcgen: $(addprefix $(objpfx)cross-,$(rpcgen-objs))
---- a/libc/timezone/Makefile
-+++ b/libc/timezone/Makefile
-@@ -182,7 +182,7 @@ $(objpfx)zic: $(addprefix $(objpfx), $(z
- $(addprefix $(objpfx)cross-,$(zic-objs)): $(objpfx)cross-%.o: %.c
-       gcc $< -c $(OUTPUT_OPTION) $(CFLAGS-$*.c) $(CPPFLAGS-$*) \
--              -DCROSS_ZIC $(compile-mkdep-flags)
-+              -DCROSS_ZIC $(HOST_CFLAGS) $(compile-mkdep-flags)
- $(objpfx)cross-zic: $(addprefix $(objpfx)cross-,$(zic-objs))
-       gcc $(addprefix $(objpfx)cross-,$(zic-objs)) -o $@
diff --git a/toolchain/patches/2.15/200-add-dl-search-paths.patch b/toolchain/patches/2.15/200-add-dl-search-paths.patch
deleted file mode 100644 (file)
index 70e7e60..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-add /usr/lib to default search path for the dynamic linker
-
---- a/libc/Makeconfig
-+++ b/libc/Makeconfig
-@@ -539,6 +539,9 @@
- default-rpath = $(libdir)
- endif
-+# Add /usr/lib to default search path for the dynamic linker
-+user-defined-trusted-dirs := /usr/lib
-+
- ifndef link-extra-libs
- link-extra-libs = $(LDLIBS-$(@F))
- link-extra-libs-static = $(link-extra-libs)
diff --git a/toolchain/patches/2.19/100-fix_cross_rpcgen.patch b/toolchain/patches/2.19/100-fix_cross_rpcgen.patch
deleted file mode 100644 (file)
index 5c0d45b..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
---- a/libc/sunrpc/rpc/types.h
-+++ b/libc/sunrpc/rpc/types.h
-@@ -75,18 +75,23 @@ typedef unsigned long rpcport_t;
- #endif
- #ifndef __u_char_defined
--typedef __u_char u_char;
--typedef __u_short u_short;
--typedef __u_int u_int;
--typedef __u_long u_long;
--typedef __quad_t quad_t;
--typedef __u_quad_t u_quad_t;
--typedef __fsid_t fsid_t;
-+typedef unsigned char u_char;
-+typedef unsigned short u_short;
-+typedef unsigned int u_int;
-+typedef unsigned long u_long;
-+#if __WORDSIZE == 64
-+typedef long int quad_t;
-+typedef unsigned long int u_quad_t;
-+#elif defined __GLIBC_HAVE_LONG_LONG
-+typedef long long int quad_t;
-+typedef unsigned long long int u_quad_t;
-+#endif
-+typedef u_quad_t fsid_t;
- # define __u_char_defined
- #endif
--#ifndef __daddr_t_defined
--typedef __daddr_t daddr_t;
--typedef __caddr_t caddr_t;
-+#if !defined(__daddr_t_defined) && defined(linux)
-+typedef long int daddr_t;
-+typedef char *caddr_t;
- # define __daddr_t_defined
- #endif
---- a/libc/sunrpc/rpc_main.c
-+++ b/libc/sunrpc/rpc_main.c
-@@ -958,9 +958,10 @@ mkfile_output (struct commandline *cmd)
-       abort ();
-       temp = rindex (cmd->infile, '.');
-       cp = stpcpy (mkfilename, "Makefile.");
--      if (temp != NULL)
--      *((char *) stpncpy (cp, cmd->infile, temp - cmd->infile)) = '\0';
--      else
-+      if (temp != NULL) {
-+        strncpy(cp, cmd->infile, temp - cmd->infile);
-+        cp[temp - cmd->infile - 1] = 0;
-+      } else
-       stpcpy (cp, cmd->infile);
-     }
diff --git a/toolchain/patches/2.19/200-add-dl-search-paths.patch b/toolchain/patches/2.19/200-add-dl-search-paths.patch
deleted file mode 100644 (file)
index fa192ca..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-add /usr/lib to default search path for the dynamic linker
-
---- a/libc/Makeconfig
-+++ b/libc/Makeconfig
-@@ -501,6 +501,9 @@ else
- default-rpath = $(libdir)
- endif
-+# Add /usr/lib to default search path for the dynamic linker
-+user-defined-trusted-dirs := /usr/lib
-+
- ifndef link-extra-libs
- link-extra-libs = $(LDLIBS-$(@F))
- link-extra-libs-static = $(link-extra-libs)
diff --git a/toolchain/patches/2.19/300-require-autoconf-2.69.patch b/toolchain/patches/2.19/300-require-autoconf-2.69.patch
deleted file mode 100644 (file)
index 623885c..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: eglibc-2.19-r25243/libc/aclocal.m4
-===================================================================
---- eglibc-2.19-r25243.orig/libc/aclocal.m4    2013-11-06 15:03:08.000000000 -0800
-+++ eglibc-2.19-r25243/libc/aclocal.m4 2014-11-22 15:43:05.343256863 -0800
-@@ -1,7 +1,7 @@
- dnl We require that everyone use exactly the same Autoconf version so that
- dnl the internal functions defined and used by the main configure script
- dnl match those expected by the fragments.
--m4_define([GLIBC_AUTOCONF_VERSION], [2.68])
-+m4_define([GLIBC_AUTOCONF_VERSION], [2.69])
- m4_if(m4_defn([AC_AUTOCONF_VERSION]), GLIBC_AUTOCONF_VERSION, [],
-       [m4_fatal(m4_flatten(
- Exactly version GLIBC_AUTOCONF_VERSION of Autoconf is required but you have