refresh patches with -rc6
authorImre Kaloz <kaloz@openwrt.org>
Tue, 1 Mar 2011 11:24:08 +0000 (11:24 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 1 Mar 2011 11:24:08 +0000 (11:24 +0000)
SVN-Revision: 25805

17 files changed:
target/linux/generic/patches-2.6.38/008-jffs2_make_lzma_available.patch
target/linux/generic/patches-2.6.38/010-debloat_lzma.patch
target/linux/generic/patches-2.6.38/028-module_exports.patch
target/linux/generic/patches-2.6.38/029-arm_module_unresolved_weak_sym.patch
target/linux/generic/patches-2.6.38/065-rootfs_split.patch
target/linux/generic/patches-2.6.38/067-block2mtd_2.6.38_fix.patch
target/linux/generic/patches-2.6.38/180-netfilter_depends.patch
target/linux/generic/patches-2.6.38/218-mini_fo_fix_2_6_38.patch
target/linux/generic/patches-2.6.38/270-bridge_no_eap_forward.patch
target/linux/generic/patches-2.6.38/290-sched_act_connmark.patch
target/linux/generic/patches-2.6.38/300-bridge_port_isolate.patch
target/linux/generic/patches-2.6.38/420-gpiodev.patch
target/linux/generic/patches-2.6.38/750-glamo-headers.patch
target/linux/generic/patches-2.6.38/801-usb_serial_endpoint_size.patch
target/linux/generic/patches-2.6.38/922-gpiommc.patch
target/linux/generic/patches-2.6.38/970-ocf_kbuild_integration.patch
target/linux/generic/patches-2.6.38/980-vm_exports.patch

index 1aace2b79f9bf9e25beb09a51ac6ab3a73bd932f..e594039bf626bd588927100af5ec143216b774bd 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.38-rc6/fs/jffs2/Kconfig
-===================================================================
---- linux-2.6.38-rc6.orig/fs/jffs2/Kconfig     2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/fs/jffs2/Kconfig  2011-02-28 15:34:05.308257697 +0100
+--- a/fs/jffs2/Kconfig
++++ b/fs/jffs2/Kconfig
 @@ -139,6 +139,15 @@ config JFFS2_LZO
          This feature was added in July, 2007. Say 'N' if you need
          compatibility with older bootloaders or kernels.
@@ -18,10 +16,8 @@ Index: linux-2.6.38-rc6/fs/jffs2/Kconfig
  config JFFS2_RTIME
        bool "JFFS2 RTIME compression support" if JFFS2_COMPRESSION_OPTIONS
        depends on JFFS2_FS
-Index: linux-2.6.38-rc6/fs/jffs2/Makefile
-===================================================================
---- linux-2.6.38-rc6.orig/fs/jffs2/Makefile    2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/fs/jffs2/Makefile 2011-02-28 15:34:05.308257697 +0100
+--- a/fs/jffs2/Makefile
++++ b/fs/jffs2/Makefile
 @@ -18,4 +18,7 @@ jffs2-$(CONFIG_JFFS2_RUBIN)  += compr_rub
  jffs2-$(CONFIG_JFFS2_RTIME)   += compr_rtime.o
  jffs2-$(CONFIG_JFFS2_ZLIB)    += compr_zlib.o
@@ -30,10 +26,8 @@ Index: linux-2.6.38-rc6/fs/jffs2/Makefile
  jffs2-$(CONFIG_JFFS2_SUMMARY)   += summary.o
 +
 +CFLAGS_compr_lzma.o += -Iinclude/linux -Ilib/lzma
-Index: linux-2.6.38-rc6/fs/jffs2/compr.c
-===================================================================
---- linux-2.6.38-rc6.orig/fs/jffs2/compr.c     2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/fs/jffs2/compr.c  2011-02-28 15:34:05.309257668 +0100
+--- a/fs/jffs2/compr.c
++++ b/fs/jffs2/compr.c
 @@ -320,6 +320,9 @@ int __init jffs2_compressors_init(void)
  #ifdef CONFIG_JFFS2_LZO
        jffs2_lzo_init();
@@ -54,10 +48,8 @@ Index: linux-2.6.38-rc6/fs/jffs2/compr.c
  #ifdef CONFIG_JFFS2_LZO
        jffs2_lzo_exit();
  #endif
-Index: linux-2.6.38-rc6/fs/jffs2/compr.h
-===================================================================
---- linux-2.6.38-rc6.orig/fs/jffs2/compr.h     2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/fs/jffs2/compr.h  2011-02-28 15:34:05.309257668 +0100
+--- a/fs/jffs2/compr.h
++++ b/fs/jffs2/compr.h
 @@ -29,9 +29,9 @@
  #define JFFS2_DYNRUBIN_PRIORITY  20
  #define JFFS2_LZARI_PRIORITY     30
@@ -81,10 +73,8 @@ Index: linux-2.6.38-rc6/fs/jffs2/compr.h
 +#endif
  
  #endif /* __JFFS2_COMPR_H__ */
-Index: linux-2.6.38-rc6/fs/jffs2/compr_lzma.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/fs/jffs2/compr_lzma.c     2011-02-28 16:15:02.388304647 +0100
+--- /dev/null
++++ b/fs/jffs2/compr_lzma.c
 @@ -0,0 +1,128 @@
 +/*
 + * JFFS2 -- Journalling Flash File System, Version 2.
@@ -214,10 +204,8 @@ Index: linux-2.6.38-rc6/fs/jffs2/compr_lzma.c
 +      jffs2_unregister_compressor(&jffs2_lzma_comp);
 +      lzma_free_workspace();
 +}
-Index: linux-2.6.38-rc6/fs/jffs2/super.c
-===================================================================
---- linux-2.6.38-rc6.orig/fs/jffs2/super.c     2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/fs/jffs2/super.c  2011-02-28 15:34:05.310257639 +0100
+--- a/fs/jffs2/super.c
++++ b/fs/jffs2/super.c
 @@ -255,14 +255,41 @@ static int __init init_jffs2_fs(void)
        BUILD_BUG_ON(sizeof(struct jffs2_raw_inode) != 68);
        BUILD_BUG_ON(sizeof(struct jffs2_raw_summary) != 32);
@@ -263,10 +251,8 @@ Index: linux-2.6.38-rc6/fs/jffs2/super.c
  
        jffs2_inode_cachep = kmem_cache_create("jffs2_i",
                                             sizeof(struct jffs2_inode_info),
-Index: linux-2.6.38-rc6/include/linux/jffs2.h
-===================================================================
---- linux-2.6.38-rc6.orig/include/linux/jffs2.h        2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/include/linux/jffs2.h     2011-02-28 15:34:05.310257639 +0100
+--- a/include/linux/jffs2.h
++++ b/include/linux/jffs2.h
 @@ -46,6 +46,7 @@
  #define JFFS2_COMPR_DYNRUBIN  0x05
  #define JFFS2_COMPR_ZLIB      0x06
@@ -275,10 +261,8 @@ Index: linux-2.6.38-rc6/include/linux/jffs2.h
  /* Compatibility flags. */
  #define JFFS2_COMPAT_MASK 0xc000      /* What do to if an unknown nodetype is found */
  #define JFFS2_NODE_ACCURATE 0x2000
-Index: linux-2.6.38-rc6/include/linux/lzma.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/include/linux/lzma.h      2011-02-28 15:34:05.310257639 +0100
+--- /dev/null
++++ b/include/linux/lzma.h
 @@ -0,0 +1,62 @@
 +#ifndef __LZMA_H__
 +#define __LZMA_H__
@@ -342,10 +326,8 @@ Index: linux-2.6.38-rc6/include/linux/lzma.h
 +static ISzAlloc lzma_alloc = {p_lzma_malloc, p_lzma_free};
 +
 +#endif
-Index: linux-2.6.38-rc6/include/linux/lzma/LzFind.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/include/linux/lzma/LzFind.h       2011-02-28 16:14:14.392426757 +0100
+--- /dev/null
++++ b/include/linux/lzma/LzFind.h
 @@ -0,0 +1,115 @@
 +/* LzFind.h -- Match finder for LZ algorithms
 +2009-04-22 : Igor Pavlov : Public domain */
@@ -462,10 +444,8 @@ Index: linux-2.6.38-rc6/include/linux/lzma/LzFind.h
 +#endif
 +
 +#endif
-Index: linux-2.6.38-rc6/include/linux/lzma/LzHash.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/include/linux/lzma/LzHash.h       2011-02-28 15:34:05.311257610 +0100
+--- /dev/null
++++ b/include/linux/lzma/LzHash.h
 @@ -0,0 +1,54 @@
 +/* LzHash.h -- HASH functions for LZ algorithms
 +2009-02-07 : Igor Pavlov : Public domain */
@@ -521,10 +501,8 @@ Index: linux-2.6.38-rc6/include/linux/lzma/LzHash.h
 +  hash4Value = (temp ^ ((UInt32)cur[2] << 8) ^ (p->crc[cur[3]] << 5)) & (kHash4Size - 1); }
 +
 +#endif
-Index: linux-2.6.38-rc6/include/linux/lzma/LzmaDec.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/include/linux/lzma/LzmaDec.h      2011-02-28 16:14:14.408426387 +0100
+--- /dev/null
++++ b/include/linux/lzma/LzmaDec.h
 @@ -0,0 +1,231 @@
 +/* LzmaDec.h -- LZMA Decoder
 +2009-02-07 : Igor Pavlov : Public domain */
@@ -757,10 +735,8 @@ Index: linux-2.6.38-rc6/include/linux/lzma/LzmaDec.h
 +#endif
 +
 +#endif
-Index: linux-2.6.38-rc6/include/linux/lzma/LzmaEnc.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/include/linux/lzma/LzmaEnc.h      2011-02-28 16:14:14.430425878 +0100
+--- /dev/null
++++ b/include/linux/lzma/LzmaEnc.h
 @@ -0,0 +1,80 @@
 +/*  LzmaEnc.h -- LZMA Encoder
 +2009-02-07 : Igor Pavlov : Public domain */
@@ -842,10 +818,8 @@ Index: linux-2.6.38-rc6/include/linux/lzma/LzmaEnc.h
 +#endif
 +
 +#endif
-Index: linux-2.6.38-rc6/include/linux/lzma/Types.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/include/linux/lzma/Types.h        2011-02-28 15:34:05.313257550 +0100
+--- /dev/null
++++ b/include/linux/lzma/Types.h
 @@ -0,0 +1,226 @@
 +/* Types.h -- Basic types
 +2009-11-23 : Igor Pavlov : Public domain */
@@ -1073,10 +1047,8 @@ Index: linux-2.6.38-rc6/include/linux/lzma/Types.h
 +EXTERN_C_END
 +
 +#endif
-Index: linux-2.6.38-rc6/lib/Kconfig
-===================================================================
---- linux-2.6.38-rc6.orig/lib/Kconfig  2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/lib/Kconfig       2011-02-28 16:14:00.063757281 +0100
+--- a/lib/Kconfig
++++ b/lib/Kconfig
 @@ -108,6 +108,12 @@ config LZO_DECOMPRESS
  
  source "lib/xz/Kconfig"
@@ -1090,10 +1062,8 @@ Index: linux-2.6.38-rc6/lib/Kconfig
  #
  # These all provide a common interface (hence the apparent duplication with
  # ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
-Index: linux-2.6.38-rc6/lib/Makefile
-===================================================================
---- linux-2.6.38-rc6.orig/lib/Makefile 2011-02-22 02:25:52.000000000 +0100
-+++ linux-2.6.38-rc6/lib/Makefile      2011-02-28 15:34:05.313257550 +0100
+--- a/lib/Makefile
++++ b/lib/Makefile
 @@ -2,6 +2,16 @@
  # Makefile for some libs needed in the kernel.
  #
@@ -1120,10 +1090,8 @@ Index: linux-2.6.38-rc6/lib/Makefile
  
  lib-$(CONFIG_DECOMPRESS_GZIP) += decompress_inflate.o
  lib-$(CONFIG_DECOMPRESS_BZIP2) += decompress_bunzip2.o
-Index: linux-2.6.38-rc6/lib/lzma/LzFind.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/lib/lzma/LzFind.c 2011-02-28 16:14:14.447425484 +0100
+--- /dev/null
++++ b/lib/lzma/LzFind.c
 @@ -0,0 +1,761 @@
 +/* LzFind.c -- Match finder for LZ algorithms
 +2009-04-22 : Igor Pavlov : Public domain */
@@ -1886,10 +1854,8 @@ Index: linux-2.6.38-rc6/lib/lzma/LzFind.c
 +    vTable->Skip = (Mf_Skip_Func)Bt4_MatchFinder_Skip;
 +  }
 +}
-Index: linux-2.6.38-rc6/lib/lzma/LzmaDec.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/lib/lzma/LzmaDec.c        2011-02-28 16:14:14.463425114 +0100
+--- /dev/null
++++ b/lib/lzma/LzmaDec.c
 @@ -0,0 +1,999 @@
 +/* LzmaDec.c -- LZMA Decoder
 +2009-09-20 : Igor Pavlov : Public domain */
@@ -2890,10 +2856,8 @@ Index: linux-2.6.38-rc6/lib/lzma/LzmaDec.c
 +  LzmaDec_FreeProbs(&p, alloc);
 +  return res;
 +}
-Index: linux-2.6.38-rc6/lib/lzma/LzmaEnc.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/lib/lzma/LzmaEnc.c        2011-02-28 16:14:14.485424605 +0100
+--- /dev/null
++++ b/lib/lzma/LzmaEnc.c
 @@ -0,0 +1,2271 @@
 +/* LzmaEnc.c -- LZMA Encoder
 +2009-11-24 : Igor Pavlov : Public domain */
@@ -5166,10 +5130,8 @@ Index: linux-2.6.38-rc6/lib/lzma/LzmaEnc.c
 +  LzmaEnc_Destroy(p, alloc, allocBig);
 +  return res;
 +}
-Index: linux-2.6.38-rc6/lib/lzma/Makefile
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.38-rc6/lib/lzma/Makefile 2011-02-28 15:34:05.321257314 +0100
+--- /dev/null
++++ b/lib/lzma/Makefile
 @@ -0,0 +1,7 @@
 +lzma_compress-objs := LzFind.o LzmaEnc.o
 +lzma_decompress-objs := LzmaDec.o
index 18e4a51ee35b7226321708364bfa5466ab5c38cd..1e41661ebb60fdbfa7e0ba613e236e4e0d94405a 100644 (file)
  /* LzmaDecode
 --- a/lib/lzma/LzmaDec.c
 +++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p, 
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
    p->needFlush = 0;
  }
  
  {
    CLzmaProps propNew;
    RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p, 
+@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
    return SZ_OK;
  }
  
  void MatchFinder_Construct(CMatchFinder *p);
  
  /* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p, 
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
      UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
      ISzAlloc *alloc);
  void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
index ec07fb21281ea8e4c58c57f6c65de2881374e45c..5268115f01139950796aff2757a5b6496539980b 100644 (file)
@@ -28,7 +28,7 @@
  #ifndef SYMBOL_PREFIX
  #define VMLINUX_SYMBOL(sym) sym
  #else
-@@ -276,35 +297,35 @@
+@@ -274,35 +295,35 @@
        /* Kernel symbol table: Normal symbols */                       \
        __ksymtab         : AT(ADDR(__ksymtab) - LOAD_OFFSET) {         \
                VMLINUX_SYMBOL(__start___ksymtab) = .;                  \
@@ -69,7 +69,7 @@
                VMLINUX_SYMBOL(__stop___ksymtab_gpl_future) = .;        \
        }                                                               \
                                                                        \
-@@ -345,7 +366,7 @@
+@@ -343,7 +364,7 @@
                                                                        \
        /* Kernel symbol table: strings */                              \
          __ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) {       \
@@ -78,7 +78,7 @@
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -670,6 +691,9 @@
+@@ -677,6 +698,9 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \
@@ -90,7 +90,7 @@
        }
 --- a/include/linux/module.h
 +++ b/include/linux/module.h
-@@ -202,16 +202,24 @@ struct module_use {
+@@ -229,16 +229,24 @@ struct module_use {
  #define __CRC_SYMBOL(sym, sec)
  #endif
  
index 385522f058891fbdce7192eb5a2d4a17018f7872..fe7027c070a46531144fb320fd2ac73cbfa30efd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/kernel/module.c
 +++ b/arch/arm/kernel/module.c
-@@ -97,6 +97,10 @@ apply_relocate(Elf32_Shdr *sechdrs, cons
+@@ -98,6 +98,10 @@ apply_relocate(Elf32_Shdr *sechdrs, cons
                        return -ENOEXEC;
                }
  
index 74cf75aa609ec6d0d5f7fa221d5756acc3ee1b2c..bd94b18ad44a71220c23183227dda3dc3d825b40 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.38-rc6/drivers/mtd/Kconfig
-===================================================================
---- linux-2.6.38-rc6.orig/drivers/mtd/Kconfig  2011-02-28 16:14:12.668466637 +0100
-+++ linux-2.6.38-rc6/drivers/mtd/Kconfig       2011-02-28 16:26:55.463734599 +0100
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
 @@ -55,6 +55,16 @@ config MTD_PARTITIONS
  
  if MTD_PARTITIONS
@@ -19,10 +17,8 @@ Index: linux-2.6.38-rc6/drivers/mtd/Kconfig
  config MTD_REDBOOT_PARTS
        tristate "RedBoot partition table parsing"
        ---help---
-Index: linux-2.6.38-rc6/drivers/mtd/mtdpart.c
-===================================================================
---- linux-2.6.38-rc6.orig/drivers/mtd/mtdpart.c        2011-02-28 16:14:12.686466221 +0100
-+++ linux-2.6.38-rc6/drivers/mtd/mtdpart.c     2011-02-28 16:28:41.399156164 +0100
+--- a/drivers/mtd/mtdpart.c
++++ b/drivers/mtd/mtdpart.c
 @@ -29,6 +29,8 @@
  #include <linux/kmod.h>
  #include <linux/mtd/mtd.h>
@@ -260,10 +256,8 @@ Index: linux-2.6.38-rc6/drivers/mtd/mtdpart.c
  static DEFINE_SPINLOCK(part_parser_lock);
  static LIST_HEAD(part_parsers);
  
-Index: linux-2.6.38-rc6/drivers/mtd/devices/block2mtd.c
-===================================================================
---- linux-2.6.38-rc6.orig/drivers/mtd/devices/block2mtd.c      2011-02-28 16:15:07.477184360 +0100
-+++ linux-2.6.38-rc6/drivers/mtd/devices/block2mtd.c   2011-02-28 16:26:55.919727057 +0100
+--- a/drivers/mtd/devices/block2mtd.c
++++ b/drivers/mtd/devices/block2mtd.c
 @@ -30,6 +30,8 @@ struct block2mtd_dev {
        struct block_device *blkdev;
        struct mtd_info mtd;
@@ -552,10 +546,8 @@ Index: linux-2.6.38-rc6/drivers/mtd/devices/block2mtd.c
  
        part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
        part->name = dev->mtd.name;
-Index: linux-2.6.38-rc6/drivers/mtd/mtdchar.c
-===================================================================
---- linux-2.6.38-rc6.orig/drivers/mtd/mtdchar.c        2011-02-28 16:14:12.652467007 +0100
-+++ linux-2.6.38-rc6/drivers/mtd/mtdchar.c     2011-02-28 16:15:07.503183744 +0100
+--- a/drivers/mtd/mtdchar.c
++++ b/drivers/mtd/mtdchar.c
 @@ -841,6 +841,13 @@ static int mtd_ioctl(struct file *file,
                file->f_pos = 0;
                break;
@@ -570,10 +562,8 @@ Index: linux-2.6.38-rc6/drivers/mtd/mtdchar.c
  
        case OTPGETREGIONCOUNT:
        case OTPGETREGIONINFO:
-Index: linux-2.6.38-rc6/include/linux/mtd/mtd.h
-===================================================================
---- linux-2.6.38-rc6.orig/include/linux/mtd/mtd.h      2011-02-28 16:14:12.613467908 +0100
-+++ linux-2.6.38-rc6/include/linux/mtd/mtd.h   2011-02-28 16:26:51.223804561 +0100
+--- a/include/linux/mtd/mtd.h
++++ b/include/linux/mtd/mtd.h
 @@ -125,6 +125,7 @@ struct nand_ecclayout {
        struct nand_oobfree oobfree[MTD_MAX_OOBFREE_ENTRIES_LARGE];
  };
@@ -592,10 +582,8 @@ Index: linux-2.6.38-rc6/include/linux/mtd/mtd.h
        /* If the driver is something smart, like UBI, it may need to maintain
         * its own reference counting. The below functions are only for driver.
         * The driver may register its callbacks. These callbacks are not
-Index: linux-2.6.38-rc6/include/linux/mtd/partitions.h
-===================================================================
---- linux-2.6.38-rc6.orig/include/linux/mtd/partitions.h       2011-02-28 16:14:12.635467400 +0100
-+++ linux-2.6.38-rc6/include/linux/mtd/partitions.h    2011-02-28 16:26:55.382735938 +0100
+--- a/include/linux/mtd/partitions.h
++++ b/include/linux/mtd/partitions.h
 @@ -34,12 +34,14 @@
   * erasesize aligned (e.g. use MTDPART_OFS_NEXTBLK).
   */
@@ -619,10 +607,8 @@ Index: linux-2.6.38-rc6/include/linux/mtd/partitions.h
  
  /*
   * Functions dealing with the various ways of partitioning the space
-Index: linux-2.6.38-rc6/include/mtd/mtd-abi.h
-===================================================================
---- linux-2.6.38-rc6.orig/include/mtd/mtd-abi.h        2011-02-28 16:14:12.596468301 +0100
-+++ linux-2.6.38-rc6/include/mtd/mtd-abi.h     2011-02-28 16:15:07.505183696 +0100
+--- a/include/mtd/mtd-abi.h
++++ b/include/mtd/mtd-abi.h
 @@ -127,6 +127,7 @@ struct otp_info {
  #define MEMWRITEOOB64         _IOWR('M', 21, struct mtd_oob_buf64)
  #define MEMREADOOB64          _IOWR('M', 22, struct mtd_oob_buf64)
index 22b845f777d3bc2c9627476ef277e48bb6d66d08..1a052b3f43a670b40911daa7356464200386c7fd 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.38-rc6/drivers/mtd/devices/block2mtd.c
-===================================================================
---- linux-2.6.38-rc6.orig/drivers/mtd/devices/block2mtd.c      2011-02-28 16:41:59.839603348 +0100
-+++ linux-2.6.38-rc6/drivers/mtd/devices/block2mtd.c   2011-02-28 16:47:59.637698484 +0100
+--- a/drivers/mtd/devices/block2mtd.c
++++ b/drivers/mtd/devices/block2mtd.c
 @@ -264,12 +264,13 @@ static int _open_bdev(struct block2mtd_d
        bdev = blkdev_get_by_path(dev->devname, mode, dev);
  #ifndef MODULE
index 22bf51c3a9006bad65c663942182d7a7830985db..d270e9020bf575526eb0104b9d19d57407c75e22 100644 (file)
@@ -8,7 +8,7 @@
        depends on NETFILTER_ADVANCED
        help
          H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -570,7 +569,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -558,7 +557,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
index 44d5622a03b46763c3d406b18b40b0fc4f1a1341..ad257f0847d7284964913eefe5323a2ed3f95e61 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.38-rc6/fs/mini_fo/dentry.c
-===================================================================
---- linux-2.6.38-rc6.orig/fs/mini_fo/dentry.c  2011-02-28 15:34:06.542221268 +0100
-+++ linux-2.6.38-rc6/fs/mini_fo/dentry.c       2011-02-28 16:05:42.307346739 +0100
+--- a/fs/mini_fo/dentry.c
++++ b/fs/mini_fo/dentry.c
 @@ -78,7 +78,7 @@ mini_fo_d_revalidate(dentry_t *dentry, i
  
  
index 883a7d06492c8158b6fd6e76a541586e317ee710..dac898276d326e3217a661559d4183895f681560 100644 (file)
@@ -12,4 +12,4 @@
 +      } else if (is_multicast_ether_addr(dest)) {
                mdst = br_mdb_get(br, skb);
                if (mdst || BR_INPUT_SKB_CB_MROUTERS_ONLY(skb)) {
-                       if ((mdst && !hlist_unhashed(&mdst->mglist)) ||
+                       if ((mdst && mdst->mglist) ||
index 013c116c4a22147b9ba902f9e1fdf2cbbad07cc6..33429cb43087f7ba4eeaa8e400ecc7bebd04fe3d 100644 (file)
 +module_exit(connmark_cleanup_module);
 --- a/net/sched/Kconfig
 +++ b/net/sched/Kconfig
-@@ -559,6 +559,18 @@
+@@ -559,6 +559,18 @@ config NET_ACT_CSUM
          To compile this code as a module, choose M here: the
          module will be called act_csum.
  
        depends on NET_CLS_U32 || NET_CLS_FW
 --- a/net/sched/Makefile
 +++ b/net/sched/Makefile
-@@ -16,6 +16,7 @@
+@@ -16,6 +16,7 @@ obj-$(CONFIG_NET_ACT_PEDIT)  += act_pedit
  obj-$(CONFIG_NET_ACT_SIMP)    += act_simple.o
  obj-$(CONFIG_NET_ACT_SKBEDIT) += act_skbedit.o
  obj-$(CONFIG_NET_ACT_CSUM)    += act_csum.o
index de1cac60e13b673ca25c5ebaa7b96ed407cce953..c051a29f2d2192cd30d7ff8f97eed923f0c6efca 100644 (file)
@@ -43,7 +43,7 @@
  #endif
 --- a/net/bridge/br_input.c
 +++ b/net/bridge/br_input.c
-@@ -91,7 +91,8 @@ int br_handle_frame_finish(struct sk_buf
+@@ -95,7 +95,8 @@ int br_handle_frame_finish(struct sk_buf
                        skb2 = skb;
  
                br->dev->stats.multicast++;
@@ -55,7 +55,7 @@
                skb = NULL;
 --- a/net/bridge/br_forward.c
 +++ b/net/bridge/br_forward.c
-@@ -113,7 +113,7 @@ void br_deliver(const struct net_bridge_
+@@ -109,7 +109,7 @@ void br_deliver(const struct net_bridge_
  /* called with rcu_read_lock */
  void br_forward(const struct net_bridge_port *to, struct sk_buff *skb, struct sk_buff *skb0)
  {
@@ -64,7 +64,7 @@
                if (skb0)
                        deliver_clone(to, skb, __br_forward);
                else
-@@ -168,7 +168,8 @@ out:
+@@ -164,7 +164,8 @@ out:
  static void br_flood(struct net_bridge *br, struct sk_buff *skb,
                     struct sk_buff *skb0,
                     void (*__packet_hook)(const struct net_bridge_port *p,
@@ -74,7 +74,7 @@
  {
        struct net_bridge_port *p;
        struct net_bridge_port *prev;
-@@ -176,6 +177,9 @@ static void br_flood(struct net_bridge *
+@@ -172,6 +173,9 @@ static void br_flood(struct net_bridge *
        prev = NULL;
  
        list_for_each_entry_rcu(p, &br->port_list, list) {
@@ -84,7 +84,7 @@
                prev = maybe_deliver(prev, p, skb, __packet_hook);
                if (IS_ERR(prev))
                        goto out;
-@@ -199,14 +203,14 @@ out:
+@@ -195,14 +199,14 @@ out:
  /* called with rcu_read_lock */
  void br_flood_deliver(struct net_bridge *br, struct sk_buff *skb)
  {
index 5c1f3a6c286244e79f8e094938854bb68a9e664c..900358e6b082b2784bcc791f244b49630807bb1e 100644 (file)
@@ -17,7 +17,7 @@
        depends on BLOCK
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
-@@ -69,6 +69,7 @@ obj-$(CONFIG_NWFLASH)                += nwflash.o
+@@ -70,6 +70,7 @@ obj-$(CONFIG_NWFLASH)                += nwflash.o
  obj-$(CONFIG_SCx200_GPIO)     += scx200_gpio.o
  obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
  obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
index 64908ecb4f36b7ab79a0ed2f997edbf71b0bad7e..f3cf973651cdeb666e3c9bbad2eda574ceb6454b 100644 (file)
@@ -10,7 +10,7 @@
  #define FB_ACCEL_NEOMAGIC_NM2093 92   /* NeoMagic NM2093              */
 --- a/include/linux/Kbuild
 +++ b/include/linux/Kbuild
-@@ -141,6 +141,8 @@ header-y += generic_serial.h
+@@ -142,6 +142,8 @@ header-y += generic_serial.h
  header-y += genetlink.h
  header-y += gfs2_ondisk.h
  header-y += gigaset_dev.h
index 45a096d873fe87d1409ae470bbac5e369868ffc6..3725b922ce3b6a8d64e0c299006bb92af1458429 100644 (file)
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1388,3 +1389,5 @@ MODULE_LICENSE("GPL");
+@@ -1392,3 +1393,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index fe27f3b6e50ad2538c2ca976e6c59abc8bfbc7ee..d0e9e214b8c73aac8a048cbca59e97e38c503dd9 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -2855,6 +2855,11 @@ T:      git git://git.kernel.org/pub/scm/linu
+@@ -2867,6 +2867,11 @@ T:      git git://git.kernel.org/pub/scm/linu
  S:    Maintained
  F:    drivers/media/video/gspca/
  
index 72c546ea4f5ae84f2c371396bcb8892e161c68da..3c322f3d1407b19f84c7f6e1e2226f98f4231bd0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -870,3 +870,6 @@ config CRYPTO_USER_API_SKCIPHER
+@@ -866,3 +866,6 @@ config CRYPTO_USER_API_SKCIPHER
  source "drivers/crypto/Kconfig"
  
  endif # if CRYPTO
index 4d10bc81c25769bf8e409646ed29e9756a9b82c4..811b23b349a3fcd495237b42140d8e1371a1d695 100644 (file)
@@ -94,7 +94,7 @@
  
  /**
   * zap_vma_ptes - remove ptes mapping the vma
-@@ -2692,6 +2693,7 @@ int vmtruncate_range(struct inode *inode
+@@ -2690,6 +2691,7 @@ int vmtruncate_range(struct inode *inode
  
        return 0;
  }