fix kmod packaging for packages where some KCONFIG symbols are set to y
authorFelix Fietkau <nbd@openwrt.org>
Thu, 2 Aug 2007 13:38:03 +0000 (13:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 2 Aug 2007 13:38:03 +0000 (13:38 +0000)
SVN-Revision: 8316

include/kernel.mk

index 407109f38bcfc6182c2147ca02c0169255e62001..dfdd277dc72d312df553df016ca8f81179abe60b 100644 (file)
@@ -99,7 +99,7 @@ define KernelPackage
     $(call KernelPackage/$(1)/$(BOARD)-$(KERNEL))
   endef
 
-  ifeq ($(filter y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),)
+  ifneq ($(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)