ath79: NanoBeam M5 fix target_devices
authorJan-Niklas Burfeind <git@aiyionpri.me>
Sat, 21 May 2022 15:17:34 +0000 (17:17 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sat, 21 May 2022 17:24:40 +0000 (19:24 +0200)
Update the name of for the Ubiquiti NanoBeam M5 to match the
auto-generated one at runtime. Otherwise sysupgrade complains about
mismatching device names.

This also required renaming the DTS.

Signed-off-by: Jan-Niklas Burfeind <git@aiyionpri.me>
target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5-xw.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5.dts [deleted file]
target/linux/ath79/image/generic-ubnt.mk

diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5-xw.dts
new file mode 100644 (file)
index 0000000..86a5e3a
--- /dev/null
@@ -0,0 +1,26 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9342_ubnt_xw.dtsi"
+
+/ {
+       compatible = "ubnt,nanobeam-m5-xw", "ubnt,xw", "qca,ar9342";
+       model = "Ubiquiti NanoBeam M5 (XW)";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0x1>;
+
+       phy1: ethernet-phy@1 {
+               reg = <1>;
+               phy-mode = "mii";
+               reset-gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&phy1>;
+};
diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5.dts b/target/linux/ath79/dts/ar9342_ubnt_nanobeam-m5.dts
deleted file mode 100644 (file)
index 86a5e3a..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "ar9342_ubnt_xw.dtsi"
-
-/ {
-       compatible = "ubnt,nanobeam-m5-xw", "ubnt,xw", "qca,ar9342";
-       model = "Ubiquiti NanoBeam M5 (XW)";
-};
-
-&mdio0 {
-       status = "okay";
-
-       phy-mask = <0x1>;
-
-       phy1: ethernet-phy@1 {
-               reg = <1>;
-               phy-mode = "mii";
-               reset-gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       phy-handle = <&phy1>;
-};
index 3713f538f1c1df1f7435eb9e58aa826c83021dce..2381d925674789deb38892b44aae0319e2dbeff2 100644 (file)
@@ -255,13 +255,13 @@ define Device/ubnt_nanobeam-ac-xc
 endef
 TARGET_DEVICES += ubnt_nanobeam-ac-xc
 
-define Device/ubnt_nanobeam-m5
+define Device/ubnt_nanobeam-m5-xw
   $(Device/ubnt-xw)
   DEVICE_MODEL := NanoBeam M5
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += loco-m-xw
 endef
-TARGET_DEVICES += ubnt_nanobeam-m5
+TARGET_DEVICES += ubnt_nanobeam-m5-xw
 
 define Device/ubnt_nanobridge-m
   $(Device/ubnt-xm)