apm821xx: sata: boot-part feature integration
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 27 Dec 2018 18:12:23 +0000 (19:12 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Tue, 1 Jan 2019 15:39:59 +0000 (16:39 +0100)
This patch adds the boot-part feature to the apm82181 sata target.
This makes it possible to configure the boot partition size with
the generic CONFIG_TARGET_KERNEL_PARTSIZE symbol.

Please note: For people using custom images: Just like with
CONFIG_TARGET_ROOTFS_PARTSIZE changing the value can cause
sysupgrade to repartition the device!

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
config/Config-images.in
target/linux/apm821xx/image/Makefile
target/linux/apm821xx/sata/target.mk

index 6fa9a67cb644f986a7f207cbf2e366e4062f8462..245aed098b36b462583a1669b742d138725bcf2f 100644 (file)
@@ -269,6 +269,7 @@ menu "Target Images"
        config TARGET_KERNEL_PARTSIZE
                int "Kernel partition size (in MB)"
                depends on GRUB_IMAGES || USES_BOOT_PART
+               default 8 if TARGET_apm821xx_sata
                default 16
 
        config TARGET_ROOTFS_PARTSIZE
index 1f054ab5b9e99d659985b697b484f9a3618b4ad7..60b1f78a3b117d50c0867f44e00d68b88c146d4a 100644 (file)
@@ -15,7 +15,9 @@ define Build/boot-img
        $(CP) $(IMAGE_KERNEL).dtb $@.bootdir/boot/$(DEVICE_DTB)
        $(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
 
-       genext2fs --block-size $(BLOCKSIZE:%k=%Ki) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
+       genext2fs --block-size $(BLOCKSIZE:%k=%Ki) \
+               --size-in-blocks $$((1024 * $(CONFIG_TARGET_KERNEL_PARTSIZE))) \
+               --root $@.bootdir $@.boot
 
        # convert it to revision 1 - needed for u-boot ext2load
        $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot
@@ -49,7 +51,7 @@ define Build/export-dtb
 endef
 
 define Build/hdd-img
-       ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS) $(BOOT_SIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+       ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS) $(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 endef
 
 define Build/MerakiAdd-dtb
@@ -230,7 +232,6 @@ define Device/wd_mybooklive
   DTB_SIZE := 16384
   KERNEL := kernel-bin | dtb | gzip | uImage gzip
   KERNEL_INITRAMFS := kernel-bin | gzip | dtb | MuImage-initramfs gzip
-  BOOT_SIZE := 8
   IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
   ARTIFACTS := kernel.dtb
   DEVICE_DTB := apollo3g.dtb
index 84de4b2ea646837147d7e6a6f437c07095b10973..790746c4800b4792c8093581c1a4cd83cc329b33 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME := Devices which boot from SATA (NAS)
-FEATURES += ext4 usb ramdisk squashfs rootfs-part
+FEATURES += ext4 usb ramdisk squashfs rootfs-part boot-part
 DEFAULT_PACKAGES += badblocks block-mount e2fsprogs \
                    kmod-dm kmod-md-mod partx-utils mkf2fs f2fsck