x86: fix missing squashfs and ext4 rootfs images
authorPaul Spooren <mail@aparcar.org>
Wed, 25 Mar 2020 19:25:10 +0000 (09:25 -1000)
committerPetr Štetiar <ynezz@true.cz>
Sat, 28 Mar 2020 12:20:05 +0000 (13:20 +0100)
The previous rework of x86 image creation done in commit cb007a7bf619
("x86: switch image generation to new code") removed images of separate
squashfs and ext4 filesystems which are handy for example in testing
under QEMU.

So this patch adds back creation of those missing rootfs images for ext4
and squashfs based filesystems.

Fixes: cb007a7bf619 ("x86: switch image generation to new code")
Signed-off-by: Paul Spooren <mail@aparcar.org>
[commit subject and description tweaks]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/x86/image/Makefile

index c29eef9c7aecdc6063e22f66e8718db7291229ee..c0c5c8323ac900b61cf3d6d634a60fe97e20c56b 100644 (file)
@@ -99,10 +99,12 @@ define Device/Default
   IMAGE/combined.img.gz := grub-config pc | combined | grub-install | gzip
   IMAGE/combined.vdi := grub-config pc | combined | grub-install | qemu-image vdi
   IMAGE/combined.vmdk := grub-config pc | combined | grub-install | qemu-image vmdk
+  IMAGE/rootfs.img := append-rootfs
+  IMAGE/rootfs.img.gz := append-rootfs | gzip
   ifeq ($(CONFIG_TARGET_IMAGES_GZIP),y)
-    IMAGES := combined.img.gz
+    IMAGES := combined.img.gz rootfs.img.gz
   else
-    IMAGES := combined.img
+    IMAGES := combined.img rootfs.img
   endif
   KERNEL := kernel-bin
   KERNEL_INSTALL := 1