ralink: cleanup ethernet Makefile/Kconfig
authorJohn Crispin <john@openwrt.org>
Thu, 6 Nov 2014 09:31:09 +0000 (09:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 6 Nov 2014 09:31:09 +0000 (09:31 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 43195

target/linux/ramips/files/drivers/net/ethernet/ralink/Kconfig
target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
target/linux/ramips/mt7620a/config-3.14
target/linux/ramips/mt7620n/config-3.14

index ca2c9ad6273c158f5afaacddc9af5aef9125d658..b25a12a1289f76db5f80f37a092e7e978fc9ca9c 100644 (file)
@@ -1,30 +1,54 @@
 config NET_RALINK
-       tristate "Ralink RT288X/RT3X5X/RT3662/RT3883/MT7620 ethernet driver"
+       tristate "Ralink ethernet driver"
        depends on RALINK
        help
          This driver supports the ethernet mac inside the ralink wisocs
 
 if NET_RALINK
+choice
+       prompt "MAC type"
+
+config NET_RALINK_RT288X
+       bool "RT288X"
+       depends on SOC_RT288X
+
+config NET_RALINK_RT305X
+       bool "RT305X"
+       depends on (SOC_RT305X || SOC_MT7620)
+
+config NET_RALINK_RT3883
+       bool "RT3883"
+       depends on SOC_RT3883
+
+config NET_RALINK_MT7620
+       bool "MT7620"
+       depends on SOC_MT7620
+
+config NET_RALINK_MT7621
+       bool "MT7621"
+       depends on SOC_MT7621
+
+endchoice
 
 config NET_RALINK_MDIO
        def_bool NET_RALINK
-       depends on (SOC_RT288X || SOC_RT3883 || SOC_MT7620)
+       depends on (NET_RALINK_RT288X || NET_RALINK_RT3883 || NET_RALINK_MT7620 || NET_RALINK_MT7621)
        select PHYLIB
 
 config NET_RALINK_MDIO_RT2880
        def_bool NET_RALINK
-       depends on (SOC_RT288X || SOC_RT3883)
+       depends on (NET_RALINK_RT288X || NET_RALINK_RT3883)
        select NET_RALINK_MDIO
 
 config NET_RALINK_ESW_RT3052
        def_bool NET_RALINK
-       depends on SOC_RT305X
+       depends on NET_RALINK_RT305X
        select PHYLIB
        select SWCONFIG
 
 config NET_RALINK_GSW_MT7620
        def_bool NET_RALINK
-       depends on SOC_MT7620
+       depends on NET_RALINK_MT7620 || NET_RALINK_MT7621
        select NET_RALINK_MDIO
        select PHYLIB
        select SWCONFIG
index 01884a7836d38afb1b56c2206daeafe408de9c98..54a07e7c2b4e221569b4ad9c9a5f416c9db791fc 100644 (file)
@@ -10,9 +10,10 @@ ralink-eth-$(CONFIG_NET_RALINK_MDIO_RT2880)  += mdio_rt2880.o
 ralink-eth-$(CONFIG_NET_RALINK_ESW_RT3052)     += esw_rt3052.o
 ralink-eth-$(CONFIG_NET_RALINK_GSW_MT7620)     += gsw_mt7620a.o mt7530.o
 
-ralink-eth-$(CONFIG_SOC_RT288X)                        += soc_rt2880.o
-ralink-eth-$(CONFIG_SOC_RT305X)                        += soc_rt305x.o
-ralink-eth-$(CONFIG_SOC_RT3883)                        += soc_rt3883.o
-ralink-eth-$(CONFIG_SOC_MT7620)                        += soc_mt7620.o
+ralink-eth-$(CONFIG_NET_RALINK_RT288X)         += soc_rt2880.o
+ralink-eth-$(CONFIG_NET_RALINK_RT305X)         += soc_rt305x.o
+ralink-eth-$(CONFIG_NET_RALINK_RT3883)         += soc_rt3883.o
+ralink-eth-$(CONFIG_NET_RALINK_MT7620)         += soc_mt7620.o
+ralink-eth-$(CONFIG_NET_RALINK_MT7621)         += soc_mt7621.o
 
 obj-$(CONFIG_NET_RALINK)                       += ralink-eth.o
index a3411a70db463ae2a85a7730282e72e0dc1d500a..b0f81487d30f9b1d0ec99f1437adfd5ccdbdf09c 100644 (file)
@@ -121,6 +121,8 @@ CONFIG_NEED_PER_CPU_KM=y
 CONFIG_NET_RALINK=y
 CONFIG_NET_RALINK_GSW_MT7620=y
 CONFIG_NET_RALINK_MDIO=y
+CONFIG_NET_RALINK_MT7620=y
+# CONFIG_NET_RALINK_RT305X is not set
 CONFIG_NLS=m
 CONFIG_NO_GENERIC_PCI_IOPORT_MAP=y
 CONFIG_OF=y
index f21312f976e57ddf70f258c757b24f0a2029a99e..1a3155ebbac2675d1d3e6daed85b7c86bc871e9d 100644 (file)
@@ -119,6 +119,8 @@ CONFIG_NEED_PER_CPU_KM=y
 CONFIG_NET_RALINK=y
 CONFIG_NET_RALINK_GSW_MT7620=y
 CONFIG_NET_RALINK_MDIO=y
+CONFIG_NET_RALINK_MT7620=y
+# CONFIG_NET_RALINK_RT305X is not set
 CONFIG_NLS=m
 CONFIG_OF=y
 CONFIG_OF_ADDRESS=y