omap24xx: Start watchdog with RT priority
authorMichael Büsch <mb@bu3sch.de>
Sun, 6 Mar 2011 10:40:04 +0000 (10:40 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sun, 6 Mar 2011 10:40:04 +0000 (10:40 +0000)
SVN-Revision: 25882

target/linux/omap24xx/base-files/etc/init.d/watchdog
target/linux/omap24xx/profiles/100-n810.mk

index fa5dc4365a20b4e113aedb96640ef1d481a0a5b0..d1ad1a175292bda8d9e7b351eda5169965bdea7d 100755 (executable)
@@ -1,13 +1,15 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2008-2010 OpenWrt.org
 
-START=97
+START=25
+
 start() {
-       if ! [ -c /dev/watchdog -a -x /sbin/watchdog ]; then
+       [ -c /dev/watchdog -a -x /sbin/watchdog ] || {
                echo "WARNING: Watchdog not available. System will reboot soon!"
-       else
-               /sbin/watchdog -T 63 -t 53 /dev/watchdog
-       fi
+               return 1
+       }
+       /sbin/watchdog -T 60 -t 50 /dev/watchdog
+       [ -x /usr/bin/schedtool ] && /usr/bin/schedtool -R -p 60 -n -20 $(pidof watchdog)
 }
 
 stop() {
index 38c3749f02bc4eb516f8a0c7fb6c2536eb5a0fc3..648b9e398166ba18f2c627b09a14f0ab57852871 100644 (file)
@@ -17,7 +17,8 @@ define Profile/n810-base
        kmod-input-evdev \
        kmod-leds-gpio \
        kmod-usb-tahvo kmod-usb-eth-gadget kmod-usb-net kmod-usb-net-cdc-ether \
-       kmod-n810bm maemo-kexec calvaria
+       kmod-n810bm maemo-kexec calvaria \
+       schedtool
 endef
 
 define Profile/n810-base/Description