cmake: skip build system check on compile
authorFelix Fietkau <nbd@nbd.name>
Mon, 20 Feb 2017 11:13:51 +0000 (12:13 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 21 Feb 2017 12:03:20 +0000 (13:03 +0100)
cmake checks the build system and its variables on its own to detect if
the makefiles need to be regenerated.
Unfortunately this can invalidate overrides passed in the
Build/Configure step. On non-Linux systems this breaks the build when
switching between targets of the same package architecture.

Fix this by forcibly disabling the build system check and relying on the
LEDE build system to take care of these things

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/cmake.mk

index 80c1b05937410cb9fce20e7b759577480cf390e7..900dae1d4afc6007f8ac04179dd7f0922a07d4fa 100644 (file)
@@ -107,3 +107,7 @@ define Host/Configure/Default
                $(HOST_CMAKE_SOURCE_DIR) \
        )
 endef
+
+MAKE_FLAGS += \
+       CMAKE_COMMAND='$$(if $$(CMAKE_DISABLE_$$@),:,$(STAGING_DIR_HOST)/bin/cmake)' \
+       CMAKE_DISABLE_cmake_check_build_system=1