kernel: refresh patches
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 31 Jul 2014 21:33:58 +0000 (21:33 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 31 Jul 2014 21:33:58 +0000 (21:33 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 41909

17 files changed:
target/linux/generic/patches-3.10/070-net_bridge_backports.patch
target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.10/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-3.10/657-qdisc_reduce_truesize.patch
target/linux/generic/patches-3.13/412-mtd-partial_eraseblock_unlock.patch
target/linux/generic/patches-3.3/020-ssb_update.patch
target/linux/generic/patches-3.3/478-mtd-partial_eraseblock_unlock.patch
target/linux/generic/patches-3.3/831-ledtrig_netdev.patch
target/linux/generic/patches-3.8/001-ARM-7668-1-fix-memset-related-crashes-caused-by-rece.patch
target/linux/generic/patches-3.8/002-ARM-7668-1-fix-memset-related-crashes-caused-by-rece.patch
target/linux/generic/patches-3.8/020-ssb_update.patch
target/linux/generic/patches-3.8/478-mtd-partial_eraseblock_unlock.patch
target/linux/generic/patches-3.8/831-ledtrig_netdev.patch
target/linux/generic/patches-3.9/020-ssb_update.patch
target/linux/generic/patches-3.9/478-mtd-partial_eraseblock_unlock.patch
target/linux/generic/patches-3.9/831-ledtrig_netdev.patch
target/linux/generic/patches-3.9/903-debloat_direct_io.patch

index f303c3a09406a559d9686de118fd181005701888..6f7e141c5e8ce405f959d969c72a73ef37fa1f55 100644 (file)
@@ -555,7 +555,7 @@ Date:   Tue May 21 21:52:54 2013 +0000
  }
  #endif
  
-@@ -1473,8 +1569,14 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1473,8 +1569,14 @@ static int br_multicast_ipv6_rcv(struct
         *  - MLD has always Router Alert hop-by-hop option
         *  - But we do not support jumbrograms.
         */
@@ -918,7 +918,7 @@ Date:   Tue May 21 21:52:54 2013 +0000
  static ssize_t show_multicast_querier(struct device *d,
                                      struct device_attribute *attr,
                                      char *buf)
-@@ -734,6 +759,7 @@ static struct attribute *bridge_attrs[] 
+@@ -734,6 +759,7 @@ static struct attribute *bridge_attrs[]
        &dev_attr_multicast_router.attr,
        &dev_attr_multicast_snooping.attr,
        &dev_attr_multicast_querier.attr,
index e38e0016898ad20761fca97e828bd80b708d26dd..407c980e014bbdb695fe48199791c672d14d9082 100644 (file)
@@ -25,7 +25,7 @@
          Ethernet bridge, which means that the different Ethernet segments it
 --- a/net/ipv6/Makefile
 +++ b/net/ipv6/Makefile
-@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o 
+@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
  obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
  
  obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
index 9ee6b01df071a7c6576612b625e4074c79fa22d8..c4611996021c3ff556c5a6bc9eae30dd141908a9 100644 (file)
  }
  #endif
  
-@@ -1447,6 +1474,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1447,6 +1474,7 @@ static int br_multicast_ipv4_rcv(struct
                                 struct net_bridge_port *port,
                                 struct sk_buff *skb)
  {
        struct sk_buff *skb2 = skb;
        const struct iphdr *iph;
        struct igmphdr *ih;
-@@ -1522,7 +1550,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1522,7 +1550,7 @@ static int br_multicast_ipv4_rcv(struct
        case IGMP_HOST_MEMBERSHIP_REPORT:
        case IGMPV2_HOST_MEMBERSHIP_REPORT:
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb2);
-@@ -1531,7 +1559,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1531,7 +1559,7 @@ static int br_multicast_ipv4_rcv(struct
                err = br_ip4_multicast_query(br, port, skb2);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
                break;
        }
  
-@@ -1548,6 +1576,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1548,6 +1576,7 @@ static int br_multicast_ipv6_rcv(struct
                                 struct net_bridge_port *port,
                                 struct sk_buff *skb)
  {
        struct sk_buff *skb2;
        const struct ipv6hdr *ip6h;
        u8 icmp6_type;
-@@ -1659,7 +1688,8 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1659,7 +1688,8 @@ static int br_multicast_ipv6_rcv(struct
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
            }
        case ICMPV6_MLD2_REPORT:
-@@ -1676,7 +1706,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1676,7 +1706,7 @@ static int br_multicast_ipv6_rcv(struct
                        goto out;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
index e27d0a04d6c0e6edbd61b70282ab86721d90bfd2..93ff7ba71d3bddd622b8c95c3d732ea74b9aefb4 100644 (file)
@@ -24,7 +24,7 @@ commont qdiscs.
        }
 --- a/net/sched/sch_fifo.c
 +++ b/net/sched/sch_fifo.c
-@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff 
+@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
  
  static int pfifo_enqueue(struct sk_buff *skb, struct Qdisc *sch)
  {
index 134f65715e95bd320a449d3fcfb99a11d7b391b5..87c8257fe115d55ae72c1476d01f9288591ecc59 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
+@@ -332,7 +332,14 @@ static int part_lock(struct mtd_info *mt
  static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
  {
        struct mtd_part *part = PART(mtd);
index eac9807f182fcd3e51f963d61896a7ce51689ed9..5354cc7b2532d301e91ca06d505d2a625fae27f1 100644 (file)
        }
  
        if (updown_tab) {
-@@ -516,8 +524,8 @@ void ssb_pmu_init(struct ssb_chipcommon 
+@@ -516,8 +524,8 @@ void ssb_pmu_init(struct ssb_chipcommon
        pmucap = chipco_read32(cc, SSB_CHIPCO_PMU_CAP);
        cc->pmu.rev = (pmucap & SSB_CHIPCO_PMU_CAP_REVISION);
  
  }
  
  static void dump_irq(struct ssb_bus *bus)
-@@ -178,9 +199,9 @@ static void ssb_mips_serial_init(struct 
+@@ -178,9 +199,9 @@ static void ssb_mips_serial_init(struct
  {
        struct ssb_bus *bus = mcore->dev->bus;
  
                mcore->nr_serial_ports = ssb_chipco_serial_init(&bus->chipco, mcore->serial_ports);
        else
                mcore->nr_serial_ports = 0;
-@@ -189,17 +210,42 @@ static void ssb_mips_serial_init(struct 
+@@ -189,17 +210,42 @@ static void ssb_mips_serial_init(struct
  static void ssb_mips_flash_detect(struct ssb_mipscore *mcore)
  {
        struct ssb_bus *bus = mcore->dev->bus;
        sprom_extract_r458(out, in);
  
        /* TODO - get remaining rev 8 stuff needed */
-@@ -641,7 +753,7 @@ static int sprom_extract(struct ssb_bus 
+@@ -641,7 +753,7 @@ static int sprom_extract(struct ssb_bus
        memset(out, 0, sizeof(*out));
  
        out->revision = in[size - 1] & 0x00FF;
        memset(out->et0mac, 0xFF, 6);           /* preset et0 and et1 mac */
        memset(out->et1mac, 0xFF, 6);
  
-@@ -650,7 +762,7 @@ static int sprom_extract(struct ssb_bus 
+@@ -650,7 +762,7 @@ static int sprom_extract(struct ssb_bus
                 * number stored in the SPROM.
                 * Always extract r1. */
                out->revision = 1;
        }
  
        switch (out->revision) {
-@@ -667,9 +779,8 @@ static int sprom_extract(struct ssb_bus 
+@@ -667,9 +779,8 @@ static int sprom_extract(struct ssb_bus
                sprom_extract_r8(out, in);
                break;
        default:
index de4481a93a6d52a6b6e19374f5abf3dfa2720d7d..d4d2940db19abf3caf247c2af5f417118d324458 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -356,7 +356,14 @@ static int part_unlock(struct mtd_info *
+@@ -357,7 +357,14 @@ static int part_unlock(struct mtd_info *
        struct mtd_part *part = PART(mtd);
        if ((len + ofs) > mtd->size)
                return -EINVAL;
index 7f94b1cd396fa17f26a5149aa178cd6352faf8c6..c100277c22881d2cdb56129dcd6e0376f5433d95 100644 (file)
@@ -29,7 +29,7 @@
  #include <linux/netdevice.h>
  #include <linux/timer.h>
  #include <linux/ctype.h>
-@@ -307,8 +306,9 @@ done:
+@@ -294,8 +293,9 @@ done:
  static void netdev_trig_timer(unsigned long arg)
  {
        struct led_netdev_data *trigger_data = (struct led_netdev_data *)arg;
@@ -40,7 +40,7 @@
  
        write_lock(&trigger_data->lock);
  
-@@ -318,7 +318,7 @@ static void netdev_trig_timer(unsigned l
+@@ -305,7 +305,7 @@ static void netdev_trig_timer(unsigned l
                goto no_restart;
        }
  
index 03bc2e4d1ae83dd9b5b9232cbc1e7691ef3abbed..07061b0bbd556802700925ce96c4886193dd37cc 100644 (file)
@@ -96,8 +96,6 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  arch/arm/lib/memset.S | 85 ++++++++++++++++++++++++++-------------------------
  1 file changed, 44 insertions(+), 41 deletions(-)
 
-diff --git a/arch/arm/lib/memset.S b/arch/arm/lib/memset.S
-index 650d5923ab83..d912e7397ecc 100644
 --- a/arch/arm/lib/memset.S
 +++ b/arch/arm/lib/memset.S
 @@ -19,9 +19,9 @@
@@ -250,6 +248,3 @@ index 650d5923ab83..d912e7397ecc 100644
 +      strneb  r1, [ip], #1
        mov     pc, lr
  ENDPROC(memset)
--- 
-1.8.3.2
-
index e3a0d7baeefe9e320504f423f5af2e150714b111..266e507e69f9ab8bfbdd726bf6b27b3cd934b83e 100644 (file)
@@ -24,8 +24,6 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  arch/arm/lib/memset.S | 33 +++++++++++++--------------------
  1 file changed, 13 insertions(+), 20 deletions(-)
 
-diff --git a/arch/arm/lib/memset.S b/arch/arm/lib/memset.S
-index d912e7397ecc..94b0650ea98f 100644
 --- a/arch/arm/lib/memset.S
 +++ b/arch/arm/lib/memset.S
 @@ -14,31 +14,15 @@
@@ -78,6 +76,3 @@ index d912e7397ecc..94b0650ea98f 100644
 +      add     r2, r2, r3              @ 1 (r2 = r2 - (4 - r3))
 +      b       1b
  ENDPROC(memset)
--- 
-1.8.3.2
-
index 4dd5dad1692c0a0deebe6ff1d0f92802bf3e50b4..7baa17d447073b7c7d03ea73b8601dd757b8b26b 100644 (file)
        }
  
        if (updown_tab) {
-@@ -526,8 +524,8 @@ void ssb_pmu_init(struct ssb_chipcommon 
+@@ -526,8 +524,8 @@ void ssb_pmu_init(struct ssb_chipcommon
        pmucap = chipco_read32(cc, SSB_CHIPCO_PMU_CAP);
        cc->pmu.rev = (pmucap & SSB_CHIPCO_PMU_CAP_REVISION);
  
                return 0;
        }
  }
-@@ -692,8 +687,23 @@ void ssb_pmu_spuravoid_pllupdate(struct 
+@@ -692,8 +687,23 @@ void ssb_pmu_spuravoid_pllupdate(struct
                pmu_ctl = SSB_CHIPCO_PMU_CTL_PLL_UPD;
                break;
        case 43222:
 +}
 --- a/drivers/ssb/driver_gpio.c
 +++ b/drivers/ssb/driver_gpio.c
-@@ -74,6 +74,16 @@ static void ssb_gpio_chipco_free(struct 
+@@ -74,6 +74,16 @@ static void ssb_gpio_chipco_free(struct
        ssb_chipco_gpio_pullup(&bus->chipco, 1 << gpio, 0);
  }
  
  }
  
  static void dump_irq(struct ssb_bus *bus)
-@@ -189,34 +210,43 @@ static void ssb_mips_serial_init(struct 
+@@ -189,34 +210,43 @@ static void ssb_mips_serial_init(struct
  static void ssb_mips_flash_detect(struct ssb_mipscore *mcore)
  {
        struct ssb_bus *bus = mcore->dev->bus;
        SPEX(alpha2[0], SSB_SPROM8_CCODE, 0xff00, 8);
        SPEX(alpha2[1], SSB_SPROM8_CCODE, 0x00ff, 0);
        SPEX(boardflags_lo, SSB_SPROM8_BFLLO, 0xFFFF, 0);
-@@ -743,7 +753,7 @@ static int sprom_extract(struct ssb_bus 
+@@ -743,7 +753,7 @@ static int sprom_extract(struct ssb_bus
        memset(out, 0, sizeof(*out));
  
        out->revision = in[size - 1] & 0x00FF;
        memset(out->et0mac, 0xFF, 6);           /* preset et0 and et1 mac */
        memset(out->et1mac, 0xFF, 6);
  
-@@ -752,7 +762,7 @@ static int sprom_extract(struct ssb_bus 
+@@ -752,7 +762,7 @@ static int sprom_extract(struct ssb_bus
                 * number stored in the SPROM.
                 * Always extract r1. */
                out->revision = 1;
        }
  
        switch (out->revision) {
-@@ -769,9 +779,8 @@ static int sprom_extract(struct ssb_bus 
+@@ -769,9 +779,8 @@ static int sprom_extract(struct ssb_bus
                sprom_extract_r8(out, in);
                break;
        default:
index 0fc4154fa6279d74625d729d7c0f06898c149f2e..134f65715e95bd320a449d3fcfb99a11d7b391b5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -330,7 +330,14 @@ static int part_lock(struct mtd_info *mt
+@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
  static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
  {
        struct mtd_part *part = PART(mtd);
index 85937d87989d6de52d6a6c77bda34abc2c0d81c6..2939ab7a52bbb0c398bca4436a221ecf7c2bdfec 100644 (file)
@@ -29,7 +29,7 @@
  #include <linux/netdevice.h>
  #include <linux/timer.h>
  #include <linux/ctype.h>
-@@ -307,8 +306,9 @@ done:
+@@ -294,8 +293,9 @@ done:
  static void netdev_trig_timer(unsigned long arg)
  {
        struct led_netdev_data *trigger_data = (struct led_netdev_data *)arg;
@@ -40,7 +40,7 @@
  
        write_lock(&trigger_data->lock);
  
-@@ -318,7 +318,7 @@ static void netdev_trig_timer(unsigned l
+@@ -305,7 +305,7 @@ static void netdev_trig_timer(unsigned l
                goto no_restart;
        }
  
index 6d871866d65c83f102677dea02e4f334b9aa9d43..7290041a5846179f50c66c978656b27a19ce0036 100644 (file)
@@ -93,7 +93,7 @@
        }
  
        if (updown_tab) {
-@@ -526,8 +524,8 @@ void ssb_pmu_init(struct ssb_chipcommon 
+@@ -526,8 +524,8 @@ void ssb_pmu_init(struct ssb_chipcommon
        pmucap = chipco_read32(cc, SSB_CHIPCO_PMU_CAP);
        cc->pmu.rev = (pmucap & SSB_CHIPCO_PMU_CAP_REVISION);
  
                return 0;
        }
  }
-@@ -692,8 +687,23 @@ void ssb_pmu_spuravoid_pllupdate(struct 
+@@ -692,8 +687,23 @@ void ssb_pmu_spuravoid_pllupdate(struct
                pmu_ctl = SSB_CHIPCO_PMU_CTL_PLL_UPD;
                break;
        case 43222:
        SPEX(alpha2[0], SSB_SPROM8_CCODE, 0xff00, 8);
        SPEX(alpha2[1], SSB_SPROM8_CCODE, 0x00ff, 0);
        SPEX(boardflags_lo, SSB_SPROM8_BFLLO, 0xFFFF, 0);
-@@ -743,7 +753,7 @@ static int sprom_extract(struct ssb_bus 
+@@ -743,7 +753,7 @@ static int sprom_extract(struct ssb_bus
        memset(out, 0, sizeof(*out));
  
        out->revision = in[size - 1] & 0x00FF;
        memset(out->et0mac, 0xFF, 6);           /* preset et0 and et1 mac */
        memset(out->et1mac, 0xFF, 6);
  
-@@ -752,7 +762,7 @@ static int sprom_extract(struct ssb_bus 
+@@ -752,7 +762,7 @@ static int sprom_extract(struct ssb_bus
                 * number stored in the SPROM.
                 * Always extract r1. */
                out->revision = 1;
        }
  
        switch (out->revision) {
-@@ -769,9 +779,8 @@ static int sprom_extract(struct ssb_bus 
+@@ -769,9 +779,8 @@ static int sprom_extract(struct ssb_bus
                sprom_extract_r8(out, in);
                break;
        default:
index 0fc4154fa6279d74625d729d7c0f06898c149f2e..134f65715e95bd320a449d3fcfb99a11d7b391b5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -330,7 +330,14 @@ static int part_lock(struct mtd_info *mt
+@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
  static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
  {
        struct mtd_part *part = PART(mtd);
index e0e77588bd6cadf668d206e408a20d5313c36a63..0eb3bb16284f54bceeadf247f20062694d341d82 100644 (file)
@@ -29,7 +29,7 @@
  #include <linux/netdevice.h>
  #include <linux/timer.h>
  #include <linux/ctype.h>
-@@ -307,8 +306,9 @@ done:
+@@ -294,8 +293,9 @@ done:
  static void netdev_trig_timer(unsigned long arg)
  {
        struct led_netdev_data *trigger_data = (struct led_netdev_data *)arg;
@@ -40,7 +40,7 @@
  
        write_lock(&trigger_data->lock);
  
-@@ -318,7 +318,7 @@ static void netdev_trig_timer(unsigned l
+@@ -305,7 +305,7 @@ static void netdev_trig_timer(unsigned l
                goto no_restart;
        }
  
index c4a99a33b4a02042752076e8433e963296ea4b84..93082ee0ffa24b9e50269cc249792413a25a99a5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/Kconfig
 +++ b/fs/Kconfig
-@@ -62,6 +62,11 @@ config FILE_LOCKING
+@@ -61,6 +61,11 @@ config FILE_LOCKING
            for filesystems like NFS and for the flock() system
            call. Disabling this option saves about 11k.