kernel: make kmod-thermal dependency conditional to match upstream kernel module...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 22 Dec 2015 19:05:35 +0000 (19:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 22 Dec 2015 19:05:35 +0000 (19:05 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47961

package/kernel/linux/modules/hwmon.mk

index ad1c7bf91d108f9896781ca87f10716df568e2fa..e09efa17c01f2faf26c9fff89940362187e7d886 100644 (file)
@@ -274,7 +274,7 @@ define KernelPackage/hwmon-gpiofan
   KCONFIG:=CONFIG_SENSORS_GPIO_FAN
   FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
   AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
-  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
+  $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
 endef
 
 define KernelPackage/hwmon-gpiofan/description