brcm2708: define KERNELNAME accordingly
authorFlorian Fainelli <florian@openwrt.org>
Fri, 28 Feb 2014 20:29:40 +0000 (20:29 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 28 Feb 2014 20:29:40 +0000 (20:29 +0000)
Define KERNELNAME to Image to get the build system to copy this image
over $(KDIR) automatically for us.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39768

target/linux/brcm2708/Makefile
target/linux/brcm2708/image/Makefile

index 8ab34eb5ee51b7b266d710e30d17df7db0964073..f83d6f56354ba3d79d0e756de028f2a557d6749b 100644 (file)
@@ -25,4 +25,6 @@ define Target/Description
        Currently produces SD Card image for Raspberry Pi.
 endef
 
+KERNELNAME="Image"
+
 $(eval $(call BuildTarget))
index 6b4cf141a67429eff4c376b30f90f06276d16897..ae977a613edb73ec87b1b93c449dbf7fcc690b0c 100644 (file)
@@ -8,10 +8,6 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 include $(INCLUDE_DIR)/host.mk
 
-define Image/Prepare
-       cp $(LINUX_DIR)/arch/arm/boot/Image $(KDIR)/Image
-endef
-
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))