Revert "bc: update to 1.07.1"
authorHans Dedecker <dedeckeh@gmail.com>
Wed, 22 May 2019 19:25:35 +0000 (21:25 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Wed, 22 May 2019 19:27:44 +0000 (21:27 +0200)
This reverts commit 0111b86f1db501d57bfee8a313fe5bebdf8b2ed9 as it
breaks on Linux distributions without ed support

./fix-libmath_h: line 1: ed: command not found

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
tools/bc/Makefile
tools/bc/patches/001-no_doc.patch

index bbfd2272ce8419f1926a75d070114c4727b4f87f..3d505d6032fa83315d33d9848a6f9f1630850ccf 100644 (file)
@@ -7,11 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bc
-PKG_VERSION:=1.07.1
+PKG_VERSION:=1.06.95
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/bc
-PKG_HASH:=62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://alpha.gnu.org/gnu/bc \
+       http://gnualpha.uib.no/bc/ \
+       http://mirrors.fe.up.pt/pub/gnu-alpha/bc/ \
+       http://www.nic.funet.fi/pub/gnu/alpha/gnu/bc/
+PKG_HASH:=7ee4abbcfac03d8a6e1a8a3440558a3d239d6b858585063e745c760957725ecc
 
 include $(INCLUDE_DIR)/host-build.mk
 
index 119f111f491169e2eab2cbef84bd5265c538794e..50deee8c89d03ad9388c877b8da3bd061084014f 100644 (file)
@@ -1,5 +1,6 @@
---- a/Makefile.am
-+++ b/Makefile.am
+diff -urN bc-1.06.95/Makefile.am bc-1.06.95.new/Makefile.am
+--- bc-1.06.95/Makefile.am     2005-05-27 01:05:41.000000000 +0100
++++ bc-1.06.95.new/Makefile.am 2013-07-09 09:33:31.521490710 +0100
 @@ -1,6 +1,6 @@
  ## Process this file with automake to produce Makefile.in
  
@@ -7,15 +8,16 @@
 +SUBDIRS = lib bc dc
  
  MAINTAINERCLEANFILES =  aclocal.m4 config.h.in configure Makefile.in \
-                       stamp-h $(distdir).tar.gz h/number.h depcomp missing \
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -288,7 +288,7 @@ target_alias = @target_alias@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
+                       stamp-h $(distdir).tar.gz h/number.h depcomp missing
+diff -urN bc-1.06.95/Makefile.in bc-1.06.95.new/Makefile.in
+--- bc-1.06.95/Makefile.in     2006-09-05 03:39:30.000000000 +0100
++++ bc-1.06.95.new/Makefile.in 2013-07-09 09:33:28.565490767 +0100
+@@ -149,7 +149,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
 -SUBDIRS = lib bc dc doc
 +SUBDIRS = lib bc dc
  MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in \
-                       stamp-h $(distdir).tar.gz h/number.h depcomp missing \
-                       bc/libmath.h
+                       stamp-h $(distdir).tar.gz h/number.h depcomp missing