kernel: update 4.4 to 4.4.85
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Wed, 30 Aug 2017 20:09:17 +0000 (21:09 +0100)
committerJohn Crispin <john@phrozen.org>
Thu, 31 Aug 2017 17:14:52 +0000 (19:14 +0200)
Refresh patches

Compile & run tested: ar71xx - Archer C7 v2

Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
include/kernel-version.mk
target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch

index da10076218ff8f2aa048951b98bc3a1b4d9cacfe..0ed92dccae099e7988dc44ea2144c631a6e11992 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .83
+LINUX_VERSION-4.4 = .85
 LINUX_VERSION-4.9 = .45
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.83 = 5b5f0a0a6cdadcbe5e1c1c057470bb42880590fc97edee299fb1833d646856b4
+LINUX_KERNEL_HASH-4.4.85 = cfa49f631587e4587ba04236ce0e56765ea938c26815d5a29eec561b21d0f055
 LINUX_KERNEL_HASH-4.9.45 = 66e5d18dc79a59606b270a1e221a0a80ac09a9e5cd13b1a8b608c514ae15666d
 
 ifdef KERNEL_PATCHVER
index 487e896718511aa211f6170247991d3b5d76646c..5bedf5dc9effc53c96a8ace4ac393b49315ffe9c 100644 (file)
  
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3819,14 +3819,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3818,14 +3818,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);