The merge of ppc (32-bit headers) and powerpc (previously 64-bit only headers) has...
authorHamish Guthrie <hcg@openwrt.org>
Thu, 9 Oct 2008 11:33:47 +0000 (11:33 +0000)
committerHamish Guthrie <hcg@openwrt.org>
Thu, 9 Oct 2008 11:33:47 +0000 (11:33 +0000)
SVN-Revision: 12933

toolchain/kernel-headers/Makefile

index a182c83c1ff76b44b5b862c64fc1f44fd19d10cf..6e02fe9888f953acf1115f233c453d2f629dbc94 100644 (file)
@@ -33,9 +33,11 @@ define Build/Configure/cris
 endef
 
 define Build/Configure/powerpc
-       $(CP) $(PKG_BUILD_DIR)/include/asm-ppc/* $(PKG_BUILD_DIR)/include/asm-powerpc/
-       rm -rf $(PKG_BUILD_DIR)/include/asm-ppc
-       ln -s $(PKG_BUILD_DIR)/include/asm-powerpc $(PKG_BUILD_DIR)/include/asm-ppc
+       if [ -d $(PKG_BUILD_DIR)/include/asm-ppc ]; then \
+               $(CP) $(PKG_BUILD_DIR)/include/asm-ppc/* $(PKG_BUILD_DIR)/include/asm-powerpc/; \
+               rm -rf $(PKG_BUILD_DIR)/include/asm-ppc; \
+               ln -s $(PKG_BUILD_DIR)/include/asm-powerpc $(PKG_BUILD_DIR)/include/asm-ppc; \
+       fi
 endef
 
 ifneq (,$(findstring uml,$(BOARD)))