kernel: make NFSv4 optional and add kmods for it - patch by Peter Wagner <tripolar...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 20 Feb 2010 05:17:39 +0000 (05:17 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 20 Feb 2010 05:17:39 +0000 (05:17 +0000)
SVN-Revision: 19772

package/kernel/modules/fs.mk
target/linux/generic-2.6/config-2.6.25
target/linux/generic-2.6/config-2.6.30
target/linux/generic-2.6/config-2.6.31
target/linux/generic-2.6/config-2.6.32

index fc1bd17d0dd5ae7678f41bdab284a69618a0d5a2..08d814d6abea9daf60161fc3d55e99684b0f2802 100644 (file)
@@ -214,13 +214,26 @@ define KernelPackage/fs-nfs-common
   AUTOLOAD:=$(call AutoLoad,30,sunrpc lockd)
 endef
 
-define KernelPackage/fs-nfs-common/2.6
-  KCONFIG+=CONFIG_SUNRPC_GSS
+$(eval $(call KernelPackage,fs-nfs-common))
+
+
+define KernelPackage/fs-nfs-common-v4
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Common NFS V4 filesystem modules
+  KCONFIG+=\
+       CONFIG_SUNRPC_GSS\
+       CONFIG_NFS_V4=y\
+       CONFIG_NFSD_V4=y
+  DEPENDS:= @LINUX_2_6 +kmod-fs-nfs-common
   FILES+=$(LINUX_DIR)/net/sunrpc/auth_gss/auth_rpcgss.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD=$(call AutoLoad,30,sunrpc lockd auth_rpcgss)
+  AUTOLOAD=$(call AutoLoad,30,auth_rpcgss)
 endef
 
-$(eval $(call KernelPackage,fs-nfs-common))
+define KernelPackage/fs-nfs-common-v4/description
+ Kernel modules for NFS V4 & NFSD V4 kernel support
+endef
+
+$(eval $(call KernelPackage,fs-nfs-common-v4))
 
 
 define KernelPackage/fs-nfs
index b544fe448d6e037a5c82e9a6bdd6e06826a7c60b..3ac9274a2b4496dbccfff4d13ecb4af754081468 100644 (file)
@@ -1073,11 +1073,11 @@ CONFIG_NFSD_TCP=y
 # CONFIG_NFSD_V2_ACL is not set
 # CONFIG_NFSD_V3_ACL is not set
 CONFIG_NFSD_V3=y
-CONFIG_NFSD_V4=y
+# CONFIG_NFSD_V4 is not set
 # CONFIG_NFS_FS is not set
 # CONFIG_NFS_V3_ACL is not set
 CONFIG_NFS_V3=y
-CONFIG_NFS_V4=y
+# CONFIG_NFS_V4 is not set
 # CONFIG_NFTL is not set
 # CONFIG_NLS_ASCII is not set
 # CONFIG_NLS_CODEPAGE_1250 is not set
index 61ba5f3882cd2a91f5d1d842660e037f81c4a9bb..3de18d7695fd28f2455dced58143835e532df423 100644 (file)
@@ -1442,11 +1442,11 @@ CONFIG_NFSD_TCP=y
 # CONFIG_NFSD_V2_ACL is not set
 # CONFIG_NFSD_V3_ACL is not set
 CONFIG_NFSD_V3=y
-CONFIG_NFSD_V4=y
+# CONFIG_NFSD_V4 is not set
 # CONFIG_NFS_FS is not set
 # CONFIG_NFS_V3_ACL is not set
 CONFIG_NFS_V3=y
-CONFIG_NFS_V4=y
+# CONFIG_NFS_V4 is not set
 # CONFIG_NFTL is not set
 # CONFIG_NILFS2_FS is not set
 CONFIG_NL80211=y
index 6678ecc013b79085abe742ab67abfb73eeb8e10b..5d571fe664d2071d6e4aac7de15c79ef5c8c58a2 100644 (file)
@@ -1446,12 +1446,12 @@ CONFIG_NFSD_TCP=y
 # CONFIG_NFSD_V2_ACL is not set
 # CONFIG_NFSD_V3_ACL is not set
 CONFIG_NFSD_V3=y
-CONFIG_NFSD_V4=y
+# CONFIG_NFSD_V4 is not set
 # CONFIG_NFS_FS is not set
 # CONFIG_NFS_V3_ACL is not set
 CONFIG_NFS_V3=y
 # CONFIG_NFS_V4_1 is not set
-CONFIG_NFS_V4=y
+# CONFIG_NFS_V4 is not set
 # CONFIG_NFTL is not set
 # CONFIG_NILFS2_FS is not set
 CONFIG_NL80211=y
index 7dcb87890bdb8c289b06e2f1b183b929b8f9f3e5..ed632a8ed15d9740227dd488c53fb1043d92632b 100644 (file)
@@ -1515,12 +1515,12 @@ CONFIG_NFSD_TCP=y
 # CONFIG_NFSD_V2_ACL is not set
 # CONFIG_NFSD_V3_ACL is not set
 CONFIG_NFSD_V3=y
-CONFIG_NFSD_V4=y
+# CONFIG_NFSD_V4 is not set
 # CONFIG_NFS_FS is not set
 # CONFIG_NFS_V3_ACL is not set
 CONFIG_NFS_V3=y
 # CONFIG_NFS_V4_1 is not set
-CONFIG_NFS_V4=y
+# CONFIG_NFS_V4 is not set
 # CONFIG_NFTL is not set
 # CONFIG_NILFS2_FS is not set
 CONFIG_NL80211=y