ath79: mark netgear variables as device specific
authorMathias Kresin <dev@kresin.me>
Mon, 6 Aug 2018 15:47:41 +0000 (17:47 +0200)
committerMathias Kresin <dev@kresin.me>
Wed, 8 Aug 2018 06:11:11 +0000 (08:11 +0200)
The variables are used in image build recipes and need to be marked as
per devices vars to be stored individual per image define. Otherwise
the last defined variable will be used for all boards.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ath79/image/common-netgear.mk

index ca4e0056891682ae85b4e151cb97e955ab15c66c..5dfcd38a92fdb737f4f6b2b445a69119c2fd29e4 100644 (file)
@@ -1,3 +1,5 @@
+DEVICE_VARS += NETGEAR_KERNEL_MAGIC NETGEAR_BOARD_ID NETGEAR_HW_ID
+
 define Build/netgear-squashfs
        rm -rf $@.fs $@.squashfs
        mkdir -p $@.fs/image