kernel: remove all local symbols from kernel modules at link time to reduce their...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 25 Mar 2011 23:47:04 +0000 (23:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 25 Mar 2011 23:47:04 +0000 (23:47 +0000)
SVN-Revision: 26298

target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch [new file with mode: 0644]
target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch [new file with mode: 0644]
target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch

diff --git a/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
new file mode 100644 (file)
index 0000000..2e25081
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -360,7 +360,7 @@
+ KBUILD_AFLAGS   := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE  := -DMODULE
+ KBUILD_CFLAGS_MODULE  := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
index 861a6b7538d5ca84ec4f66fd5ae362e29b91ad9b..47f796a909ff4af0f938fa519059ed9808df46cb 100644 (file)
@@ -3,7 +3,7 @@
 @@ -361,6 +361,7 @@ KBUILD_AFLAGS   := -D__ASSEMBLY__
  KBUILD_AFLAGS_MODULE  := -DMODULE
  KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
 +KBUILD_LDFLAGS_MODULE_PREREQ  := 
  
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
diff --git a/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
new file mode 100644 (file)
index 0000000..86a3e2f
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -361,7 +361,7 @@
+ KBUILD_AFLAGS   := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE  := -DMODULE
+ KBUILD_CFLAGS_MODULE  := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
index 402cd0cacb2e30c36496f4db606b93f4064ef929..2d3a67d12b5e2121df5ce26ffc5625b27fe832d5 100644 (file)
@@ -3,7 +3,7 @@
 @@ -362,6 +362,7 @@ KBUILD_AFLAGS   := -D__ASSEMBLY__
  KBUILD_AFLAGS_MODULE  := -DMODULE
  KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
 +KBUILD_LDFLAGS_MODULE_PREREQ  := 
  
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)