kernel: bump 4.9 to 4.9.129
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 26 Sep 2018 10:51:29 +0000 (12:51 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 26 Sep 2018 13:54:18 +0000 (15:54 +0200)
Refreshed all patches.

Removed upstreamed:
- 203-MIPS-ath79-fix-restart.patch

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/203-MIPS-ath79-fix-restart.patch [deleted file]
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/generic/pending-4.9/190-2-5-e1000e-Fix-wrong-comment-related-to-link-detection.patch
target/linux/layerscape/patches-4.9/401-mtd-spi-nor-support-layerscape.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch

index c1f859e4a2f0b1dd1d3846fd2279c58e2e0ca687..ba0f12a114231507c7395cfb6a2998f8e0731d31 100644 (file)
@@ -2,13 +2,13 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .128
 LINUX_VERSION-4.14 = .71
 LINUX_VERSION-3.18 = .123
+LINUX_VERSION-4.9 = .129
 
-LINUX_KERNEL_HASH-4.9.128 = bdb76f48491a6aadc89c0f0f7fdc240d77cee54da5aac59da0b5d98e226b6f12
 LINUX_KERNEL_HASH-4.14.71 = 76a4473dbcbd922c23a16130414829a36eb7e2f4e5859bd1b742fffdff907489
 LINUX_KERNEL_HASH-3.18.123 = c10de32c9b31fb619b016a00d77afc394db5a4542e258e927f06a5ead86f8c64
+LINUX_KERNEL_HASH-4.9.129 = 6f5510d3fcfec1bf1e2d9c8e2fdcd7628c1886c6bdb29092adc5ccdf75e39318
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/ar71xx/patches-4.9/203-MIPS-ath79-fix-restart.patch b/target/linux/ar71xx/patches-4.9/203-MIPS-ath79-fix-restart.patch
deleted file mode 100644 (file)
index 48f4d95..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/arch/mips/ath79/setup.c
-+++ b/arch/mips/ath79/setup.c
-@@ -40,6 +40,7 @@ static char ath79_sys_type[ATH79_SYS_TYP
- static void ath79_restart(char *command)
- {
-+      local_irq_disable();
-       ath79_device_reset_set(AR71XX_RESET_FULL_CHIP);
-       for (;;)
-               if (cpu_wait)
---- a/arch/mips/include/asm/mach-ath79/ath79.h
-+++ b/arch/mips/include/asm/mach-ath79/ath79.h
-@@ -135,6 +135,7 @@ static inline u32 ath79_pll_rr(unsigned
- static inline void ath79_reset_wr(unsigned reg, u32 val)
- {
-       __raw_writel(val, ath79_reset_base + reg);
-+      (void) __raw_readl(ath79_reset_base + reg); /* flush */
- }
- static inline u32 ath79_reset_rr(unsigned reg)
index 1db23d7235d14c5cb2d8d51d616d9fe229d6d152..12174919bb37d6d9d745d91505c52d4d9f69b07c 100644 (file)
@@ -707,7 +707,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
                msleep(100);    /* Cool down */
 --- a/drivers/usb/core/message.c
 +++ b/drivers/usb/core/message.c
-@@ -1912,6 +1912,85 @@ free_interfaces:
+@@ -1923,6 +1923,85 @@ free_interfaces:
        if (cp->string == NULL &&
                        !(dev->quirks & USB_QUIRK_CONFIG_INTF_STRINGS))
                cp->string = usb_cache_string(dev, cp->desc.iConfiguration);
index 0e8e0660db5d9b555885bb69ce553f8f461d37e0..393c4524e4d28df16a3af2e77fa0d21bd565472f 100644 (file)
@@ -1379,7 +1379,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                 */
 --- a/drivers/net/xen-netfront.c
 +++ b/drivers/net/xen-netfront.c
-@@ -1065,7 +1065,7 @@ err:
+@@ -1064,7 +1064,7 @@ err:
        if (work_done < budget) {
                int more_to_do = 0;
  
index 87b12b9cbe2e3eaa01a44e802b515186a24b9716..8899664fba9c137f14cee6488a0ebb65e6129f02 100644 (file)
@@ -23,7 +23,7 @@ Tested-by: Aaron Brown <aaron.f.brown@intel.com>
 
 --- a/drivers/net/ethernet/intel/e1000e/netdev.c
 +++ b/drivers/net/ethernet/intel/e1000e/netdev.c
-@@ -5078,7 +5078,7 @@ static bool e1000e_has_link(struct e1000
+@@ -5067,7 +5067,7 @@ static bool e1000e_has_link(struct e1000
  
        /* get_link_status is set on LSC (link status) interrupt or
         * Rx sequence error interrupt.  get_link_status will stay
@@ -32,7 +32,7 @@ Tested-by: Aaron Brown <aaron.f.brown@intel.com>
         * for copper adapters ONLY
         */
        switch (hw->phy.media_type) {
-@@ -5096,7 +5096,7 @@ static bool e1000e_has_link(struct e1000
+@@ -5085,7 +5085,7 @@ static bool e1000e_has_link(struct e1000
                break;
        case e1000_media_type_internal_serdes:
                ret_val = hw->mac.ops.check_for_link(hw);
index 00ce33355932f3e46e27b4c7e06f15d9b08a4cf6..fed6711e5520e363b9eff19287ba2652768c8d2c 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/mtd/mtdchar.c
 +++ b/drivers/mtd/mtdchar.c
-@@ -451,7 +451,7 @@ static int mtdchar_readoob(struct file *
+@@ -455,7 +455,7 @@ static int mtdchar_readoob(struct file *
         * data. For our userspace tools it is important to dump areas
         * with ECC errors!
         * For kernel internal usage it also might return -EUCLEAN
index afd29e4fe2b2a3dea5b6d1b845d0bb1466e7ebbb..d467a913dba70b0291bd3db9b934dba31254ed3b 100644 (file)
@@ -214,7 +214,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        for (i = 0; i < nent; ++i) {
                arm_smmu_write_strtab_ent(NULL, -1, strtab, &ste);
-@@ -1364,8 +1374,6 @@ static bool arm_smmu_capable(enum iommu_
+@@ -1365,8 +1375,6 @@ static bool arm_smmu_capable(enum iommu_
        switch (cap) {
        case IOMMU_CAP_CACHE_COHERENCY:
                return true;
@@ -223,7 +223,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        case IOMMU_CAP_NOEXEC:
                return true;
        default:
-@@ -1377,7 +1385,9 @@ static struct iommu_domain *arm_smmu_dom
+@@ -1378,7 +1386,9 @@ static struct iommu_domain *arm_smmu_dom
  {
        struct arm_smmu_domain *smmu_domain;
  
@@ -234,7 +234,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                return NULL;
  
        /*
-@@ -1508,6 +1518,11 @@ static int arm_smmu_domain_finalise(stru
+@@ -1509,6 +1519,11 @@ static int arm_smmu_domain_finalise(stru
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
        struct arm_smmu_device *smmu = smmu_domain->smmu;
  
@@ -246,7 +246,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* Restrict the stage to what we can actually support */
        if (!(smmu->features & ARM_SMMU_FEAT_TRANS_S1))
                smmu_domain->stage = ARM_SMMU_DOMAIN_S2;
-@@ -1580,7 +1595,7 @@ static __le64 *arm_smmu_get_step_for_sid
+@@ -1581,7 +1596,7 @@ static __le64 *arm_smmu_get_step_for_sid
        return step;
  }
  
@@ -255,7 +255,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        int i, j;
        struct arm_smmu_master_data *master = fwspec->iommu_priv;
-@@ -1599,17 +1614,14 @@ static int arm_smmu_install_ste_for_dev(
+@@ -1600,17 +1615,14 @@ static int arm_smmu_install_ste_for_dev(
  
                arm_smmu_write_strtab_ent(smmu, sid, step, &master->ste);
        }
@@ -275,7 +275,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  static int arm_smmu_attach_dev(struct iommu_domain *domain, struct device *dev)
-@@ -1628,7 +1640,7 @@ static int arm_smmu_attach_dev(struct io
+@@ -1629,7 +1641,7 @@ static int arm_smmu_attach_dev(struct io
        ste = &master->ste;
  
        /* Already attached to a different domain? */
@@ -284,7 +284,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                arm_smmu_detach_dev(dev);
  
        mutex_lock(&smmu_domain->init_mutex);
-@@ -1649,10 +1661,12 @@ static int arm_smmu_attach_dev(struct io
+@@ -1650,10 +1662,12 @@ static int arm_smmu_attach_dev(struct io
                goto out_unlock;
        }
  
@@ -300,7 +300,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                ste->s1_cfg = &smmu_domain->s1_cfg;
                ste->s2_cfg = NULL;
                arm_smmu_write_ctx_desc(smmu, ste->s1_cfg);
-@@ -1661,10 +1675,7 @@ static int arm_smmu_attach_dev(struct io
+@@ -1662,10 +1676,7 @@ static int arm_smmu_attach_dev(struct io
                ste->s2_cfg = &smmu_domain->s2_cfg;
        }
  
@@ -312,7 +312,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  out_unlock:
        mutex_unlock(&smmu_domain->init_mutex);
        return ret;
-@@ -1695,6 +1706,9 @@ arm_smmu_unmap(struct iommu_domain *doma
+@@ -1696,6 +1707,9 @@ arm_smmu_unmap(struct iommu_domain *doma
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
        struct io_pgtable_ops *ops = smmu_domain->pgtbl_ops;
  
@@ -322,7 +322,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        if (!ops)
                return 0;
  
-@@ -1810,7 +1824,7 @@ static void arm_smmu_remove_device(struc
+@@ -1811,7 +1825,7 @@ static void arm_smmu_remove_device(struc
                return;
  
        master = fwspec->iommu_priv;
@@ -331,7 +331,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                arm_smmu_detach_dev(dev);
        iommu_group_remove_device(dev);
        kfree(master);
-@@ -1839,6 +1853,9 @@ static int arm_smmu_domain_get_attr(stru
+@@ -1840,6 +1854,9 @@ static int arm_smmu_domain_get_attr(stru
  {
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -341,7 +341,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        switch (attr) {
        case DOMAIN_ATTR_NESTING:
                *(int *)data = (smmu_domain->stage == ARM_SMMU_DOMAIN_NESTED);
-@@ -1854,6 +1871,9 @@ static int arm_smmu_domain_set_attr(stru
+@@ -1855,6 +1872,9 @@ static int arm_smmu_domain_set_attr(stru
        int ret = 0;
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -351,7 +351,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        mutex_lock(&smmu_domain->init_mutex);
  
        switch (attr) {
-@@ -1883,6 +1903,31 @@ static int arm_smmu_of_xlate(struct devi
+@@ -1884,6 +1904,31 @@ static int arm_smmu_of_xlate(struct devi
        return iommu_fwspec_add_ids(dev, args->args, 1);
  }
  
@@ -383,7 +383,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static struct iommu_ops arm_smmu_ops = {
        .capable                = arm_smmu_capable,
        .domain_alloc           = arm_smmu_domain_alloc,
-@@ -1898,6 +1943,8 @@ static struct iommu_ops arm_smmu_ops = {
+@@ -1899,6 +1944,8 @@ static struct iommu_ops arm_smmu_ops = {
        .domain_get_attr        = arm_smmu_domain_get_attr,
        .domain_set_attr        = arm_smmu_domain_set_attr,
        .of_xlate               = arm_smmu_of_xlate,