move hardware monitoring support in a separate hwmon.mk (before adding other modules)
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 17:14:24 +0000 (17:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 17:14:24 +0000 (17:14 +0000)
SVN-Revision: 8983

package/kernel/modules/hwmon.mk [new file with mode: 0644]
package/kernel/modules/other.mk

diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
new file mode 100644 (file)
index 0000000..753c455
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006,2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+HWMON_MENU:=Hardware Monitoring Support
+
+define KernelPackage/hwmon-core
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=Hardware monitoring support
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:= \
+       CONFIG_HWMON \
+       CONFIG_HWMON_VID \
+       CONFIG_HWMON_DEBUG_CHIP=n
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,hwmon hwmon-vid)
+endef
+
+define KernelPackage/hwmon-core/description
+ Kernel modules for hardware monitoring
+endef
+
+$(eval $(call KernelPackage,hwmon-core))
+
+
+define KernelPackage/hwmon-pc87360
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=PC87360 monitoring support
+  KCONFIG:=CONFIG_SENSORS_PC87360
+  FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,pc87360)
+  DEPENDS:=kmod-hwmon-core
+endef
+
+define KernelPackage/hwmon-pc87360/description
+ Kernel modules for PC87360 chips
+endef
+
+$(eval $(call KernelPackage,hwmon-pc87360))
+
index 0e3368b0b68fe04ba8b1a18661c6628c78144578..7bb75ef9cb4e4da905998fd9119007ae9dcd4123 100644 (file)
@@ -332,43 +332,6 @@ endef
 $(eval $(call KernelPackage,scx200-wdt))
 
 
-define KernelPackage/hwmon
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Hardware monitoring support
-  DEPENDS:=@LINUX_2_6
-  KCONFIG:= \
-       CONFIG_HWMON \
-       CONFIG_HWMON_VID \
-       CONFIG_HWMON_DEBUG_CHIP=n
-  FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,40,hwmon hwmon-vid)
-endef
-
-define KernelPackage/hwmon/description
- Kernel modules for hardware monitoring
-endef
-
-$(eval $(call KernelPackage,hwmon))
-
-
-define KernelPackage/hwmon-pc87360
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=PC87360 monitoring support
-  DEPENDS:=kmod-hwmon
-  KCONFIG:=CONFIG_SENSORS_PC87360
-  FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,pc87360)
-endef
-
-define KernelPackage/hwmon-pc87360/description
- Kernel modules for PC87360 chips
-endef
-
-$(eval $(call KernelPackage,hwmon-pc87360))
-
-
 define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core