ramips: use patch-dtb for F5D8235 V1
authorTobias Wolf <github-NTEO@vplace.de>
Sun, 22 Apr 2018 17:34:57 +0000 (19:34 +0200)
committerMathias Kresin <dev@kresin.me>
Mon, 23 Apr 2018 20:07:22 +0000 (22:07 +0200)
The old DTB method (OWRTDTB) is not recognized by the boot process
anymore with 4.9/4.14.

This patch reuses KERNEL_DTB to get a valid DTB applied to the kernel
image.

Signed-off-by: Tobias Wolf <github-NTEO@vplace.de>
target/linux/ramips/image/rt288x.mk

index 280ce561728fdb8829e2deefcab62f9028e2b0f2..c7f7d064fff42c46fac8cf8de6e2ae53b1f02a58 100644 (file)
@@ -47,13 +47,11 @@ endef
 TARGET_DEVICES += dlink_dap-1522-a1
 
 define Device/f5d8235-v1
+  DTS := F5D8235_V1
   IMAGE_SIZE := 7744k
   DEVICE_TITLE := Belkin F5D8235 V1
   DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
     kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
-  DEVICE_DTS := F5D8235_V1
-  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
-  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
 endef
 TARGET_DEVICES += f5d8235-v1