kernel: rfkill depends on input-core
authorFelix Fietkau <nbd@openwrt.org>
Thu, 18 Jul 2013 17:26:17 +0000 (17:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 18 Jul 2013 17:26:17 +0000 (17:26 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37409

package/kernel/linux/modules/001-depends.mk
package/kernel/linux/modules/other.mk

index e0af73570516822a658d60b21d8e7acd487eab31..445466fb3853cc4a485721b540ef6d58cd655705 100644 (file)
@@ -24,7 +24,7 @@ endef
 
 
 define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx) $(1)
 endef
 
 define AddDepends/rfkill
index 03cfbc16f5ede40f0dbe0545290ae3d7d63702ad..960d6fd80fba83449a8203f2b4c87f003f4177c1 100644 (file)
@@ -247,7 +247,7 @@ define KernelPackage/rfkill
   FILES:= \
     $(LINUX_DIR)/net/rfkill/rfkill.ko
   AUTOLOAD:=$(call AutoLoad,20,rfkill)
-  $(call SetDepends/rfkill)
+  $(call SetDepends/rfkill,+kmod-input-core)
 endef
 
 define KernelPackage/rfkill/description