kernel: update kernel 4.4 to version 4.4.8
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 24 Apr 2016 09:32:17 +0000 (11:32 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 24 Apr 2016 09:32:17 +0000 (11:32 +0200)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
14 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.4/0069-hid-Reduce-default-mouse-polling-interval-to-60Hz.patch
target/linux/brcm2708/patches-4.4/0222-net-fix-bridge-multicast-packet-checksum-validation.patch [deleted file]
target/linux/brcm2708/patches-4.4/0223-bpf-add-skb_postpush_rcsum-and-fix-dev_forward_skb-o.patch [deleted file]
target/linux/generic/patches-4.4/630-packet_socket_type.patch
target/linux/generic/patches-4.4/642-bridge_port_isolate.patch
target/linux/generic/patches-4.4/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-4.4/655-increase_skb_pad.patch
target/linux/generic/patches-4.4/656-skb_reduce_truesize-helper.patch
target/linux/generic/patches-4.4/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-4.4/721-phy_packets.patch
target/linux/generic/patches-4.4/903-debloat_direct_io.patch
target/linux/lantiq/patches-4.4/0001-MIPS-lantiq-add-pcie-driver.patch

index 51417ff3c8c5ffd80a197db51c92349e8c3a8f05..33fed6b0f11ac9a4207295d63405f9270daea046 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .29
 LINUX_VERSION-4.1 = .20
 LINUX_VERSION-4.3 = .4
 LINUX_VERSION-3.18 = .29
 LINUX_VERSION-4.1 = .20
 LINUX_VERSION-4.3 = .4
-LINUX_VERSION-4.4 = .7
+LINUX_VERSION-4.4 = .8
 
 LINUX_KERNEL_MD5SUM-3.18.29 = b25737a0bc98e80d12200de93f239c28
 LINUX_KERNEL_MD5SUM-4.1.20 = 075c38a3a23ca5bc80437b13606df00a
 LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
 
 LINUX_KERNEL_MD5SUM-3.18.29 = b25737a0bc98e80d12200de93f239c28
 LINUX_KERNEL_MD5SUM-4.1.20 = 075c38a3a23ca5bc80437b13606df00a
 LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
-LINUX_KERNEL_MD5SUM-4.4.7 = 4345597c9a10bd73c28b6ae3a854d8d7
+LINUX_KERNEL_MD5SUM-4.4.8 = d6430ac57c5f1830798095b7147908e4
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index b4b749e4b9c02a74a9f712a2740d63e554de5c64..17e4606506ce068f6e7f3f5c32bf24e19f05f056 100644 (file)
                        ptr--;
                }
                if (tunnel->parms.o_flags&GRE_KEY) {
                        ptr--;
                }
                if (tunnel->parms.o_flags&GRE_KEY) {
-@@ -836,7 +836,7 @@ static inline int ip6gre_xmit_ipv6(struc
+@@ -838,7 +838,7 @@ static inline int ip6gre_xmit_ipv6(struc
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
 --- a/net/ipv6/ip6_tunnel.c
 +++ b/net/ipv6/ip6_tunnel.c
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
 --- a/net/ipv6/ip6_tunnel.c
 +++ b/net/ipv6/ip6_tunnel.c
-@@ -1396,7 +1396,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1386,7 +1386,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
                memcpy(p, foc->val, foc->len);
 --- a/net/ipv4/igmp.c
 +++ b/net/ipv4/igmp.c
                memcpy(p, foc->val, foc->len);
 --- a/net/ipv4/igmp.c
 +++ b/net/ipv4/igmp.c
-@@ -501,7 +501,7 @@ static struct sk_buff *add_grec(struct s
+@@ -500,7 +500,7 @@ static struct sk_buff *add_grec(struct s
                if (!skb)
                        return NULL;
                psrc = (__be32 *)skb_put(skb, sizeof(__be32));
                if (!skb)
                        return NULL;
                psrc = (__be32 *)skb_put(skb, sizeof(__be32));
index e269150f23c2fc3058ebe10c529047f897cb7d02..c292692192d25d4132ca24adf27e9707a2814837 100644 (file)
@@ -19,7 +19,7 @@ Reduces overhead when using X
  module_param_named(mousepoll, hid_mousepoll_interval, uint, 0644);
  MODULE_PARM_DESC(mousepoll, "Polling interval of mice");
  
  module_param_named(mousepoll, hid_mousepoll_interval, uint, 0644);
  MODULE_PARM_DESC(mousepoll, "Polling interval of mice");
  
-@@ -1091,8 +1091,12 @@ static int usbhid_start(struct hid_devic
+@@ -1083,8 +1083,12 @@ static int usbhid_start(struct hid_devic
                }
  
                /* Change the polling interval of mice. */
                }
  
                /* Change the polling interval of mice. */
diff --git a/target/linux/brcm2708/patches-4.4/0222-net-fix-bridge-multicast-packet-checksum-validation.patch b/target/linux/brcm2708/patches-4.4/0222-net-fix-bridge-multicast-packet-checksum-validation.patch
deleted file mode 100644 (file)
index b3f105b..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-From 966e306c7690f118bedf2f5de94e22e487bd39ec Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Linus=20L=C3=BCssing?= <linus.luessing@c0d3.blue>
-Date: Wed, 24 Feb 2016 04:21:42 +0100
-Subject: [PATCH 222/232] net: fix bridge multicast packet checksum validation
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-We need to update the skb->csum after pulling the skb, otherwise
-an unnecessary checksum (re)computation can ocure for IGMP/MLD packets
-in the bridge code. Additionally this fixes the following splats for
-network devices / bridge ports with support for and enabled RX checksum
-offloading:
-
-[...]
-[   43.986968] eth0: hw csum failure
-[   43.990344] CPU: 3 PID: 0 Comm: swapper/3 Not tainted 4.4.0 #2
-[   43.996193] Hardware name: BCM2709
-[   43.999647] [<800204e0>] (unwind_backtrace) from [<8001cf14>] (show_stack+0x10/0x14)
-[   44.007432] [<8001cf14>] (show_stack) from [<801ab614>] (dump_stack+0x80/0x90)
-[   44.014695] [<801ab614>] (dump_stack) from [<802e4548>] (__skb_checksum_complete+0x6c/0xac)
-[   44.023090] [<802e4548>] (__skb_checksum_complete) from [<803a055c>] (ipv6_mc_validate_checksum+0x104/0x178)
-[   44.032959] [<803a055c>] (ipv6_mc_validate_checksum) from [<802e111c>] (skb_checksum_trimmed+0x130/0x188)
-[   44.042565] [<802e111c>] (skb_checksum_trimmed) from [<803a06e8>] (ipv6_mc_check_mld+0x118/0x338)
-[   44.051501] [<803a06e8>] (ipv6_mc_check_mld) from [<803b2c98>] (br_multicast_rcv+0x5dc/0xd00)
-[   44.060077] [<803b2c98>] (br_multicast_rcv) from [<803aa510>] (br_handle_frame_finish+0xac/0x51c)
-[...]
-
-Fixes: 9afd85c9e455 ("net: Export IGMP/MLD message validation code")
-Reported-by: Álvaro Fernández Rojas <noltari@gmail.com>
-Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- net/core/skbuff.c | 22 ++++++++++++++++++++--
- 1 file changed, 20 insertions(+), 2 deletions(-)
-
---- a/net/core/skbuff.c
-+++ b/net/core/skbuff.c
-@@ -2965,6 +2965,24 @@ int skb_append_pagefrags(struct sk_buff
- EXPORT_SYMBOL_GPL(skb_append_pagefrags);
- /**
-+ *    skb_push_rcsum - push skb and update receive checksum
-+ *    @skb: buffer to update
-+ *    @len: length of data pulled
-+ *
-+ *    This function performs an skb_push on the packet and updates
-+ *    the CHECKSUM_COMPLETE checksum.  It should be used on
-+ *    receive path processing instead of skb_push unless you know
-+ *    that the checksum difference is zero (e.g., a valid IP header)
-+ *    or you are setting ip_summed to CHECKSUM_NONE.
-+ */
-+static unsigned char *skb_push_rcsum(struct sk_buff *skb, unsigned len)
-+{
-+      skb_push(skb, len);
-+      skb_postpush_rcsum(skb, skb->data, len);
-+      return skb->data;
-+}
-+
-+/**
-  *    skb_pull_rcsum - pull skb and update receive checksum
-  *    @skb: buffer to update
-  *    @len: length of data pulled
-@@ -4101,9 +4119,9 @@ struct sk_buff *skb_checksum_trimmed(str
-       if (!pskb_may_pull(skb_chk, offset))
-               goto err;
--      __skb_pull(skb_chk, offset);
-+      skb_pull_rcsum(skb_chk, offset);
-       ret = skb_chkf(skb_chk);
--      __skb_push(skb_chk, offset);
-+      skb_push_rcsum(skb_chk, offset);
-       if (ret)
-               goto err;
diff --git a/target/linux/brcm2708/patches-4.4/0223-bpf-add-skb_postpush_rcsum-and-fix-dev_forward_skb-o.patch b/target/linux/brcm2708/patches-4.4/0223-bpf-add-skb_postpush_rcsum-and-fix-dev_forward_skb-o.patch
deleted file mode 100644 (file)
index 1793d5e..0000000
+++ /dev/null
@@ -1,124 +0,0 @@
-From 7ce01cd3013b7c9f1b257a6033b6d1f67fed5b5c Mon Sep 17 00:00:00 2001
-From: Daniel Borkmann <daniel@iogearbox.net>
-Date: Thu, 7 Jan 2016 15:50:23 +0100
-Subject: [PATCH 223/232] bpf: add skb_postpush_rcsum and fix dev_forward_skb
- occasions
-
-Add a small helper skb_postpush_rcsum() and fix up redirect locations
-that need CHECKSUM_COMPLETE fixups on ingress. dev_forward_skb() expects
-a proper csum that covers also Ethernet header, f.e. since 2c26d34bbcc0
-("net/core: Handle csum for CHECKSUM_COMPLETE VXLAN forwarding"), we
-also do skb_postpull_rcsum() after pulling Ethernet header off via
-eth_type_trans().
-
-When using eBPF in a netns setup f.e. with vxlan in collect metadata mode,
-I can trigger the following csum issue with an IPv6 setup:
-
-  [  505.144065] dummy1: hw csum failure
-  [...]
-  [  505.144108] Call Trace:
-  [  505.144112]  <IRQ>  [<ffffffff81372f08>] dump_stack+0x44/0x5c
-  [  505.144134]  [<ffffffff81607cea>] netdev_rx_csum_fault+0x3a/0x40
-  [  505.144142]  [<ffffffff815fee3f>] __skb_checksum_complete+0xcf/0xe0
-  [  505.144149]  [<ffffffff816f0902>] nf_ip6_checksum+0xb2/0x120
-  [  505.144161]  [<ffffffffa08c0e0e>] icmpv6_error+0x17e/0x328 [nf_conntrack_ipv6]
-  [  505.144170]  [<ffffffffa0898eca>] ? ip6t_do_table+0x2fa/0x645 [ip6_tables]
-  [  505.144177]  [<ffffffffa08c0725>] ? ipv6_get_l4proto+0x65/0xd0 [nf_conntrack_ipv6]
-  [  505.144189]  [<ffffffffa06c9a12>] nf_conntrack_in+0xc2/0x5a0 [nf_conntrack]
-  [  505.144196]  [<ffffffffa08c039c>] ipv6_conntrack_in+0x1c/0x20 [nf_conntrack_ipv6]
-  [  505.144204]  [<ffffffff8164385d>] nf_iterate+0x5d/0x70
-  [  505.144210]  [<ffffffff816438d6>] nf_hook_slow+0x66/0xc0
-  [  505.144218]  [<ffffffff816bd302>] ipv6_rcv+0x3f2/0x4f0
-  [  505.144225]  [<ffffffff816bca40>] ? ip6_make_skb+0x1b0/0x1b0
-  [  505.144232]  [<ffffffff8160b77b>] __netif_receive_skb_core+0x36b/0x9a0
-  [  505.144239]  [<ffffffff8160bdc8>] ? __netif_receive_skb+0x18/0x60
-  [  505.144245]  [<ffffffff8160bdc8>] __netif_receive_skb+0x18/0x60
-  [  505.144252]  [<ffffffff8160ccff>] process_backlog+0x9f/0x140
-  [  505.144259]  [<ffffffff8160c4a5>] net_rx_action+0x145/0x320
-  [...]
-
-What happens is that on ingress, we push Ethernet header back in, either
-from cls_bpf or right before skb_do_redirect(), but without updating csum.
-The "hw csum failure" can be fixed by using the new skb_postpush_rcsum()
-helper for the dev_forward_skb() case to correct the csum diff again.
-
-Thanks to Hannes Frederic Sowa for the csum_partial() idea!
-
-Fixes: 3896d655f4d4 ("bpf: introduce bpf_clone_redirect() helper")
-Fixes: 27b29f63058d ("bpf: add bpf_redirect() helper")
-Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
-Acked-by: Alexei Starovoitov <ast@kernel.org>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- include/linux/skbuff.h | 17 +++++++++++++++++
- net/core/filter.c      | 17 +++++++++++++----
- 2 files changed, 30 insertions(+), 4 deletions(-)
-
---- a/include/linux/skbuff.h
-+++ b/include/linux/skbuff.h
-@@ -2737,6 +2737,23 @@ static inline void skb_postpull_rcsum(st
- unsigned char *skb_pull_rcsum(struct sk_buff *skb, unsigned int len);
-+static inline void skb_postpush_rcsum(struct sk_buff *skb,
-+                                    const void *start, unsigned int len)
-+{
-+      /* For performing the reverse operation to skb_postpull_rcsum(),
-+       * we can instead of ...
-+       *
-+       *   skb->csum = csum_add(skb->csum, csum_partial(start, len, 0));
-+       *
-+       * ... just use this equivalent version here to save a few
-+       * instructions. Feeding csum of 0 in csum_partial() and later
-+       * on adding skb->csum is equivalent to feed skb->csum in the
-+       * first place.
-+       */
-+      if (skb->ip_summed == CHECKSUM_COMPLETE)
-+              skb->csum = csum_partial(start, len, skb->csum);
-+}
-+
- /**
-  *    pskb_trim_rcsum - trim received skb and update checksum
-  *    @skb: buffer to trim
---- a/net/core/filter.c
-+++ b/net/core/filter.c
-@@ -1288,8 +1288,9 @@ static u64 bpf_skb_store_bytes(u64 r1, u
-               /* skb_store_bits cannot return -EFAULT here */
-               skb_store_bits(skb, offset, ptr, len);
--      if (BPF_RECOMPUTE_CSUM(flags) && skb->ip_summed == CHECKSUM_COMPLETE)
--              skb->csum = csum_add(skb->csum, csum_partial(ptr, len, 0));
-+      if (BPF_RECOMPUTE_CSUM(flags))
-+              skb_postpush_rcsum(skb, ptr, len);
-+
-       return 0;
- }
-@@ -1415,8 +1416,12 @@ static u64 bpf_clone_redirect(u64 r1, u6
-       if (unlikely(!skb2))
-               return -ENOMEM;
--      if (BPF_IS_REDIRECT_INGRESS(flags))
-+      if (BPF_IS_REDIRECT_INGRESS(flags)) {
-+              if (skb_at_tc_ingress(skb2))
-+                      skb_postpush_rcsum(skb2, skb_mac_header(skb2),
-+                                         skb2->mac_len);
-               return dev_forward_skb(dev, skb2);
-+      }
-       skb2->dev = dev;
-       skb_sender_cpu_clear(skb2);
-@@ -1459,8 +1464,12 @@ int skb_do_redirect(struct sk_buff *skb)
-               return -EINVAL;
-       }
--      if (BPF_IS_REDIRECT_INGRESS(ri->flags))
-+      if (BPF_IS_REDIRECT_INGRESS(ri->flags)) {
-+              if (skb_at_tc_ingress(skb))
-+                      skb_postpush_rcsum(skb, skb_mac_header(skb),
-+                                         skb->mac_len);
-               return dev_forward_skb(dev, skb);
-+      }
-       skb->dev = dev;
-       skb_sender_cpu_clear(skb);
index d649bf08032da7b24c5baa2f03a8dd1a0dd99724..48c422030a05a46499082bb00ac0cb5276bebc1a 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
                goto out;
  
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto out;
  
        if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -1982,12 +1984,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -1986,12 +1988,12 @@ static int packet_rcv(struct sk_buff *sk
        int skb_len = skb->len;
        unsigned int snaplen, res;
  
        int skb_len = skb->len;
        unsigned int snaplen, res;
  
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2107,12 +2109,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -2111,12 +2113,12 @@ static int tpacket_rcv(struct sk_buff *s
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
  
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
        BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
  
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3097,6 +3099,7 @@ static int packet_create(struct net *net
+@@ -3092,6 +3094,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3712,6 +3715,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3707,6 +3710,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
        default:
                return -ENOPROTOOPT;
        }
-@@ -3764,6 +3777,13 @@ static int packet_getsockopt(struct sock
+@@ -3759,6 +3772,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index 0be8c8fdd861397e2dfe835936d7f371d45e75a7..1dc32b6f539eabcf72bde2810259e871d2cde714 100644 (file)
@@ -11,8 +11,8 @@ Isolating individual bridge ports
  #define BR_PROXYARP_WIFI      BIT(10)
 +#define BR_ISOLATE_MODE       BIT(11)
  
  #define BR_PROXYARP_WIFI      BIT(10)
 +#define BR_ISOLATE_MODE       BIT(11)
  
- /* values as per ieee8021QBridgeFdbAgingTime */
- #define BR_MIN_AGEING_TIME    (10 * HZ)
+ #define BR_DEFAULT_AGEING_TIME        (300 * HZ)
 --- a/net/bridge/br_sysfs_if.c
 +++ b/net/bridge/br_sysfs_if.c
 @@ -173,6 +173,22 @@ BRPORT_ATTR_FLAG(unicast_flood, BR_FLOOD
 --- a/net/bridge/br_sysfs_if.c
 +++ b/net/bridge/br_sysfs_if.c
 @@ -173,6 +173,22 @@ BRPORT_ATTR_FLAG(unicast_flood, BR_FLOOD
index 59aa1eda15a7ac907590f2a0fb481beb8896f90a..f729f38f11ad40e47c427df74ab10dee9185c83e 100644 (file)
@@ -11,8 +11,8 @@ Implement optinal multicast->unicast conversion for igmp snooping
  #define BR_ISOLATE_MODE       BIT(11)
 +#define BR_MULTICAST_TO_UCAST BIT(12)
  
  #define BR_ISOLATE_MODE       BIT(11)
 +#define BR_MULTICAST_TO_UCAST BIT(12)
  
- /* values as per ieee8021QBridgeFdbAgingTime */
- #define BR_MIN_AGEING_TIME    (10 * HZ)
+ #define BR_DEFAULT_AGEING_TIME        (300 * HZ)
 --- a/net/bridge/br_multicast.c
 +++ b/net/bridge/br_multicast.c
 @@ -42,12 +42,13 @@ static void br_multicast_add_router(stru
 --- a/net/bridge/br_multicast.c
 +++ b/net/bridge/br_multicast.c
 @@ -42,12 +42,13 @@ static void br_multicast_add_router(stru
index e46e4709c13b87994a49e8b94e450fc75ffae7d1..ad95d4c67e8fa6a54174b6724c592014e481835d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2155,7 +2155,7 @@ static inline int pskb_network_may_pull(
+@@ -2179,7 +2179,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index 341a31b137efd4f182dbdad6e8de221938d1d0d5..dad74482ab226d7b62181721860a4dd0912d93cd 100644 (file)
@@ -14,7 +14,7 @@ when needed.
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2200,6 +2200,24 @@ static inline void pskb_trim_unique(stru
+@@ -2224,6 +2224,24 @@ static inline void pskb_trim_unique(stru
        BUG_ON(err);
  }
  
        BUG_ON(err);
  }
  
index 7123c806460e2aff7438faa4cb1bbe7c454bc304..0d4409ebda122ad486532dc364235dd9be697365 100644 (file)
@@ -295,15 +295,15 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
                __skb_tunnel_rx(skb, t->dev, t->net);
  
  
                __skb_tunnel_rx(skb, t->dev, t->net);
  
-@@ -1179,6 +1316,7 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1224,6 +1361,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
        __u32 mtu;
        u8 tproto;
        int err;
 +      struct __ip6_tnl_fmr *fmr;
  
        tproto = ACCESS_ONCE(t->parms.proto);
        __u32 mtu;
        u8 tproto;
        int err;
 +      struct __ip6_tnl_fmr *fmr;
  
        tproto = ACCESS_ONCE(t->parms.proto);
-       if (tproto != IPPROTO_IPIP && tproto != 0)
-@@ -1198,6 +1336,18 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, str
+       if ((tproto != IPPROTO_IPV6 && tproto != 0) ||
+@@ -1254,6 +1392,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
@@ -321,8 +321,8 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
 +
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
 +
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
-               /* XXX: send ICMP error even if DF is not set. */
-@@ -1366,6 +1516,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+               if (err == -EMSGSIZE)
+@@ -1368,6 +1518,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
@@ -337,7 +337,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        ip6_tnl_dst_reset(t);
        ip6_tnl_link_config(t);
        return 0;
        ip6_tnl_dst_reset(t);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1404,6 +1562,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
+@@ -1406,6 +1564,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -345,7 +345,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1699,6 +1858,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1701,6 +1860,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
        return 0;
  }
  
@@ -361,7 +361,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1730,6 +1898,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1732,6 +1900,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_PROTO])
                parms->proto = nla_get_u8(data[IFLA_IPTUN_PROTO]);
  
        if (data[IFLA_IPTUN_PROTO])
                parms->proto = nla_get_u8(data[IFLA_IPTUN_PROTO]);
@@ -408,7 +408,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static int ip6_tnl_newlink(struct net *src_net, struct net_device *dev,
  }
  
  static int ip6_tnl_newlink(struct net *src_net, struct net_device *dev,
-@@ -1782,6 +1990,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -1784,6 +1992,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -421,7 +421,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -1799,6 +2013,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -1801,6 +2015,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(4) +
                /* IFLA_IPTUN_PROTO */
                nla_total_size(1) +
                nla_total_size(4) +
                /* IFLA_IPTUN_PROTO */
                nla_total_size(1) +
@@ -446,7 +446,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
                0;
  }
  
-@@ -1806,6 +2038,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1808,6 +2040,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -456,7 +456,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
-@@ -1814,8 +2049,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1816,8 +2051,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
@@ -485,7 +485,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return 0;
  
  nla_put_failure:
        return 0;
  
  nla_put_failure:
-@@ -1839,6 +2093,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -1841,6 +2095,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
index 04bafcdfdc93c358e68d924c862fd411f9a4fe6f..79af5f91cd6bf3916f3f47951aac4dc8d6ef0c4e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1297,6 +1297,7 @@ enum netdev_priv_flags {
+@@ -1298,6 +1298,7 @@ enum netdev_priv_flags {
        IFF_NO_QUEUE                    = 1<<21,
        IFF_OPENVSWITCH                 = 1<<22,
        IFF_L3MDEV_SLAVE                = 1<<23,
        IFF_NO_QUEUE                    = 1<<21,
        IFF_OPENVSWITCH                 = 1<<22,
        IFF_L3MDEV_SLAVE                = 1<<23,
@@ -8,7 +8,7 @@
  };
  
  #define IFF_802_1Q_VLAN                       IFF_802_1Q_VLAN
  };
  
  #define IFF_802_1Q_VLAN                       IFF_802_1Q_VLAN
-@@ -1323,6 +1324,7 @@ enum netdev_priv_flags {
+@@ -1324,6 +1325,7 @@ enum netdev_priv_flags {
  #define IFF_NO_QUEUE                  IFF_NO_QUEUE
  #define IFF_OPENVSWITCH                       IFF_OPENVSWITCH
  #define IFF_L3MDEV_SLAVE              IFF_L3MDEV_SLAVE
  #define IFF_NO_QUEUE                  IFF_NO_QUEUE
  #define IFF_OPENVSWITCH                       IFF_OPENVSWITCH
  #define IFF_L3MDEV_SLAVE              IFF_L3MDEV_SLAVE
@@ -41,7 +41,7 @@
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2186,6 +2186,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2210,6 +2210,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -52,7 +52,7 @@
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2308,16 +2312,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2332,16 +2336,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
  }
  
  
index ee85c40b62cac0df9fb0fc214a1e27e827f195a0..460da1dbe063275a845cef4f4f4d16d20519d892 100644 (file)
@@ -26,7 +26,7 @@
  endif
 --- a/include/linux/fs.h
 +++ b/include/linux/fs.h
  endif
 --- a/include/linux/fs.h
 +++ b/include/linux/fs.h
-@@ -2681,6 +2681,7 @@ enum {
+@@ -2691,6 +2691,7 @@ enum {
        DIO_SKIP_DIO_COUNT = 0x08,
  };
  
        DIO_SKIP_DIO_COUNT = 0x08,
  };
  
@@ -34,7 +34,7 @@
  void dio_end_io(struct bio *bio, int error);
  
  ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
  void dio_end_io(struct bio *bio, int error);
  
  ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-@@ -2688,6 +2689,18 @@ ssize_t __blockdev_direct_IO(struct kioc
+@@ -2698,6 +2699,18 @@ ssize_t __blockdev_direct_IO(struct kioc
                             loff_t offset, get_block_t get_block,
                             dio_iodone_t end_io, dio_submit_t submit_io,
                             int flags);
                             loff_t offset, get_block_t get_block,
                             dio_iodone_t end_io, dio_submit_t submit_io,
                             int flags);
index afe32c29f48c7deb785bb4e6c36a3519a0268183..f417b3ef0f943ae64bbe0b60a3f347eea5d4bc5e 100644 (file)
@@ -5495,7 +5495,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1229,6 +1229,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1212,6 +1212,8 @@ void pci_walk_bus(struct pci_bus *top, i
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);