fix prepare error with brcm-2.4 and missing files/ (thx, thepeople)
authorFelix Fietkau <nbd@openwrt.org>
Tue, 21 Oct 2008 19:26:36 +0000 (19:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 21 Oct 2008 19:26:36 +0000 (19:26 +0000)
SVN-Revision: 13021

include/quilt.mk

index c569231173ed63cc0ab0890ed330a7c0e2e524fc..d3233d823895cbcd06a3e742bad047923f507d37 100644 (file)
@@ -66,9 +66,10 @@ define Build/Patch/Default
        $(call PatchDir,$(PATCH_DIR),)
 endef
 
+kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
 define Kernel/Patch/Default
        rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
-       $(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+       $(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
        find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
        $(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
        $(call PatchDir,$(PATCH_DIR),platform/)