layerscape: ls1012ardb: only reserve ext4 fs as default firmware.bin
authorYutang Jiang <yutang.jiang@nxp.com>
Wed, 9 Nov 2016 15:51:48 +0000 (23:51 +0800)
committerJohn Crispin <john@phrozen.org>
Wed, 16 Nov 2016 09:54:33 +0000 (10:54 +0100)
In Device/ls1012ardb IMAGES variable, there are two separate firmware
references to the same packages, while do mult-job compile, the same package
build process will arise conflict occasionally. So, only reserve one ext4 fs
as the default firmware.bin.

Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
target/linux/layerscape/image/Makefile

index 6005e91cc43f5ec0e6cfe8ffcde388773e6f5afd..bb94ff863f9dc8dd9b920b3baffc37dcd0049f7c 100644 (file)
@@ -72,10 +72,6 @@ ifeq ($(SUBTARGET),32b)
   DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
 endif
   IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
-                                       append-ls-dtb $$(DEVICE_DTS) | pad-to 4M | append-kernel | pad-to 9M | \
-                                       append-rootfs | pad-to 32M | check-size 33554433
-  IMAGES += firmware.ext4.bin
-  IMAGE/firmware.ext4.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
                                        append-ls-dtb $$(DEVICE_DTS) | pad-to 4M | append-kernel | pad-to 9M | \
                                        append-ls-rootfs-ext4 $(1) 23M | check-size 33554433
 endef