mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 28 Dec 2012 19:17:19 +0000 (19:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 28 Dec 2012 19:17:19 +0000 (19:17 +0000)
SVN-Revision: 34909

include/target.mk
target/linux/ar71xx/Makefile
target/linux/generic/patches-3.6/302-mips_no_branch_likely.patch [new file with mode: 0644]
target/linux/generic/patches-3.6/305-mips_module_reloc.patch
target/linux/generic/patches-3.7/302-mips_no_branch_likely.patch [new file with mode: 0644]
target/linux/lantiq/Makefile
target/linux/ramips/Makefile

index 61cdf0640efa8aa969cd596362b421b05c3bea67..4f31aaf170f24bd954c164e7d750bf21ec681d8f 100644 (file)
@@ -193,7 +193,7 @@ ifeq ($(DUMP),1)
   DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -fno-caller-saves
   DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -fno-caller-saves
   DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e -fno-caller-saves
-  DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves
+  DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -mno-branch-likely
   DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
   DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -fno-caller-saves
   DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
index 73d90e37b11b0a3388509ea479260d59ae5efa64..fe8826f07146773f5b0b0f894f1ec6c526727baa 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
 FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
 LINUX_VERSION:=3.6.11
diff --git a/target/linux/generic/patches-3.6/302-mips_no_branch_likely.patch b/target/linux/generic/patches-3.6/302-mips_no_branch_likely.patch
new file mode 100644 (file)
index 0000000..1da9540
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also.  Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y                      += -msoft-float
+ LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
+ KBUILD_AFLAGS_MODULE          += -mlong-calls
index fea4a0012939973df964686c46aa883fea0b716e..a2738dca7e4b6adc798bbe7f37a1348cef114aa0 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
 @@ -90,8 +90,8 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
- cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
+ cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
  cflags-y                      += -msoft-float
  LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
 -KBUILD_AFLAGS_MODULE          += -mlong-calls
diff --git a/target/linux/generic/patches-3.7/302-mips_no_branch_likely.patch b/target/linux/generic/patches-3.7/302-mips_no_branch_likely.patch
new file mode 100644 (file)
index 0000000..1da9540
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also.  Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y                      += -msoft-float
+ LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
+ KBUILD_AFLAGS_MODULE          += -mlong-calls
index d0eb2df1be81d931e4b93b18d989fb82e71af2fd..84958df7f65c027d55054c3d9ea6023a6e0e97fa 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS=xway ase falcon
 
 LINUX_VERSION:=3.7.1
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC
index e165da6f239be0351bb405cd2831c85198429bc7..ba00c926829f36fdb6205d4f35cff74af683a034 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
 LINUX_VERSION:=3.6.11