sunxi: use common image prefix
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 27 May 2015 15:34:48 +0000 (15:34 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 27 May 2015 15:34:48 +0000 (15:34 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 45788

target/linux/sunxi/image/Makefile

index 3187a2df598c82d79207d10a2ce59823f2de0967..6fcd61f5dbb6e2cb142f76f888a87c1b8ce4b00e 100644 (file)
@@ -52,7 +52,7 @@ define Image/Build/SDCard
        rm -f $(KDIR)/boot.img
        mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
        
-       mcopy -i $(KDIR)/boot.img $(BIN_DIR)/uboot-sunxi-$(PROFILE)/openwrt-sunxi-$(PROFILE)-boot.scr ::boot.scr
+       mcopy -i $(KDIR)/boot.img $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-boot.scr ::boot.scr
        mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(2).dtb ::dtb
        mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
        
@@ -62,7 +62,7 @@ define Image/Build/SDCard
                $(KDIR)/root.$(1) \
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
-               $(BIN_DIR)/uboot-sunxi-$(PROFILE)/openwrt-sunxi-$(PROFILE)-u-boot-with-spl.bin
+               $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-u-boot-with-spl.bin
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime
@@ -125,7 +125,7 @@ define Image/Build
        $(call Image/Build/$(1),$(1))
        $(call Image/Build/Profile/$(PROFILE),$(1))
        
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))