kernel: bump 4.14 to 4.14.129
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 24 Jun 2019 11:38:47 +0000 (13:38 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 24 Jun 2019 14:36:30 +0000 (16:36 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/450-gpio-nxp-74hc153-gpio-chip-driver.patch
target/linux/ar71xx/patches-4.14/451-gpio-74x164-improve-platform-device-support.patch
target/linux/ar71xx/patches-4.14/452-gpio-add-gpio-latch-driver.patch
target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch
target/linux/generic/backport-4.14/296-v4.16-netfilter-don-t-allocate-space-for-arp-bridge-hooks-.patch
target/linux/generic/backport-4.14/308-v4.16-netfilter-move-reroute-indirection-to-struct-nf_ipv6.patch
target/linux/generic/backport-4.14/380-v5.3-net-sched-Introduce-act_ctinfo-action.patch

index 4de0faea16f90af7ce580f350c1f2901bfdd2c11..a1ef72c17097a19dc0ff675601375c36406e3611 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .183
-LINUX_VERSION-4.14 = .128
+LINUX_VERSION-4.14 = .129
 LINUX_VERSION-4.19 = .53
 
 LINUX_KERNEL_HASH-4.9.183 = fd57b0991cdbf4e2e933c260356a4768d6685a77460684f8de36a59fd42867f3
-LINUX_KERNEL_HASH-4.14.128 = e93c2c754f1f9c610314b2fe9f27a9636ad3a7f43983469bb8e0f44a531f2913
+LINUX_KERNEL_HASH-4.14.129 = 7548482b03aea1784e728e4d29fe75a2abc61c9dbf9851ec925a7fbecf9336e4
 LINUX_KERNEL_HASH-4.19.53 = e647730b7eafac70c3bd7abed4e6ed5a09eb794c645fcb0c62a79f62edbdeb02
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3ea491bc37bc644be6eed7ffe294c7a48844e123..0902773ff4523ff0492c7cd5a5a4b62185439a57 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1298,4 +1298,12 @@ config GPIO_VIPERBOARD
+@@ -1299,4 +1299,12 @@ config GPIO_VIPERBOARD
  
  endmenu
  
index 870804e9373cc27ed148f76ec7eda5fe5ac9e245..8039a71689016fa795ae9cdbd0746dc19320b789 100644 (file)
 +#endif
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1250,7 +1250,6 @@ menu "SPI GPIO expanders"
+@@ -1251,7 +1251,6 @@ menu "SPI GPIO expanders"
  
  config GPIO_74X164
        tristate "74x164 serial-in/parallel-out 8-bits shift register"
index d88b480410e8950f923981ba5a8e5fa016f5db3e..13c5781deec97ea1c9e8327cb185a6d31de5afd5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1305,4 +1305,9 @@ config GPIO_NXP_74HC153
+@@ -1306,4 +1306,9 @@ config GPIO_NXP_74HC153
          Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
          provides a GPIO interface supporting input mode only.
  
index 9b33393c01d5912451f8893654a8a1cc30c1983b..5e339865d38bfdb541ca50284350ee27d4284954 100644 (file)
@@ -159,7 +159,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        net->nf.proc_netfilter = proc_net_mkdir(net, "netfilter",
 --- a/net/netfilter/nf_queue.c
 +++ b/net/netfilter/nf_queue.c
-@@ -201,6 +201,23 @@ repeat:
+@@ -202,6 +202,23 @@ repeat:
        return NF_ACCEPT;
  }
  
@@ -183,7 +183,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  /* Caller must hold rcu read-side lock */
  void nf_reinject(struct nf_queue_entry *entry, unsigned int verdict)
  {
-@@ -216,12 +233,12 @@ void nf_reinject(struct nf_queue_entry *
+@@ -217,12 +234,12 @@ void nf_reinject(struct nf_queue_entry *
        net = entry->state.net;
        pf = entry->state.pf;
  
index 9444f6bb482810beb0b29e2d798070a8989c9fd5..b27b02f5061ae960283aad6dfd24c606d0eb7b60 100644 (file)
@@ -152,7 +152,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  #endif
 --- a/net/netfilter/nf_queue.c
 +++ b/net/netfilter/nf_queue.c
-@@ -204,8 +204,10 @@ repeat:
+@@ -205,8 +205,10 @@ repeat:
  static struct nf_hook_entries *nf_hook_entries_head(const struct net *net, u8 pf, u8 hooknum)
  {
        switch (pf) {
index 6e9413e511fdf35ab44686d1dda8e820a9e020a3..9303a0b777b6c029c1c577813b0a94f8e3f50696 100644 (file)
@@ -171,7 +171,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  
 --- a/net/netfilter/nf_queue.c
 +++ b/net/netfilter/nf_queue.c
-@@ -266,7 +266,6 @@ void nf_reinject(struct nf_queue_entry *
+@@ -267,7 +267,6 @@ void nf_reinject(struct nf_queue_entry *
        const struct nf_hook_entry *hook_entry;
        const struct nf_hook_entries *hooks;
        struct sk_buff *skb = entry->skb;
@@ -179,7 +179,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        const struct net *net;
        unsigned int i;
        int err;
-@@ -293,8 +292,7 @@ void nf_reinject(struct nf_queue_entry *
+@@ -294,8 +293,7 @@ void nf_reinject(struct nf_queue_entry *
                verdict = nf_hook_entry_hookfn(hook_entry, skb, &entry->state);
  
        if (verdict == NF_ACCEPT) {
index fa7d4c8c1585ed23aa8fddaabffa686dc0fb07be..dd22d2bfac1868c5c03b04d1f9a1cc725e6107a2 100644 (file)
@@ -55,9 +55,6 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
  create mode 100644 include/uapi/linux/tc_act/tc_ctinfo.h
  create mode 100644 net/sched/act_ctinfo.c
 
-diff --git a/include/net/tc_act/tc_ctinfo.h b/include/net/tc_act/tc_ctinfo.h
-new file mode 100644
-index 000000000000..f071c1d70a25
 --- /dev/null
 +++ b/include/net/tc_act/tc_ctinfo.h
 @@ -0,0 +1,33 @@
@@ -94,8 +91,6 @@ index 000000000000..f071c1d70a25
 +#define to_ctinfo(a) ((struct tcf_ctinfo *)a)
 +
 +#endif /* __NET_TC_CTINFO_H */
-diff --git a/include/uapi/linux/pkt_cls.h b/include/uapi/linux/pkt_cls.h
-index 46c506615f4a..408b02fbb34a 100644
 --- a/include/uapi/linux/pkt_cls.h
 +++ b/include/uapi/linux/pkt_cls.h
 @@ -66,7 +66,8 @@ enum {
@@ -108,9 +103,6 @@ index 46c506615f4a..408b02fbb34a 100644
  };
  
  #define TCA_ID_MAX __TCA_ID_MAX
-diff --git a/include/uapi/linux/tc_act/tc_ctinfo.h b/include/uapi/linux/tc_act/tc_ctinfo.h
-new file mode 100644
-index 000000000000..f5f26d95d0e7
 --- /dev/null
 +++ b/include/uapi/linux/tc_act/tc_ctinfo.h
 @@ -0,0 +1,29 @@
@@ -143,8 +135,6 @@ index 000000000000..f5f26d95d0e7
 +#define TCA_CTINFO_MAX (__TCA_CTINFO_MAX - 1)
 +
 +#endif
-diff --git a/net/sched/Kconfig b/net/sched/Kconfig
-index e70ed26485a2..962d90f72f54 100644
 --- a/net/sched/Kconfig
 +++ b/net/sched/Kconfig
 @@ -808,6 +808,19 @@ config NET_ACT_CONNMARK
@@ -167,8 +157,6 @@ index e70ed26485a2..962d90f72f54 100644
  config NET_ACT_SKBMOD
          tristate "skb data modification action"
          depends on NET_CLS_ACT
-diff --git a/net/sched/Makefile b/net/sched/Makefile
-index 9e43a4721ef8..44ee5b87b895 100644
 --- a/net/sched/Makefile
 +++ b/net/sched/Makefile
 @@ -21,6 +21,7 @@ obj-$(CONFIG_NET_ACT_CSUM)   += act_csum.o
@@ -179,9 +167,6 @@ index 9e43a4721ef8..44ee5b87b895 100644
  obj-$(CONFIG_NET_ACT_SKBMOD)  += act_skbmod.o
  obj-$(CONFIG_NET_ACT_IFE)     += act_ife.o
  obj-$(CONFIG_NET_IFE_SKBMARK) += act_meta_mark.o
-diff --git a/net/sched/act_ctinfo.c b/net/sched/act_ctinfo.c
-new file mode 100644
-index 000000000000..e65344e32801
 --- /dev/null
 +++ b/net/sched/act_ctinfo.c
 @@ -0,0 +1,394 @@
@@ -579,6 +564,3 @@ index 000000000000..e65344e32801
 +MODULE_AUTHOR("Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>");
 +MODULE_DESCRIPTION("Conntrack mark to DSCP restoring");
 +MODULE_LICENSE("GPL");
--- 
-2.20.1 (Apple Git-117)
-