linux: disable kmod-zram on ep93xx, it does not export unmap_kernel_range
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 25 Jan 2015 21:02:12 +0000 (21:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 25 Jan 2015 21:02:12 +0000 (21:02 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44145

package/kernel/linux/modules/other.mk

index b2d8eb7efaadc56b6d08eee56c4ec616f6481f42..25e0f199d8fe5db42f09b6fc4af3808a3d34399f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -748,7 +748,7 @@ $(eval $(call KernelPackage,ikconfig))
 define KernelPackage/zram
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ZRAM
-  DEPENDS:=+kmod-lib-lzo
+  DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx
   KCONFIG:= \
        CONFIG_ZSMALLOC \
        CONFIG_ZRAM \