base-files/sysupgrade: add more busybox applet symlinks to ramdisk
authorGabor Juhos <juhosg@openwrt.org>
Thu, 27 Oct 2011 07:54:49 +0000 (07:54 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 27 Oct 2011 07:54:49 +0000 (07:54 +0000)
Adds symlinks for printf and wc to make life happier in the sysupgrade ramdisk.
Also make code more readable by escaping that overly long line.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
SVN-Revision: 28616

package/base-files/Makefile
package/base-files/files/lib/upgrade/common.sh

index 002d51674de27a4e1602f2045102d8acc6261b13..7e895f1d31d7abacddd36931b675fb28398bfecb 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=83
+PKG_RELEASE:=84
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 11e1b2cdfaa4d49c35a2d7ee7989f703fd62f67e..65ce816db263adc7edee20e91ea4ad7defe5da7e 100644 (file)
@@ -48,7 +48,12 @@ pivot() { # <new_root> <old_root>
 }
 
 run_ramfs() { # <command> [...]
-       install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump /bin/sleep /bin/zcat /usr/bin/bzcat
+       install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount        \
+               /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd   \
+               /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" \
+               /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump          \
+               /bin/sleep /bin/zcat /usr/bin/bzcat /usr/bin/printf /usr/bin/wc
+
        install_bin /sbin/mtd
        for file in $RAMFS_COPY_BIN; do
                install_bin $file