ramips: add WHR-1166 support
authorJohn Crispin <john@openwrt.org>
Tue, 1 Jul 2014 10:26:42 +0000 (10:26 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 1 Jul 2014 10:26:42 +0000 (10:26 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 41447

target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/01_leds
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/dts/WHR-1166D.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 904afd1a41236e72a9b4536cef0f3a54a07734c4..3ed0fbb670e3bd6d66b82976c0b272cbc109c3c5 100644 (file)
@@ -110,6 +110,7 @@ case "$FIRMWARE" in
        whr-g300n | \
        whr-300hp2 | \
        whr-600d | \
+       whr-1166d | \
        wl-330n | \
        wl-330n3g | \
        wl-351 | \
@@ -141,7 +142,7 @@ case "$FIRMWARE" in
        cy-swr1100)
                rt2x00_eeprom_extract "factory" 8192 512
                ;;
-       rt-n56u | whr-600d)
+       rt-n56u | whr-600d | whr-1166d)
                rt2x00_eeprom_extract "factory" 32768 512
                ;;
        esac
index c5e380cbc6e37c2fde840dafcae90b21ada6ca8f..c2f768b8a32b46895fcf5c8165140a3731f56c82 100755 (executable)
@@ -176,7 +176,8 @@ case $board in
                set_wifi_led "asus:blue:wifi"
                ;;
        whr-300hp2 |\
-       whr-600d)
+       whr-600d |\
+       whr-1166d)
                ucidef_set_led_default "power" "power" "buffalo:green:power" "1"
                ucidef_set_led_default "router" "router" "buffalo:green:router" "1"
                ;;
index 5d897fc521da922647c86bea68d2a38b63a87bca..697599341b16787a540ba073e720f7f808d6276a 100755 (executable)
@@ -241,6 +241,9 @@ ramips_board_detect() {
        *"WHR-600D")
                name="whr-600d"
                ;;
+       *"WHR-1166D")
+               name="whr-1166d"
+               ;;
        *"WHR-G300N")
                name="whr-g300n"
                ;;
diff --git a/target/linux/ramips/dts/WHR-1166D.dts b/target/linux/ramips/dts/WHR-1166D.dts
new file mode 100644 (file)
index 0000000..47e0b1b
--- /dev/null
@@ -0,0 +1,138 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "ralink,mt7620a-soc";
+       model = "Buffalo WHR-1166D";
+
+       palmbus@10000000 {
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "en25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "mx25l6405d";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xeb0000>;
+                               };
+
+                               partition@e00000 {
+                                       label = "usercfg";
+                                       reg = <0xe00000 0x100000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "wled", "nd_sd";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+
+               ralink,port-map = "llllw";
+       };
+
+       gsw@10110000 {
+               ralink,port4 = "ephy";
+       };
+
+       pcie@10140000 {
+               status = "okay";
+       };
+       
+       gpio-leds {
+               compatible = "gpio-leds";
+               power {
+                       label = "buffalo:red:power";
+                       gpios = <&gpio0 7 1>;
+               };
+               status {
+                       label = "buffalo:green:status";
+                       gpios = <&gpio0 8 1>;
+               };
+               power2 {
+                       label = "buffalo:green:power";
+                       gpios = <&gpio0 9 1>;
+               };
+               status2 {
+                       label = "buffalo:orange:status";
+                       gpios = <&gpio0 10 1>;
+               };
+               internet {
+                       label = "buffalo:green:internet";
+                       gpios = <&gpio2 17 1>;
+               };
+               router {
+                       label = "buffalo:green:router";
+                       gpios = <&gpio2 18 1>;
+               };
+               router2 {
+                       label = "buffalo:orange:router";
+                       gpios = <&gpio2 19 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               s1 {
+                       label = "reset";
+                       gpios = <&gpio2 12 1>;
+                       linux,code = <0x100>;
+               };
+               s2 {
+                       label = "aoss";
+                       gpios = <&gpio2 13 1>;
+                       linux,code = <0x101>;
+               };
+               s3 {
+                       label = "ap";
+                       gpios = <&gpio2 14 1>;
+                       linux,code = <0x102>;
+               };
+               s4 {
+                       label = "bridge";
+                       gpios = <&gpio2 15 1>;
+                       linux,code = <0x103>;
+               };
+       };
+};
index 1b342deb7a413ced6b8789611f5d7f60ab7c1571..ec3ef75de3a84200261ae99b545500b7c781198a 100644 (file)
@@ -705,6 +705,8 @@ Image/Build/Profile/RP-N53=$(call BuildFirmware/Default8M/$(1),$(1),rp_n53,RP-N5
 whr_300hp2_mtd_size=7012352
 Image/Build/Profile/WHR300HP2=$(call BuildFirmware/CustomFlash/$(1),$(1),whr-300hp2,WHR-300HP2,$(whr_300hp2_mtd_size))
 Image/Build/Profile/WHR600D=$(call BuildFirmware/CustomFlash/$(1),$(1),whr-600d,WHR-600D,$(whr_300hp2_mtd_size))
+whr_1166d_mtd_size=15400960
+Image/Build/Profile/WHR1166D=$(call BuildFirmware/CustomFlash/$(1),$(1),whr-1166d,WHR-1166D,$(whr_1166hd_mtd_size))
 dlink810l_mtd_size=6881280
 Image/Build/Profile/DIR-810L=$(call BuildFirmware/CustomFlash/$(1),$(1),dir-810l,DIR-810L,$(dlink810l_mtd_size))
 na930_mtd_size=20971520
@@ -720,6 +722,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR-810L,$(1))
        $(call Image/Build/Profile/WHR300HP2,$(1))
        $(call Image/Build/Profile/WHR600D,$(1))
+       $(call Image/Build/Profile/WHR1166D,$(1))
        $(call Image/Build/Profile/NA930,$(1))
 endef
 endif