x86: add packages files to image bootfs
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Tue, 20 Nov 2018 16:20:41 +0000 (17:20 +0100)
committerJohn Crispin <john@phrozen.org>
Mon, 26 Nov 2018 11:05:44 +0000 (12:05 +0100)
Add files to bootfs image from selected as built-in packages, which want
to install files to targets boot file system.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/x86/image/Makefile

index b537c40f24e6c3c2a2d76fb36095205e8eaaa7cd..dbf8a8594b44865ef3ff509d8262d9d2103b4a56 100644 (file)
@@ -85,6 +85,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
                -e 's#@ROOT@#$(GRUB_ROOT)#g' \
                -e 's#@TITLE@#$(GRUB_TITLE)#g' \
                ./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
        PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" $(SCRIPT_DIR)/gen_image_generic.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
@@ -123,6 +124,7 @@ define Image/Build/iso
                -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
                -e 's#@TITLE@#$(GRUB_TITLE)#g' \
                ./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $(KDIR)/root.grub/boot/
        mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
                -o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
 endef