mbedtls: Cosmetic cleanups
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Sun, 10 Jun 2018 22:22:36 +0000 (00:22 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 18 Jun 2018 18:28:20 +0000 (20:28 +0200)
This is more of a cosmetic change and a reminder that the CMake script hardcodes -O2.
Source:
https://github.com/ARMmbed/mbedtls/blob/mbedtls-2.7/CMakeLists.txt#L73
https://github.com/ARMmbed/mbedtls/blob/master/CMakeLists.txt#L97

Remove the release type option as it's already provided by the toolchain.
Source:
https://github.com/openwrt/openwrt/blob/master/include/cmake.mk#L50

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
package/libs/mbedtls/Makefile

index 8e0a480e40b74ae035fa4026c8ee984e2e283148..19db4b803bacb19ef08468be254576b23698d738 100644 (file)
@@ -64,9 +64,9 @@ endef
 PKG_INSTALL:=1
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_CFLAGS := $(filter-out -O%,$(TARGET_CFLAGS))
 
 CMAKE_OPTIONS += \
-       -DCMAKE_BUILD_TYPE:String="Release" \
        -DUSE_SHARED_MBEDTLS_LIBRARY:Bool=ON \
        -DENABLE_TESTING:Bool=OFF \
        -DENABLE_PROGRAMS:Bool=ON