ar71xx: increase kernel partition size for TP-Link RE450 v1
authorPiotr Dymacz <pepe2k@gmail.com>
Mon, 6 Nov 2017 22:17:24 +0000 (23:17 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Tue, 14 Nov 2017 21:36:46 +0000 (22:36 +0100)
This increases kernel partition size and fixes rootfs (file-system)
partition size on TP-Link RE450 v1. Also, while we are at it, switch
from statically defined kernel and rootfs partitions in kernel cmdline
to "tplink-fw" mtd splitter.

Fixes: FS#1072.
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ar71xx/image/tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index bbc21d4044744341e1167b14deb03073b8a86628..f31185898670dac2b7243bca2cca122f0e7ff7f5 100644 (file)
@@ -270,7 +270,7 @@ TARGET_DEVICES += eap120-v1
 define Device/re450-v1
   DEVICE_TITLE := TP-LINK RE450 v1
   DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
-  MTDPARTS := spi0.0:128k(u-boot)ro,1344k(kernel),4672k(rootfs),64k(partition-table)ro,64k(product-info)ro,1856k(config)ro,64k(art)ro,6016k@0x20000(firmware)
+  MTDPARTS := spi0.0:128k(u-boot)ro,6016k(firmware),64k(partition-table)ro,64k(product-info)ro,1856k(config)ro,64k(art)ro
   IMAGE_SIZE := 7936k
   BOARDNAME := RE450
   TPLINK_BOARD_ID := RE450
index 65b37926f6112393c9f03fb295c4de942cd28c9c..eef1f913b96ff70497fc798d95bf02f796256243 100644 (file)
@@ -852,8 +852,8 @@ static struct device_info boards[] = {
                */
                .partitions = {
                        {"fs-uboot", 0x00000, 0x20000},
-                       {"os-image", 0x20000, 0x150000},
-                       {"file-system", 0x170000, 0x4a0000},
+                       {"os-image", 0x20000, 0x180000},
+                       {"file-system", 0x1a0000, 0x460000},
                        {"partition-table", 0x600000, 0x02000},
                        {"default-mac", 0x610000, 0x00020},
                        {"pin", 0x610100, 0x00020},