layerscape: fix PKG_BUILD_DIR for packages
authorYangbo Lu <yangbo.lu@nxp.com>
Mon, 25 Dec 2017 04:21:26 +0000 (12:21 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 26 Dec 2017 22:30:59 +0000 (23:30 +0100)
PKG_BUILD_DIR was defined with quoting PKG_VERSION in
layerscape package makefiles. Now PKG_VERSION has been
removed from these makefiles. When PKG_BUILD_DIR quotes
PKG_VERSION, '=' should be used instead ':=' to make
sure PKG_VERSION has been defined in common makefile.

Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
package/firmware/layerscape/ls-dpl/Makefile
package/firmware/layerscape/ls-mc/Makefile

index c3e2f096a99c28cb24ffea28518c322612170d4f..86483cab89f68b282a09c977387e8b5d7135fe01 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://github.com/qoriq-open-source/dpl-examples.git
 PKG_SOURCE_VERSION:=a6c83759c0d9c02822eec89e86357a0998ef51d4
 PKG_MIRROR_HASH:=d0311591843fbf9faebc7e2f0d53cba47d42ef21c4407c5881f354df6c458ce5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_FLAGS:=nonshared
 
index eb58dd70a4ae2eef7f036eee7255a0f607805b0f..a81e095638dce38dcd79d5808428e5110f0c5e1c 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://github.com/qoriq-open-source/mc-binary.git
 PKG_SOURCE_VERSION:=824745fe1580b281bebb808321c3f41353a3140a
 PKG_MIRROR_HASH:=984c7905af3a4b87b72263de9220901c531fe064f0b89dd2882676354e09ed16
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_FLAGS:=nonshared