use autoreconf hook instead of manual call
authorJohn Crispin <john@openwrt.org>
Wed, 25 Jul 2012 10:34:06 +0000 (10:34 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 25 Jul 2012 10:34:06 +0000 (10:34 +0000)
SVN-Revision: 32837

include/package-version-override.mk
include/package.mk

index f69d9b1776b46f1a1402136712f6a4fc35aa6ebe..2c1741eef1683b1212a397807c2e741d34bdc08b 100644 (file)
@@ -62,7 +62,6 @@ define prepare_custom_source_directory
                rm -Rf $(PKG_BUILD_DIR); \
                echo "Preparing Custom Source Directory link: $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR)"; \
                ln -snf $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR) $(PKG_BUILD_DIR); \
-               [ -x "$(PKG_BUILD_DIR)/autoreconf" ] && (cd $(PKG_BUILD_DIR); autoreconf -i;) \
        else \
                echo "Custom Source Directory $(CONFIG_$(PKG_NAME)_CUSTOM_SOURCE_DIR) is invalid"; \
                false; \
index abffa0c64cc3ef23b83e369165d861fa8237a6fd..64973b051066803e5bdc5690fa33ec4e352d0cc2 100644 (file)
@@ -76,6 +76,9 @@ ifeq ($(CONFIG_$(PKG_NAME)_USE_CUSTOM_SOURCE_DIR),y)
 PKG_SOURCE_URL:=
 # add hook to install a link to customer source path of dedicated package
 Hooks/Prepare/Pre += prepare_custom_source_directory
+ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
+  Hooks/Configure/Pre += autoreconf_target
+endif
 # define empty default action
 define Build/Prepare/Default
        @: