docs: remove all refrences in Makefiles/scripts
authorMathias Kresin <dev@kresin.me>
Wed, 30 Nov 2016 09:00:41 +0000 (10:00 +0100)
committerMathias Kresin <dev@kresin.me>
Wed, 30 Nov 2016 09:13:14 +0000 (10:13 +0100)
The SDK Makefile still trys to copy the docs folder which was removed
with 882f4d2d63272abce8c1966983aa10178e2e971f. This causes an SDK build
error.

All other removals are just cleanup.

Signed-off-by: Mathias Kresin <dev@kresin.me>
include/toplevel.mk
scripts/checkpatch.pl
scripts/symlink-tree.sh
target/sdk/Makefile

index 81329ac41455c394b7e618c3f5372a1716407aab..f31884d3fe3050913869ea36a3c7d4f27abe7b5a 100644 (file)
@@ -223,12 +223,6 @@ package/symlinks-clean:
 help:
        cat README
 
-docs docs/compile: FORCE
-       @$(_SINGLE)$(SUBMAKE) -C docs compile
-
-docs/clean: FORCE
-       @$(_SINGLE)$(SUBMAKE) -C docs clean
-
 distclean:
        rm -rf bin build_dir .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
        @$(_SINGLE)$(SUBMAKE) -C scripts/config clean
index 9858e62fbbd41b920020a79de6c8b8aff1101d51..c4b7437b90250990c0bc9227fb503591a6fda0d3 100755 (executable)
@@ -391,7 +391,7 @@ sub top_of_openwrt_tree {
 
        my @tree_check = (
                "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README",
-               "docs", "feeds.conf.default", "include", "package", "rules.mk",
+               "feeds.conf.default", "include", "package", "rules.mk",
                "scripts", "target", "toolchain", "tools"
        );
 
index 3b7ce4718d3d36f8b456903de867c2ec8f75d4c2..aa169e2455f810f9f5ec4eb8123f9e9bbc82c049 100755 (executable)
@@ -10,7 +10,6 @@ FILES="
        Makefile
        README
        dl
-       docs
        feeds.conf.default
        include
        package
index 54c50ab760c9701e1cbb7db26358776bad2edac8..de77d1a31aa45e6c6dd2626595c5dcd9ca836854 100644 (file)
@@ -67,7 +67,7 @@ all: compile
 
 $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
        mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
-       $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
+       $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
        $(TAR) -cf - -C $(TOPDIR) \
                `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
                `cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \