packages: mt76: add 14c3:7610 pci id to list
authorPawel Dembicki <paweldembicki@gmail.com>
Wed, 25 Mar 2020 06:08:37 +0000 (07:08 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 8 Apr 2020 13:05:29 +0000 (14:05 +0100)
This commit add patch with 14c3:7610 pci id addition.

It was sent upstream.

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
[bumped PKG_RELEASE]
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/mt76/Makefile
package/kernel/mt76/patches/0001-mt76-mt76x0-pci-add-mt7610-PCI-ID.patch [new file with mode: 0644]

index 4ee79fe0425c017d51f00fa2fff869475a778401..965eafb6f8d077cd108c88a6c9b1d0d2dec15b46 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mt76
-PKG_RELEASE=1
+PKG_RELEASE=2
 
 PKG_LICENSE:=GPLv2
 PKG_LICENSE_FILES:=
diff --git a/package/kernel/mt76/patches/0001-mt76-mt76x0-pci-add-mt7610-PCI-ID.patch b/package/kernel/mt76/patches/0001-mt76-mt76x0-pci-add-mt7610-PCI-ID.patch
new file mode 100644 (file)
index 0000000..a2aa0ec
--- /dev/null
@@ -0,0 +1,30 @@
+From 9b082c3fd3fc954937444220995cb05662ab2e82 Mon Sep 17 00:00:00 2001
+From: Pawel Dembicki <paweldembicki@gmail.com>
+Date: Wed, 25 Mar 2020 06:51:29 +0100
+Subject: [PATCH] mt76: mt76x0: pci: add mt7610 PCI ID
+
+Add mt7610 PCI id found on D-Link DWR-960 to pci_device_id table.
+
+Run-tested on D-Link DWR-960 with no-name half-size mPCIE card
+with mt7610e.
+
+Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
+---
+ mt76x0/pci.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/mt76x0/pci.c b/mt76x0/pci.c
+index e2974e0ae1fc..3bd753cda190 100644
+--- a/mt76x0/pci.c
++++ b/mt76x0/pci.c
+@@ -215,6 +215,7 @@ mt76x0e_remove(struct pci_dev *pdev)
+ }
+
+ static const struct pci_device_id mt76x0e_device_table[] = {
++      { PCI_DEVICE(0x14c3, 0x7610) },
+       { PCI_DEVICE(0x14c3, 0x7630) },
+       { PCI_DEVICE(0x14c3, 0x7650) },
+       { },
+--
+2.20.1
+