Get rid of glamo-lcm-spi. It's not used and probably never will be.
authorLars-Peter Clausen <lars@metafoo.de>
Thu, 16 Jul 2009 19:01:45 +0000 (19:01 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Thu, 16 Jul 2009 19:01:45 +0000 (19:01 +0000)
SVN-Revision: 16871

target/linux/s3c24xx/config-2.6.30
target/linux/s3c24xx/files-2.6.30/drivers/mfd/glamo/Kconfig
target/linux/s3c24xx/files-2.6.30/drivers/mfd/glamo/Makefile
target/linux/s3c24xx/files-2.6.30/drivers/mfd/glamo/glamo-lcm-spi.c [deleted file]

index b28237da556eda77c00869305764d0b8843b0950..759966ded9f58a1a5d8ea96400bcf9beb884b328 100644 (file)
@@ -99,6 +99,7 @@ CONFIG_FB_CFB_IMAGEBLIT=y
 # CONFIG_FB_SYS_FOPS is not set
 # CONFIG_FB_SYS_IMAGEBLIT is not set
 # CONFIG_FB_TILEBLITTING is not set
+# CONFIG_FB_TMIO is not set
 # CONFIG_FB_VIRTUAL is not set
 CONFIG_FIQ=y
 # CONFIG_FIRMWARE_EDID is not set
@@ -248,11 +249,11 @@ CONFIG_MACH_NEO1973_GTA02=y
 # CONFIG_MACH_TCT_HAMMER is not set
 # CONFIG_MACH_VR1000 is not set
 # CONFIG_MACH_VSTMS is not set
+CONFIG_MFD_CORE=y
 CONFIG_MFD_GLAMO=y
 CONFIG_MFD_GLAMO_FB=y
 # CONFIG_MFD_GLAMO_FB_XGLAMO_WORKAROUND is not set
 CONFIG_MFD_GLAMO_MCI=y
-CONFIG_MFD_GLAMO_SPI_FB=y
 CONFIG_MFD_GLAMO_SPI_GPIO=y
 CONFIG_MFD_PCF50633=y
 # CONFIG_MFD_T7L66XB is not set
index c27c130895f2ddbf02b298142ec28f7dbbe4b139..2ae335a190e40dc5215b8abaa037b3a87cc29770 100644 (file)
@@ -41,14 +41,6 @@ config MFD_GLAMO_SPI_GPIO
        help
           Enable a bitbanging SPI adapter driver for the Smedia Glamo.
 
-config MFD_GLAMO_SPI_FB
-       tristate "Glamo LCM control channel SPI support"
-       depends on MFD_GLAMO_FB
-       help
-         Enable a bitbanging SPI adapter driver for the Smedia Glamo LCM
-         control channel.  This SPI interface is frequently used to
-         interconnect the LCM control interface.
-
 config MFD_GLAMO_MCI
        tristate "Glamo S3C SD/MMC Card Interface support"
        depends on MFD_GLAMO && MMC
index dc64d50fa13ff3f4dbca7b33e85892dd521e181c..99a927a5bfb63f03391b619bf99d7c4b83f9d707 100644 (file)
@@ -7,6 +7,5 @@ obj-$(CONFIG_MFD_GLAMO_SPI)             += glamo-spi.o
 obj-$(CONFIG_MFD_GLAMO_SPI_GPIO)       += glamo-spi-gpio.o
 
 obj-$(CONFIG_MFD_GLAMO_FB)             += glamo-fb.o
-obj-$(CONFIG_MFD_GLAMO_SPI_FB)         += glamo-lcm-spi.o
 obj-$(CONFIG_MFD_GLAMO_MCI)            += glamo-mci.o
 
diff --git a/target/linux/s3c24xx/files-2.6.30/drivers/mfd/glamo/glamo-lcm-spi.c b/target/linux/s3c24xx/files-2.6.30/drivers/mfd/glamo/glamo-lcm-spi.c
deleted file mode 100644 (file)
index 45d12fc..0000000
+++ /dev/null
@@ -1,241 +0,0 @@
-/*
- * Copyright (C) 2007 Openmoko, Inc.
- * Author: Harald Welte <laforge@openmoko.org>
- *
- * Smedia Glamo GPIO based SPI driver
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- *
- * This driver currently only implements a minimum subset of the hardware
- * features, esp. those features that are required to drive the jbt6k74
- * LCM controller asic in the TD028TTEC1 LCM.
- *
-*/
-
-#define DEBUG
-#if 0
-#include <linux/kernel.h>
-#include <linux/init.h>
-#include <linux/delay.h>
-#include <linux/device.h>
-#include <linux/spinlock.h>
-#include <linux/workqueue.h>
-#include <linux/platform_device.h>
-
-#include <linux/spi/spi.h>
-#include <linux/spi/spi_bitbang.h>
-#include <linux/spi/glamo.h>
-
-#include <linux/glamofb.h>
-
-#include <mach/hardware.h>
-
-#include "glamo-core.h"
-#include "glamo-regs.h"
-
-struct glamo_spi {
-       struct spi_bitbang      bitbang;
-       struct spi_master       *master;
-       struct glamo_spi_info   *info;
-       struct device           *dev;
-};
-
-static inline struct glamo_spi *to_gs(struct spi_device *spi)
-{
-       return spi->controller_data;
-}
-
-static int glamo_spi_setupxfer(struct spi_device *spi, struct spi_transfer *t)
-{
-       unsigned int bpw;
-
-       bpw = t ? t->bits_per_word : spi->bits_per_word;
-
-       if (bpw != 9 && bpw != 8) {
-               dev_err(&spi->dev, "invalid bits-per-word (%d)\n", bpw);
-               return -EINVAL;
-       }
-
-       return 0;
-}
-
-static void glamo_spi_chipsel(struct spi_device *spi, int value)
-{
-#if 0
-       struct glamo_spi *gs = to_gs(spi);
-
-       dev_dbg(&spi->dev, "chipsel %d: spi=%p, gs=%p, info=%p, handle=%p\n",
-               value, spi, gs, gs->info, gs->info->glamofb_handle);
-
-       glamofb_cmd_mode(gs->info->glamofb_handle, value);
-#endif
-}
-
-static int glamo_spi_txrx(struct spi_device *spi, struct spi_transfer *t)
-{
-       struct glamo_spi *gs = to_gs(spi);
-       const u_int16_t *ui16 = (const u_int16_t *) t->tx_buf;
-       u_int16_t nine_bits;
-       int i;
-
-       dev_dbg(&spi->dev, "txrx: tx %p, rx %p, bpw %d, len %d\n",
-               t->tx_buf, t->rx_buf, t->bits_per_word, t->len);
-
-       if (spi->bits_per_word == 9)
-               nine_bits = (1 << 9);
-       else
-               nine_bits = 0;
-
-       if (t->len > 3 * sizeof(u_int16_t)) {
-               dev_err(&spi->dev, "this driver doesn't support "
-                       "%u sized xfers\n", t->len);
-               return -EINVAL;
-       }
-
-       for (i = 0; i < t->len/sizeof(u_int16_t); i++) {
-               /* actually transfer the data */
-#if 1
-               glamofb_cmd_write(gs->info->glamofb_handle,
-                                 GLAMO_LCD_CMD_TYPE_SERIAL | nine_bits |
-                                 (1 << 10) | (1 << 11) | (ui16[i] & 0x1ff));
-#endif
-               /* FIXME: fire ?!? */
-               if (i == 0 && (ui16[i] & 0x1ff) == 0x29) {
-                       dev_dbg(&spi->dev, "leaving command mode\n");
-                       glamofb_cmd_mode(gs->info->glamofb_handle, 0);
-               }
-       }
-
-       return t->len;
-}
-
-static int glamo_spi_setup(struct spi_device *spi)
-{
-       int ret;
-
-       if (!spi->bits_per_word)
-               spi->bits_per_word = 9;
-
-       /* FIXME: hardware can do this */
-       if (spi->mode & SPI_LSB_FIRST)
-               return -EINVAL;
-
-       ret = glamo_spi_setupxfer(spi, NULL);
-       if (ret < 0) {
-               dev_err(&spi->dev, "setupxfer returned %d\n", ret);
-               return ret;
-       }
-
-       dev_dbg(&spi->dev, "%s: mode %d, %u bpw\n",
-               __FUNCTION__, spi->mode, spi->bits_per_word);
-
-       return 0;
-}
-
-static int glamo_spi_probe(struct platform_device *pdev)
-{
-       struct spi_master *master;
-       struct glamo_spi *sp;
-       int ret;
-       int i;
-
-       master = spi_alloc_master(&pdev->dev, sizeof(struct glamo_spi));
-       if (master == NULL) {
-               dev_err(&pdev->dev, "failed to allocate spi master\n");
-               ret = -ENOMEM;
-               goto err;
-       }
-
-       sp = spi_master_get_devdata(master);
-       memset(sp, 0, sizeof(struct glamo_spi));
-
-       sp->master = spi_master_get(master);
-       sp->info = pdev->dev.platform_data;
-       if (!sp->info) {
-               dev_err(&pdev->dev, "can't operate without platform data\n");
-               ret = -EIO;
-               goto err_no_pdev;
-       }
-       dev_dbg(&pdev->dev, "sp->info(pdata) = %p\n", sp->info);
-
-       sp->dev = &pdev->dev;
-
-       platform_set_drvdata(pdev, sp);
-
-       sp->bitbang.master = sp->master;
-       sp->bitbang.setup_transfer = glamo_spi_setupxfer;
-       sp->bitbang.chipselect = glamo_spi_chipsel;
-       sp->bitbang.txrx_bufs = glamo_spi_txrx;
-       sp->bitbang.master->setup = glamo_spi_setup;
-
-       ret = spi_bitbang_start(&sp->bitbang);
-       if (ret)
-               goto err_no_bitbang;
-
-       /* register the chips to go with the board */
-
-       glamofb_cmd_mode(sp->info->glamofb_handle, 1);
-
-       for (i = 0; i < sp->info->board_size; i++) {
-               dev_info(&pdev->dev, "registering %p: %s\n",
-                        &sp->info->board_info[i],
-                        sp->info->board_info[i].modalias);
-
-               sp->info->board_info[i].controller_data = sp;
-               spi_new_device(master, sp->info->board_info + i);
-       }
-
-       return 0;
-
-err_no_bitbang:
-       platform_set_drvdata(pdev, NULL);
-err_no_pdev:
-       spi_master_put(sp->bitbang.master);
-err:
-       return ret;
-
-}
-
-static int glamo_spi_remove(struct platform_device *pdev)
-{
-       struct glamo_spi *sp = platform_get_drvdata(pdev);
-
-       spi_bitbang_stop(&sp->bitbang);
-       spi_master_put(sp->bitbang.master);
-
-       return 0;
-}
-
-#define glamo_spi_suspend NULL
-#define glamo_spi_resume NULL
-
-static struct platform_driver glamo_spi_drv = {
-       .probe          = glamo_spi_probe,
-       .remove         = glamo_spi_remove,
-       .suspend        = glamo_spi_suspend,
-       .resume         = glamo_spi_resume,
-       .driver         = {
-               .name   = "glamo-lcm-spi",
-               .owner  = THIS_MODULE,
-       },
-};
-
-static int __init glamo_spi_init(void)
-{
-       return platform_driver_register(&glamo_spi_drv);
-}
-
-static void __exit glamo_spi_exit(void)
-{
-       platform_driver_unregister(&glamo_spi_drv);
-}
-
-module_init(glamo_spi_init);
-module_exit(glamo_spi_exit);
-
-MODULE_DESCRIPTION("Smedia Glamo 336x/337x LCM serial command SPI Driver");
-MODULE_AUTHOR("Harald Welte <laforge@openmoko.org>")
-MODULE_LICENSE("GPL");
-#endif