ath3k: Add firmware support for QCA Rome
authorRobert Marko <robimarko@gmail.com>
Mon, 2 Apr 2018 22:44:43 +0000 (00:44 +0200)
committerJohn Crispin <john@phrozen.org>
Fri, 18 May 2018 06:58:08 +0000 (08:58 +0200)
Add needed firmware for newer QCA Rome Bluetooth family.
This enables use of bluetooth with ath3k driver on QCA9377/9378 devices.

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/firmware/linux-firmware/qca.mk

index 0a809d1a2196c738bc1a3448c2d2157c991f5da1..23fcc0905a28b41ab5e1a61e63d3fb3bdd36e8d4 100644 (file)
@@ -4,6 +4,10 @@ define Package/ar3k-firmware/install
        $(CP) \
                $(PKG_BUILD_DIR)/ar3k/*.dfu \
                $(1)/lib/firmware/ar3k
+       $(INSTALL_DIR) $(1)/lib/firmware/qca
+       $(CP) \
+               $(PKG_BUILD_DIR)/qca/*.bin \
+               $(1)/lib/firmware/qca
 endef
 $(eval $(call BuildPackage,ar3k-firmware))