Enabled working ar7_wdt, style cleanups
authorMatteo Croce <rootkit85@yahoo.it>
Wed, 12 Sep 2007 16:15:12 +0000 (16:15 +0000)
committerMatteo Croce <rootkit85@yahoo.it>
Wed, 12 Sep 2007 16:15:12 +0000 (16:15 +0000)
SVN-Revision: 8764

target/linux/ar7/config-2.6.22
target/linux/ar7/files/arch/mips/ar7/vlynq-pci.c
target/linux/ar7/files/arch/mips/ar7/vlynq.c
target/linux/ar7/files/drivers/char/ar7_gpio.c
target/linux/ar7/files/drivers/char/watchdog/ar7_wdt.c
target/linux/ar7/files/drivers/leds/leds-ar7.c
target/linux/ar7/files/drivers/mtd/ar7part.c
target/linux/ar7/files/include/asm-mips/ar7/mmzone.h
target/linux/ar7/patches-2.6.22/110-flash.patch
target/linux/ar7/patches-2.6.22/500-serial_kludge.patch

index 605140a99adb17b3aec33b40380c293a104a3441..2137efd8a66fa979faafe675653c39930fd677c8 100644 (file)
@@ -3,7 +3,7 @@ CONFIG_32BIT=y
 # CONFIG_64BIT_PHYS_ADDR is not set
 CONFIG_AR7=y
 CONFIG_AR7_GPIO=y
-# CONFIG_AR7_WDT is not set
+CONFIG_AR7_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
 # CONFIG_ARCH_SUPPORTS_MSI is not set
index ffcfa62a17707854a2847e9831a71b0130879dfb..bffea513553025eacc2ed67a343d1e7ac91df7be 100644 (file)
@@ -133,7 +133,8 @@ static inline u32 vlynq_get_mapped(struct vlynq_device *dev, int res)
        return ret;
 }
 
-static inline u32 vlynq_read(u32 val, int size) {
+static inline u32 vlynq_read(u32 val, int size)
+{
        switch (size) {
        case 1:
                return *(u8 *)&val;
index 76dbd55ef4477625e281e279c7547e296746e72f..3e852cd670d4b30794284ec0c82d310bfcb4b556 100644 (file)
@@ -438,8 +438,10 @@ void vlynq_set_local_mapping(struct vlynq_device *dev, u32 tx_offset,
 
        vlynq_reg_write(dev->local->tx_offset, tx_offset);
        for (i = 0; i < 4; i++) {
-               vlynq_reg_write(dev->local->rx_mapping[i].offset, mapping[i].offset);
-               vlynq_reg_write(dev->local->rx_mapping[i].size, mapping[i].size);
+               vlynq_reg_write(dev->local->rx_mapping[i].offset,
+                                                       mapping[i].offset);
+               vlynq_reg_write(dev->local->rx_mapping[i].size,
+                                                       mapping[i].size);
        }
 }
 
@@ -450,8 +452,10 @@ void vlynq_set_remote_mapping(struct vlynq_device *dev, u32 tx_offset,
 
        vlynq_reg_write(dev->remote->tx_offset, tx_offset);
        for (i = 0; i < 4; i++) {
-               vlynq_reg_write(dev->remote->rx_mapping[i].offset, mapping[i].offset);
-               vlynq_reg_write(dev->remote->rx_mapping[i].size, mapping[i].size);
+               vlynq_reg_write(dev->remote->rx_mapping[i].offset,
+                                                       mapping[i].offset);
+               vlynq_reg_write(dev->remote->rx_mapping[i].size,
+                                                       mapping[i].size);
        }
 }
 
index c0ee897e22b2493b0bdae091bb77bbd2d119e6fa..d3cd7d96cc71efe68bf7da23b11b23522fc1e190 100644 (file)
@@ -1,18 +1,18 @@
 /*
  * linux/drivers/char/ar7_gpio.c
- * 
+ *
  * Copyright (C) 2007 OpenWrt.org
- * 
+ *
  * This program is free software; you can redistribute it and/or modify
  * it under the terms of the GNU General Public License as published by
  * the Free Software Foundation; either version 2 of the License, or
  * (at your option) any later version.
- * 
+ *
  * This program is distributed in the hope that it will be useful,
  * but WITHOUT ANY WARRANTY; without even the implied warranty of
  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
  * GNU General Public License for more details.
- * 
+ *
  * You should have received a copy of the GNU General Public License
  * along with this program; if not, write to the Free Software
  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
index 889306188c9451d89feb32ee99e91e6853ed5881..2acbd941d5972ae89842df60084f0c7bb22ccf57 100644 (file)
@@ -1,6 +1,6 @@
 /*
  * linux/drivers/char/ar7_wdt.c
- * 
+ *
  * Copyright (C) 2007 OpenWrt.org
  * Copyright (c) 2005 Enrik Berkhan <Enrik.Berkhan@akk.org>
  *
  * it under the terms of the GNU General Public License as published by
  * the Free Software Foundation; either version 2 of the License, or
  * (at your option) any later version.
- * 
+ *
  * This program is distributed in the hope that it will be useful,
  * but WITHOUT ANY WARRANTY; without even the implied warranty of
  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
  * GNU General Public License for more details.
- * 
+ *
  * You should have received a copy of the GNU General Public License
  * along with this program; if not, write to the Free Software
  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
@@ -55,8 +55,8 @@ static int nowayout = WATCHDOG_NOWAYOUT;
 module_param(nowayout, int, 0);
 MODULE_PARM_DESC(nowayout, "Disable watchdog shutdown on close");
 
-#define READ_REG(x) readl((void __iomem*)&(x))
-#define WRITE_REG(x,v) writel((v), (void __iomem*)&(x))
+#define READ_REG(x) readl((void __iomem *)&(x))
+#define WRITE_REG(x, v) writel((v), (void __iomem *)&(x))
 
 struct ar7_wdt {
        u32 kick_lock;
index 809a4d44442c184db2cac900b381ce880bf72a8f..fb137c9221e362d69b211ab7d36043e56df951b0 100644 (file)
@@ -1,18 +1,18 @@
 /*
  * linux/drivers/leds/leds-ar7.c
- * 
+ *
  * Copyright (C) 2007 OpenWrt.org
- * 
+ *
  * This program is free software; you can redistribute it and/or modify
  * it under the terms of the GNU General Public License as published by
  * the Free Software Foundation; either version 2 of the License, or
  * (at your option) any later version.
- * 
+ *
  * This program is distributed in the hope that it will be useful,
  * but WITHOUT ANY WARRANTY; without even the implied warranty of
  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
  * GNU General Public License for more details.
- * 
+ *
  * You should have received a copy of the GNU General Public License
  * along with this program; if not, write to the Free Software
  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
index aa2508f90ddbd14573899792eda7a6790eed8a60..775041d7d65fac8c6895a3a971a4f8eadc0df02b 100644 (file)
@@ -1,16 +1,16 @@
 /*
  * Copyright (C) 2007 Eugene Konev <ejka@openwrt.org>
- * 
+ *
  * This program is free software; you can redistribute it and/or modify
  * it under the terms of the GNU General Public License as published by
  * the Free Software Foundation; either version 2 of the License, or
  * (at your option) any later version.
- * 
+ *
  * This program is distributed in the hope that it will be useful,
  * but WITHOUT ANY WARRANTY; without even the implied warranty of
  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
  * GNU General Public License for more details.
- * 
+ *
  * You should have received a copy of the GNU General Public License
  * along with this program; if not, write to the Free Software
  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
@@ -137,5 +137,6 @@ static int __init ar7_parser_init(void)
 module_init(ar7_parser_init);
 
 MODULE_LICENSE("GPL");
-MODULE_AUTHOR("Felix Fietkau <nbd@openwrt.org>, Eugene Konev <ejka@openwrt.org>");
+MODULE_AUTHOR( "Felix Fietkau <nbd@openwrt.org>, "
+               "Eugene Konev <ejka@openwrt.org>");
 MODULE_DESCRIPTION("MTD partitioning for TI AR7");
index 59d9c712fe416729493f7d556767e65821c9fa36..8086593557a8cafbfd3ec3b7419780ea3c832772 100644 (file)
@@ -20,8 +20,8 @@
 #define _ASM_MACH_MMZONE_H
 
 extern pg_data_t __node_data[];
-#define NODE_DATA(nid)         (&__node_data[nid])
-#define NODE_MEM_MAP(nid)      (NODE_DATA(nid)->node_mem_map)
-#define pa_to_nid(addr)                (((addr) >= ARCH_PFN_OFFSET << PAGE_SHIFT) ? 0 : -1)
+#define NODE_DATA(nid) (&__node_data[nid])
+#define NODE_MEM_MAP(nid) (NODE_DATA(nid)->node_mem_map)
+#define pa_to_nid(addr) (((addr) >= ARCH_PFN_OFFSET << PAGE_SHIFT) ? 0 : -1)
 
 #endif /* _ASM_MACH_MMZONE_H */
index b104067540c7774b9d6bfcc4bb982a29fc6be4f5..6edc353e926a87ef29bdc631483b4e83eea7f31c 100644 (file)
@@ -28,12 +28,13 @@ diff -Nru linux-2.6.19.2/drivers/mtd/Makefile linux-ar7/drivers/mtd/Makefile
 diff -Nru linux-2.6.19.2/drivers/mtd/maps/physmap.c linux-ar7/drivers/mtd/maps/physmap.c
 --- linux-2.6.19.2/drivers/mtd/maps/physmap.c  2006-12-12 02:32:53.000000000 +0700
 +++ linux-ar7/drivers/mtd/maps/physmap.c       2007-02-03 21:57:11.000000000 +0700
-@@ -74,7 +74,7 @@
+@@ -74,7 +74,8 @@
  
  static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
  #ifdef CONFIG_MTD_PARTITIONS
 -static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
-+static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "ar7part", NULL };
++static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
++                                      "ar7part", NULL };
  #endif
  
  static int physmap_flash_probe(struct platform_device *dev)
index 9292a4cefc602d1686e11169544e72a9c4e80d9c..c6bd3a77845d37f44b830b95f40f181304a5df97 100644 (file)
@@ -38,13 +38,14 @@ diff -urN linux-2.6.22.orig/include/linux/serial_core.h linux-2.6.22/include/lin
 diff -urN linux-2.6.22.orig/include/linux/serialP.h linux-2.6.22/include/linux/serialP.h
 --- linux-2.6.22.orig/include/linux/serialP.h  2007-07-09 01:32:17.000000000 +0200
 +++ linux-2.6.22/include/linux/serialP.h       2007-07-11 03:08:57.000000000 +0200
-@@ -135,6 +135,9 @@
+@@ -135,6 +135,10 @@
   * the interrupt line _up_ instead of down, so if we register the IRQ
   * while the UART is in that state, we die in an IRQ storm. */
  #define ALPHA_KLUDGE_MCR (UART_MCR_OUT2)
 +#elif defined(CONFIG_AR7)
 +/* This is how it is set up by bootloader... */
-+#define ALPHA_KLUDGE_MCR  (UART_MCR_OUT2 | UART_MCR_OUT1 | UART_MCR_RTS | UART_MCR_DTR)
++#define ALPHA_KLUDGE_MCR (UART_MCR_OUT2 | UART_MCR_OUT1 \
++                      | UART_MCR_RTS | UART_MCR_DTR)
  #else
  #define ALPHA_KLUDGE_MCR 0
  #endif